Kodi Community Forum

Full Version: YouTube
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
The discussion of what is happening behind the scenes as far as code fixes to this problem continues in recent posts here: https://github.com/anxdpanic/plugin.vide...-939156545

If there are more people here with the required technical ability then you may want to assist there if possible Nod
1st Post - go easy!

Buffering...

Just another datapoint, in case it may assist someone who can fix this..

I was getting this problem only occasionally previously, so when it did occur I'd usually reboot the Minix ARM box as a workaround - for a sometimes fix.

However, just lately, nothing seems to work.

I also get the 'source to slow for continuous download' message.

Youtube addon V6.8.17. All tests via an ethernet connection. No VPN.

What I've tried so far:

1. 2 different Kodi installs;
#1 Minix ARM box running Coreelec 9.2.8, Kodi 18.9
#2 x64 NUC (i5/16GB RAM/256GB SSD) Libreelec 9.2.6 (Kernel 5.1.16), Kodi 18.9; both exhibit the same buffering issues.
2. Different Ethernet/Network outlet; (My home Network is fine, tested that as well, no other complaints from other users - just Y/T on Kodi)
3. Tried during different times during the day and night (in case my ISP is experiencing congestion/local problems)
4. Checked for any updates – none available.

Finally, I have tried streaming other live channels, and can report no problems at all with either device.

I still have not upgraded to V19.1 as yet, I think I read issues with python libraries and addons.

Thank-you.

PS. Happy to Post logs if that helps.
I'll try to go easy, but per previous posts:

- Your YouTube addon is not the latest 'Alpha' version
- Your Kodi version is out of date
- Your LibreElec version is out of date
- Not sure about the CoreElec version (I thought it wasn't even properly developed/supported anymore?)
- Because of the above I guess InputStream Adaptive will not be the latest version either

You also don't state if you have MPEG-DASH Enabled or Disabled or what Video Resolution you have chosen.

Yes, Google is making life difficult for us at the moment. But having totally a totally out of date and/or poorly configured Kodi setup may not be helpful either...

Please don't take my post personally @sprocketoctopus - it's really meant as an example that it is very difficult to compare like with like with so many variations in individual setups, especially out of date setups.

I previously posted my totally up to date system as an example of what is working well for me, and in order that other users can also maybe try that if they are having issues.

Hope it helps Nod
Hey,

please allow me to add my 2 cents. I love the YT addon and use it extensively every day, so I guess I'm just as sad /pissed. I'm using 19.1.0 and upgraded to 6.8.18~alpha1+matrix.1 today. Using my own API keys which are linked to my personal google account, which I also use with YT in the browser.

The issues were getting worse on my side until about 2 days ago, when I switched to a paid YT account. Normally 3 or 4 restarts of the same video would do, but at that time even 10 restarts would not do it and skipping between streams would not help either. OTOH any video runs wihout issue in the browser. My impression is that my ISP and google infrastructure are not the problem. Hence my motivation.

My API keys were then associated with a "ad-free" YT account, and at first nothing changed. One day later though things were about back to normal. At least that is my impression. Only 2 out of perhaps 10 streams I watched today experienced outages. After switching to 6.8.18 alpha 1 even the ones with outages played normally. 

I really cant be sure about a connection between thottling and a paid account. All I can say is that my subjective experience is very different since I changed that.

I will stay with 6.8.18 alpha, keep observing for the rest of the trial period and then revert to free, lets see what happens.
(2021-10-09, 11:27)splatterpop Wrote: [ -> ]The issues were getting worse on my side until about 2 days ago, when I switched to a paid YT account.

I really cant be sure about a connection between thottling and a paid account. All I can say is that my subjective experience is very different since I changed that.

I will stay with 6.8.18 alpha, keep observing for the rest of the trial period and then revert to free, lets see what happens.
I just started a Youtube premium free trial so i'll see how/if that affects things & report back.
I was having this issue and I've seemed to resolve it by changing my "Video Quality" inside MPEG-DASH to a fixed 1080p away from adaptive.
An Alpha 2 version containing a further fix to the 'rate bypass' (buffering) just went up on GitHub:

https://github.com/anxdpanic/plugin.vide.../6.x.x-dev

6.x.x-dev
@github-actions github-actions released this 13 minutes ago

[fix] Fix to_str |contrib: RNavega|
[fix] Fix ratebypass |contrib: RNavega|
[lang] translation updates from Weblate

Download the appropriate file from the GitHub link above and use Kodi's 'Install from Zip' feature to try this version.

It's working even better than Alpha 1 from my testing so far.

Hope this helps Nod
10 hours ago, every video I tried was unwatchable, and now everything works. I did not change anything, really bizarre...

My setup is:

CoreELEC 19.2.0
YouTube addon 6.8.18 alpha 1 unofficial
InputStream Adaptive 19.0.0.1
Amlogic S905X with 2 GB RAM
Ethernet connection with 450 Mbit Internet
I... made a compromise and enabled mpeg-dash and so far more videos are playable. The ones from jerryrig at least play with zero issues!
6.8.18a1 on kodi 18.9, I am now updating it to 6.8.18a2.
(2021-10-10, 04:55)jmh2002 Wrote: [ -> ]An Alpha 2 version containing a further fix to the 'rate bypass' (buffering) just went up on GitHub:

https://github.com/anxdpanic/plugin.vide.../6.x.x-dev

6.x.x-dev
@github-actions github-actions released this 13 minutes ago

[fix] Fix to_str |contrib: RNavega|
[fix] Fix ratebypass |contrib: RNavega|
[lang] translation updates from Weblate

Download the appropriate file from the GitHub link above and use Kodi's 'Install from Zip' feature to try this version.

It's working even better than Alpha 1 from my testing so far.

Hope this helps Nod

So... which of the 6 files is the right one to download? Last time I ended up downloading all of them and just trying one-by-one... how do we know which is the right one?

Thanks
Not the 2 that have source in their names, and for the the remaining 4, please read what I wrote in this post
https://forum.kodi.tv/showthread.php?tid...pid3063499
(2021-10-10, 11:06)jim_p Wrote: [ -> ]Not the 2 that have source in their names, and for the the remaining 4, please read what I wrote in this post
https://forum.kodi.tv/showthread.php?tid...pid3063499

Gotcha.... ignore the 2 source ones, don't bother with the 2 unofficial ones because don't matter, then of the 2 left the "matrix" is for v19+ and the remaining is for below v19
(2021-10-09, 19:38)Morgyn Wrote: [ -> ]I was having this issue and I've seemed to resolve it by changing my "Video Quality" inside MPEG-DASH to a fixed 1080p away from adaptive.

I also tried 360p for awhile using "ask for quality" and the problem got better, did not resolve though. BTW changing to 360p permanently in the settings had no effect, still played 1080p.

Day #2 with no problems here, everything plays fine at HD, with input stream set to standard.
(2021-10-10, 04:55)jmh2002 Wrote: [ -> ]An Alpha 2 version containing a further fix to the 'rate bypass' (buffering) just went up on GitHub:

https://github.com/anxdpanic/plugin.vide.../6.x.x-dev

6.x.x-dev
@github-actions github-actions released this 13 minutes ago

[fix] Fix to_str |contrib: RNavega|
[fix] Fix ratebypass |contrib: RNavega|
[lang] translation updates from Weblate

Download the appropriate file from the GitHub link above and use Kodi's 'Install from Zip' feature to try this version.

It's working even better than Alpha 1 from my testing so far.

Hope this helps Nod
I have a possibly OT question (but related to this addons).

Instead the panicked repo it's no updated whit this dev release........... it's possible, in some mode, to add this Github source directly on KODI source to install this alpha2 whitout need to download the zip from pc and install manually on my kodi setup ?
In general, no. Github must offer a directory listing for what you want to add in (and via) kodi's file manager, and github simply does not do that.