Kodi Community Forum

Full Version: YouTube
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2022-01-08, 20:00)giaur Wrote: [ -> ]Are you sure that's not network issue?

I wouldn't think so, from my two example videos, according to the player process info menu (press o) the LinusTechTips videos stream is 3840x1920p, 29.970fps, while the twocents video is 1920x1080p, 23.976fps. I've never seen an audio drop on the LinusTechTips one despite playing through it a few times, meanwhile the twocents one obviously has regular issues. If it was network related, I'd expect the 4k one to have more trouble than the 1080p one.

Also, if it was a networking issue, I'd expect the video to be paused and buffer, rather than continue video playback with no audio.
its kinda offtopic.. but its feasable to make a newpipe addon for kodi.. new pipe is a opensource youtube cliente that does not use google APIs in any way... if you want you cant export your subscriptions using google take out.. but you do not have to login at all or use api keys and etc..

i think it whould be perfect for basic youtube waching on kodi.. if you send a link to kodi etc.. without complex key and secret codes..  i think it whould be perfect for most users.. and if you need more interaction you can use the classic addon
Is there any way to get the cc auto translations working again?

It was possible on prior versions of the addon but it was something that seemed to vanish in the last release.

Was something I used fairly often so would be nice to find a way to get it working again.
(2022-01-11, 22:15)Steph09 Wrote: [ -> ]Is there any way to get the cc auto translations working again?

It was possible on prior versions of the addon but it was something that seemed to vanish in the last release.

Was something I used fairly often so would be nice to find a way to get it working again.
+1  Translate subtitles from Lang1(English is common) to Lang2, but only if native subtitles for Lang2 isn't available!
Just wanted to say THANKS for your amazing work !
This is veeerryyyyy appreciated.
I face brief audio dropouts as well on my Kodi box.

This only happens while playing 4K Youtube content. The audio cuts out for a fraction of a second, long enough to miss a word during a conversation. The video does not stutter or cut out during this.

My device is Odroid N2 connected to a Yamaha AVR, which connects to a Sony LED. Kodi version is Core Elec 19.4-Matrix_rc2.
N2 is wired to gigabit switch. I can stream local 4K content fine, and face no audio dropouts.

Is there a fix for this issue ?
I have just installed the latest version from Kodi repo., API’s entered etc, but when i authorize the device via Google , after i enter the first generated code i get this error  'LoginException: [401] invalid_client Invalid Client Type', the same as another poster on this thread. Installed on a recently reset PC with no VPN connected. Is this a known error?, is there maybe a Github version i should install instead?
I experience audio drop outs as well.

I use a Vero 4k+ and the audio drops out for a half a second every 49 seconds - on all resolutions. It does not drop out if I play the audio only on the same file

EDIT: This issue went away when I took 25, 29.94 and 30 frames per second out of the whitelist.

Edit again: This issue went away when I changed a setting to not change the resolution and framerate to match the video.
I've noticed that I was no longer logged in.  On retrying to connect with my API keys I am getting a login error:

2022-01-24 10:15:56.742 T:21448   ERROR <general>: [plugin.video.youtube] Requesting device and user code failed: Code: |401| JSON: |{'error': 'invalid_client', 'error_description': 'Only clients of type 'TVs and Limited Input devices' can use the OAuth 2.0 flow for TV and Limited-Input Device Applications. Please create and use an appropriate client.', 'error_uri': 'https://developers.google.com/identity/protocols/oauth2/limited-input-device#creatingcred'}|
2022-01-24 10:15:56.764 T:21448   ERROR <general>: [plugin.video.youtube] LoginException: [401] invalid_client: Only clients of type 'TVs and Limited Input devices' can use the OAuth 2.0 flow for TV and Limited-Input Device Applications. Please create and use an appropriate client.

Has anyone else got this happening and found a way past it?
@jeffski10 - read back a few pages in the thread - looks like Google messed around again.

You'll need to recreate new keys (using the new client class), then things work again.
Hi

I can't login at the Youtube plugin. Get error "invalid client" and "wrong client id". 
API key, id and secret is typed in correct. I have created them new, client also with this limited access.
But every time I do the OAuth login, this error occures. After that, I look at the ID and see, it's cutted. The ending part ".apps.googleusercontent.com" is missing. Yeah, funny, then I understand the error message. But why was the client id cutted?
I have 2 identical Intel NUC's running Libreelec 10.0.1 - today 1 NUC was logged out of YouTube and the other was not. I have not yet attempted to log back in. Both NUC's are using the same API keys. I'm crossing my fingers that I don't have to create new API Keys. I'm getting too old for that stuff ☺

Edit: I tried to log in again 3 times and got the error message others have gotten. I wonder why my other NUC is still working. 

Is there a complete, easy to follow guide for making new API Keys (that seniors can follow) ?
So... My subscriptions is blank again now.
I've been using unofficial-6.8.18+matrix.1 and it has been working great until now.

I have tried log out/in and even created new API keys etc but it makes no difference.

I have Rpi3 and running Libreelec 11
Whenever I open a channel subscription, the max list of videos (items) per page is limited to 50. I have tried editing the "settings" files to increase that relevant "id" with no success.

Does anyone know how to display 100 items per page? It will come especially handy when browsing channels who have hundreds of videos.

Thanks.
OK - So I logged into the Google Cloud Platform page and see my existing API Key and OAuth 2.0 Client ID listed. Do I create another OAuth 2.0 Client ID or delete the existing one and create a new one ? One of my Intel NUC's is still working with my current API Keys but my other NUC and 2 windows 10 desktops all logged out and get the error message when trying to log back in.

- I'm guessing I can use my old API Key, right ?
- Can I have (2) OAuth 2.0 Client IDs using the same API Key ?
- What is the "new client class" others have mentioned ?