Kodi Community Forum

Full Version: YouTube
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Is it possible to restrict this addon to let my kid access only a few channels or block some channels that he should not get access to?

You could use the YouTube Channels addon https://forum.kodi.tv/showthread.php?tid=45246 then you can add certain channels for your kid to access.
what does it mean :
disable/enable YouTube Settings - MPEG-DASH...??
pls i pray you to try to explain it to me as you were talking to a little child with no skills at all..
Choosing MPEG-DASH in YouTube:
  • Choose Addons on the sidebar.
  • Right-click on the YouTube add-on (or if you're on a TV, select the YouTube add-on then press the option button).
  • When the context menu appears, choose Settings.
  • Then choose MPEG-DASH on the sidebar and toggle the switch for "Use MPEG-DASH".

If it's disabled, you'll probably need to install InputStream Adaptive or InputStream Helper:
  • Settings > Add-ons > Search
  • Enter InputStream
Then the following add-ons should appear in the list, click on/choose each one and choose the Install button:
  • Script - InputStream Helper
  • VideoPlayer InputStream - InputStream Adaptive
There may be further things you need to do depending on your Kodi install (e.g. OSMC or LibreElec may need a script running from the command line as well).
hi first many thxs for yr kind and clear reply!

but in simple word what does it really mean if:
it's disabled, and if it is enabled ?
i mean i'd like to kwnow what happens in case it is disabled or enabled...
pls i pray you to try to explain it to me as you were talking to a little child with no skills at all..
cheers

ps: i've already the two you indicated, installed, :
InputStream Adaptive and  InputStream Helper
plus also InputStream FFmpeg Direct installed too
i mean i've these 3 all installed in my kodi 19.1 portable vers.
It's a different way of streaming that automatically changes the bitrate if the available bandwidth changes and allows for higher resolutions. Also I think subtitles are only available with MPEG-DASH, perhaps someone can clarify if this is not the case.

More info a few pages back:

https://forum.kodi.tv/showthread.php?tid...pid3066889
hi, first thxs so much for yr attention:

so in very easy and simple word what happens if the MPEG-DASH is disabled?
cause the post you link is very detailed for it when is enabled..
but , i repeat i pray to describe in simple words cause i'm so ignorant and very very few skilled..,
i pray you to simply describe what happens when that setting of mpeg-dash is -disabled-

thxs so much indeed again for yr kind helping and patience too...
cheers
Well, basically the opposite. Fixed bitrate all the way through playback, lower resolutions (up to 720p on demand/1080p live), and no subtitles... If someone could confirm the no subtitles bit that would be helpful.
(2022-02-21, 10:16)Anonnymouse Wrote: [ -> ]Well, basically the opposite. Fixed bitrate all the way through playback, lower resolutions (up to 720p on demand/1080p live), and no subtitles... If someone could confirm the no subtitles bit that would be helpful.

thxs so much indeed!
you have been very clear and simple,
thxs again for yr kind helping
and patience too...
cheers
(2022-02-16, 00:12)Doktor-X Wrote: [ -> ]this video may be inappropriate for some users, this is new error that i get when i send link to coreelec using kore with yatse i dont get anything, no error no video.
It's because it's a age restricted video, example: https://www.youtube.com/watch?v=9tdzEFOClbw
Even though I'm logged into a profile where the "Restricted mode" has been turned off, these videos still wont play in kodi.
In the browser they work fine.
If this could be fixed it would be awesome.
(2022-02-22, 22:34)dobbelina Wrote: [ -> ]
(2022-02-16, 00:12)Doktor-X Wrote: [ -> ]this video may be inappropriate for some users, this is new error that i get when i send link to coreelec using kore with yatse i dont get anything, no error no video.
It's because it's a age restricted video, example: https://www.youtube.com/watch?v=9tdzEFOClbw
Even though I'm logged into a profile where the "Restricted mode" has been turned off, these videos still wont play in kodi.
In the browser they work fine.
If this could be fixed it would be awesome.

I had this issue for a long time, but finally a couple of weeks ago, I found a solution.

First of, age verify your Google account (credit card verification).

Follow the normal guide with API keys etc.

Log on with the YouTube addon.

First verification, choose your Google account. (this is what makes the difference, as it then gets the age verification)

Second verification, choose your YouTube account. 

Worked for me, on my two Kodi devices Smile
I'm using Yatse to cast Youtube videos from my Android Youtube app to Kodi on my raspberry pi. Lately I've noticed that every video needs to buffer excessively. If I navigate to the video via the Youtube plugin, there are no issues. Does anyone have an inkling on where the issue is?
Anyone experienced with "My Subscriptions" shown all empty?
Let me start out by saying my apologies if this has been answered but I looked on github and this forum and no one seems to have mentioned this lately.
My subscriptions are blank but my playlists and subscribers are available. I have seen where this has happened to others quite a while ago, and they created new api keys.
Ugh. I was lucky to have created my keys quite a while ago, but if I must I must. I would just like someone to confirm this is the solution to the no subscription issue.
Thanks in advance
(2022-02-27, 07:28)samsonluk Wrote: [ -> ]Anyone experienced with "My Subscriptions" shown all empty?

Yep, same here.
Here too...
(2022-02-27, 07:28)samsonluk Wrote: [ -> ]Anyone experienced with "My Subscriptions" shown all empty?
 
(2022-02-27, 07:33)Sobersally Wrote: [ -> ]Let me start out by saying my apologies if this has been answered but I looked on github and this forum and no one seems to have mentioned this lately.
My subscriptions are blank but my playlists and subscribers are available. I have seen where this has happened to others quite a while ago, and they created new api keys.
Ugh. I was lucky to have created my keys quite a while ago, but if I must I must. I would just like someone to confirm this is the solution to the no subscription issue.
Thanks in advance

(2022-02-27, 09:39)C.O.D. Wrote: [ -> ]Here too...



We all are experiencing it. I created a github issue. I suggest referring further developments.