Kodi Community Forum

Full Version: [RELEASE] Launcher - application launcher plugin for Linux, Mac, Windows, and Xbox
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
without looking at your code, let me suggest that instead of using "%s/%s" or "%s\%s" you should use os.path.join(%s,%s) if you aren't already.

Like I said I haven't looked at the code so forgive me if I'm just talking out of my ass here and that doesn't apply to you.
So no it is only missing Mac OS X support?
...any Mac python gurus out there? Huh
I was looking at parts of the Apple Movie Trailer script and there and several routines in there that check for Mac, Linux, Xbox, and Windows.

Some code could probably be borrowed from there to get it working on a Mac. I don't have a Mac so don't look at me :p

@leo, I'd love to test the script out once you got it together.
The support on xbox has been fixed as described above.
I'll be happy if you'll try it.


This version has been tested with xbmc atlantis beta for windows & linux.

but tested only with windows & linux. I don't xbox, sorry.
rwparris2 Wrote:without looking at your code, let me suggest that instead of using "%s/%s" or "%s\%s" you should use os.path.join(%s,%s) if you aren't already.

Like I said I haven't looked at the code so forgive me if I'm just talking out of my ass here and that doesn't apply to you.

you right. I'll fix it in the next release. (if it will be...)
Hey Leo2,

I've been out of town for the last couple days and I just got back. I downloaded your revisions and just uploaded them straight over the old files.

Everything seemed to continue to work fine so I removed the current emulator that I had installed through the Launcher and added a new item to the Launcher.
  1. It recognized my system as an xbox and displayed .xbe files Smile
  2. After I added my zsnexbox emulator and it's ROM path it seemed to fire up the first game I tested "Demolition Man".
I tried to change the thumbnail for the emulator, and the Yahoo! search came up. Certain images would only initiate the Launcher dialog window when I selected them, and after a few seconds the dialog would dissapear leaving me at the Yahoo! image search with 10 thumbnails to choose from still. I would press back and refresh the directory, but no change. This is new behavior that I didn't experience before your revision.

Other images would save properly and kick me out to the main Launcher window, but after refreshing the directory would show no thumbnail at all. I noticed this happening with the old version of the script also. I'm thinking it might have something to do with the file names of thumbnails that Yahoo! finds because it doesn't seem to matter if they are .png or .jpg some simply work and others don't. It might be a cache issue with the xbox. Maybe related to the size of the image it's saving from Yahoo!?

After messing with the thumbnails for a bit, I tried to launch a different ROM, the "7th Saga" and this time my xbox just locked up. I rebooted and tried again and the same thing happened. I know for sure that this is a working ROM.

Sorry I haven't diagnosed these problems a little better, this is sort of just a first impression. I will play with it a little more this weekend and try and determine the cause of the problems a little more definitely.

Good job with the script so far!
Thanks for your testing and the feedback.
I notice the problem with the images , but didn't successes to understand when it happens.
I will be looking forward your detailed diagnostic in order to fix the other problems.
Does this work with the latest version of XBMC? I couldn't get it to work. It just wants to browse the folder.
Hi -

This is a much needed plugin for me - I really need to be able to launch my TV client (Beyond TV Link) from XBMC somehow, and this final integration step is all that I need to retire my MediaPortal configuration.

I am using Launcher 1.01 beta on XBMC for Windows (Atlantis) Beta 1. The TV client is launched like this:

EXE Path:

C:\Program Files\SnapStream Media\Beyond TV Link\BTVD3DShell.exe

Command Line Arguments:

/networkclient:DVR /networkclientuser:user /networkclientpassword:pw

The app always starts in FS, and as it receives focus, overlays anything 'behind' it.

OK, so I setup Launcher as per instructions, added the program, and named it 'Watch TV'. The 'Wait for Application' setting is set to True. (It doesn't work if I disable this option).

The first time I select the option, BeyondTV executes, works fine, but then when I exit the program, the first time (only) XBMC window restores itself to full screen, but no keyboard input is recognized. It's as if focus is elsewhere. Pressing 'Alt-Tab' once brings focus back to XBMC, and keyboard input is recognized again.

The second time I select the option, BeyondTV executes, works fine, but when I exit the program, now XBMC does not restore itself to full screen at all. Basically, I just see the Windows desktop (XBMC is running, but minimized). By pressing 'Alt-Tab', XBMC restores itself to fullscreen and XBMC has focus again.

Therefore, the logic that (WISo?) put in there that watches for the child app to complete and then restore XBMC window/focus doesn't seem to be completely working.

Here is the log for the session I described above:


Any help would be greatly appreciated - thanks!

Quote:Does this work with the latest version of XBMC? I couldn't get it to work. It just wants to browse the folder.

I'm running
kernel version: 1.0.4034.1
XBMC pre-2.1 (compiled July 28, 2008)

And it's working for me. Could you be a little more specific with your problem. If you can only browse for a file to launch, but never select a file it might be because the file type you are trying to launch is being filtered.

On my xbox I had this problem with the ver. 1.0 of this script because it was treating the xbox as a windows platform and only showing ".exe" or ".bat" files instead of ".xbe". Make sure your using the newest version 1.01 and be aware that there are a few minor kinks being worked out.
Wait, I don't think I understand the install process.
Firstly. Do I need to copy (from the zip) the Launcher folder and rename it for every program I wanna launch? I tried to set one up, decided it was wrong (as it failed to work) and then when I deleted the source and tried to add a new one it kept taking me to a folder instead of asking me the next question it had before (the folder was titled same as the program i'd just tried to set up).

I am also getting a bit confused by the install instructions.

1. unzip the file into Plugins/Program directory. Should I rename it for every program?
2. (linux users only): create a symlink for /usr/lib/libcurl.so.4 named /usr/lib/libcurl.so (run: "sudo ln -sf /usr/lib/libcurl.so.4 /usr/lib/libcurl.so" in terminal) Windows
3. Run XBMC:
3.1. Switch to MC360 Skin (or some other skin that has "Programs" Section) Using Project Mayhem
3.2. Go to Games -> Applications -> Add Source -> Browse -> Program Plugins Programs is on main page
3.3. Select Launcher and Click "OK" I did this before and was asked to select 1 or 2 options, they were something like standalone program and file launcher (don't remember the words off-handHere's where the new problem begins. Instead of getting the 2 options I now get the screen linked below.
3.4. Click OK Again. At this point I was confused and on my own as now it started asking me to link the program to launch and associate file extensions.
3.5. Right Click on "Launcher" Icon
3.6. Choose "Add to Favorites"
3.7. Switch back to PMIII Skin.
3.8. Click on the Arrow in the bottom right corner
3.9. Choose "Launcher"
I went thru it all, it seemed to be working out despite the confusion. Finished. Clicked. A window comes up asking if it should import or search for files in the directory, i said 'no', nothing happens. Just backs out of the operation I guessed. I tried again, said 'yes', it scanned, said 0 files loaded and....I can't seem to remember what it did right there.
Point is that now I can't even try again cuz of whatever its showing below. I tried to copy over it. I tried to delete then re-copy it. It continues to be there in either case, so I'm stumped.


While I'm at it, I don't wanna start a new thread something so trivial; What the heck is this empty box for? The blue arrow opens it up but nothing's ever been there. Is that My Favorites list?
Ok, I may have caused the problem myself. I keep forgetting that it's not windows and (at least in Project Mayhem) Anything that you mouse over becomes highlighted and is what you will be selecting when you hit ok. But I still am having some trouble figuring it out. I see I don't need multiple folders renamed (didn't seem right anyways) but I wonder, do I have to set up Launcher repeatedly (so it appears many times in the programs folder as a source) or can i set it once and add multiple programs inside it after I select the Launcher Source? It seems like the latter should be true but I couldn't seem to get it to do that. I keep trying for that one. That's not that big an issue.
My big issue is setting up my emulator. I select my executable, I need no parameters, it asks for the 'files path' which i assume is my ROMs. When it says 'set the file extension I hit another roadblock. What is my format here? I put 'gba' and it loaded 4 of about 1k, but '*.gba' loads nothing. Do I need to go thru and rename all my GBA files cuz at a thousand game files I think I can just use the file browser in VBA and launch this as an executable.
oh my god, its cApS sEnSiTiVe isn't it?
oh my god, its cApS sEnSiTiVe!!
Well, I still get an error tho when I try to run a game. VBA opens then returns an error window with "Unsupported file type X:\Emulators\GBA"
I realized that my folder is names "GBA ROMS" so it must be confused by the space. I changed it to "GBA_ROMS" and got the error again, but this time it was in the file's name. So apparently the LAUNCHER can't handle spaces. I gotta tell you, it's hard to conceive editing so many ROMs. This doesn't even include my NES, SNES and Sega emus.
I would love to see some thumbs support in this script, but I think it's a long way off. Sorry for the confusion with the earlier posts.
PS; what is the format for multiple extensions? GBA, VBA or GBA; VBA or Do I only get one at a time?