Kodi Community Forum

Full Version: [RELEASE] Launcher - application launcher plugin for Linux, Mac, Windows, and Xbox
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Have anybody been successful with running Spotify under Wine on Ubuntu?
Anyone using this to run applications in appletv land? (besides emu's)
I'm having troubles playing emulators with my Game Controller.

Running XbmcLive 9.04 with Xbox 360 Wireless Controller (running on xboxdrv). I'm using the controller in my XBMC UI.

I'm launching mame with the following command:
Quote:xmame -gm -skip_gameinfo -jdev /dev/input/js0 -jt 1 -rp /home/xbmc/Games/Mame/Roms/ -video-mode 1 -fullscreen $1

When the warning screen (press OK to continue) shows I am unable to continue with either the gamepad or keyboard. When I move my D-pad I can hear my XBMC moving the selection.

What am I doing wrong?
Hi, firstly thanks so far so good. I'm running MAME with this fine on Win 7 RC using transparency skin.

I have one problem and it seems random. When I try to add thumb for a game, yahoo finds thumbs, some a bit random, I'll pick one it will say saving but then Nothing? Its just blank. The reason I say this is random is because in other occasions with diff games it works fine?

Any ideas?
Is there a way I can manually add thumbs if I find a better pic? I'm a novice
Any help will be appreciated.

I am trying to use the launcher with BTV and it works fine IF BTV is not set to come up full screen. It appears that XBMC isn't minimizing corrrectly when launching full screen BTV.

I read some earlier comments in this thread that seemed to indicate that launching another app full screen wasn't supported. Is this correct, or I am missing something? Any help would be appreciated.
is there any way to get emulator-specific fanart working? i.e. select your zSNES folder, and a SNES fanart backdrop is visible behind the games list?
arosequi Wrote:Using Launcher 1.02 on Ubuntu 9.04 (Aeon skin), I have no way to change the "Sort By" for my programs or files. It's stuck on "Sort By: Date", which is awful when trying to find a specific game. Any advice?

P.S. I see this same behavior when using PM3.HD.

I have this problem as well, no matter which skin I'm using. It makes it nearly impossible to find entries, since a few of my categories have thousands of entries. The contents of my .xml file are oddly ordered as well.
im using MediaStream.Redux.Mod & sort is disabled (+ set on date).
at this point we've established this is not skin specific...

Some time back (3-4 months ago) i could sort in alpha order.
... so some-thing's changed. what ? do we need to report a bug ?
I'm having the same problem as DavidCru. Mame seems to not get the focus, so any key press is directed to xbmc. When I use the "\" key I can play the game, but after leaving mame xbmc stays in the upper left corner and no key press is directed to it.
f4ion1 Wrote:I use and constantly bounce between XBMC, Boxee, & Hulu Desktop on my XP HTPC. I'd really like to get Launcher working so I can just keep XBMC open all the time and launch Boxee or Hulu Desktop from XBMC then return to XBMC once I close it out. Currently I'm using a wireless keyboard to launch whichever app I use & use the built in IR receiver in each app to recognize my remote. I setup HuluDesktop and it worked great from Launcher. But when I create a launcher shortcut to the Boxee EXE it crashes(boxee.exe). Anybody know why this is. I tried running the exe manually and it opens fine. I even opened them both(XBMC & Boxee) at the same time to make sure there isn't a conflict and they ran fine.

Same thing happens to me, get some error about a 'skin'. Anyone else get this to work?
KingCrab Wrote:I'm having the same problem as DavidCru. Mame seems to not get the focus, so any key press is directed to xbmc. When I use the "\" key I can play the game, but after leaving mame xbmc stays in the upper left corner and no key press is directed to it.

i created a bash script with 3 lines
this is the http api command to toggle FullScreen (like hitting "\")
otherwise all my EMUs load behind XBMC

curl "http://localhost:8080/xbmcCmds/xbmcHttp?command=Action(199)"
curl "http://localhost:8080/xbmcCmds/xbmcHttp?command=Action(199)"
then in launcher.xml, call the script as application & the real app as switch 1 ...
<args>mednafen -nes.stretch 1 -nes.input.port1 gamepad  -nes.special scale4x -nes.pixshader scale4x -vdriver sdl -fs 1 -nes.xres 1920 -nes.yres 1080 </args>
since the games library doesn't seem to be coming any time soon...is there any way to easily rename a bunch of ROMs...via an emu application, etc?

and i'm also getting the sorting bug (stuck sorting by Date) described on the previous page after adding a thumbnail to a game...
I am currently launching Maximus Arcade through the plugin.. And, while it does work, it seems to be "polling" very frequently on the window whether it is active or not... and thus, when I have a video preview of a game, it *may* stutter the background music within Maximus Arcade.

I do not have this issue on the machine if i run XBMC/Maximus Arcade on their own... I do have the issue if i run it through the plugin however... (hence why I assume its the polling issue)

Is it somehow possible to NOT have the plugin check the window state? I.e, Leave XBMC running fullscreen in the background and i have Maximus Arcade create its own window ontop?

Help would be very much appreciated!
ArtVandelae how do i apply your .patch file for "Patch to set the working directory in CWIN32Util::XBMCShellExecute"
I'm having trouble running mednafen (NES) to run fullscreen through this plugin (Ubuntu). With or without the "-fs 1" switch, XBMC goes to the background and mednafen is windowed.

Also, I'd like to find some way of gracefully quitting emulators without a keyboard, either from a remote or gamepad (Xbox 360 controller). I guess I could have a script hooked up to a button in irexec that that kills all the emulators.