Kodi Community Forum

Full Version: [RELEASE] Launcher - application launcher plugin for Linux, Mac, Windows, and Xbox
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Got my thumbnails to load up automatically, but it's an ugly hack. I changed this code on line #434 of launcher_plugin.py
romdata["thumb"] = ""
to this
romdata["thumb"] = 'E:\\Emulators\\zsnexbox\\artwork\\Shots 1\\' + romname + '.png'
Which because I have thumbnails for all of my ROMs, I basically hardcoded the path to those images once in this part of the script so I wouldn't have to write it 500 times by hand in Launchers.xml

It would be better if it would just grab the path that we've assigned from settings.xml and only write the path if the image exist in that location. That's probably the way you have it setup already, but I was getting blank thumbnails.
Quote:launcher does run as it is supposed to until it is time to launch something the launcher popup window opens and then closes then it does nothing.
Okay that sounds exactly like what was happening to me on the xbox. Take a look at your Launcher.xml and see what info it has for each <filename> entry.

For me, each <filename> entry for all of my ROMs had quotation marks around them like this:
<filename>"E:\Emulators\zsnexbox\roms\Secret Of Mana I.zip"</filename>
I removed the quotes like this
<filename>E:\Emulators\zsnexbox\roms\Secret Of Mana I.zip</filename>
and now all of the ROMs load up and play. See my post a couple messages up. This might work different on Windows, I'm only testing on xbox.

To anyone who is interested, I got Aeon Skin to execute Launcher reliably from the navbar. Instead of trying to link directly to Launcher, I have my "Arcade" button link to MyPrograms/Applications. I navigate to Launcher just once and then it remembers for everytime after that.

This probably wouldn't work if you had more applications that you were trying to link to from the home navbar. But with Launcher, who needs any other apps?

Here's the new code for Homescrollers.xml
<item id="3">
micster Wrote:I noticed that the individual Launcher items work, like the link for my zsnexbox emulator and it has no quotes within Launcher.xml but the individual ROMs fail to launch. Editing the following code seems to solve the problem.

Line #433 of launcher_plugin.py
romdata["filename"] = '"' + fullname + '"'
to this
romdata["filename"] = fullname
you right. fixed. now it's on svn.
micster Wrote:I understand if this problem is going to have to wait. Personally I already have all of the thumbnails and being able to manually set them in the .xml file is nice. I'm still having trouble getting the thumbnails to show up automatically. They are named the same as the ROMs with a .png extension. After putting them all in the thumbnail folder before I scan for ROMs, I now get blank/missing thumbnail images where as before I was getting the default icon for my skin.

If I edit Launchers.xml by hand and specify the path to the thumbnails within the <thumb> field (which are all blank to start with) then it shows up. Are the <thumb> fields inside Launchers.xml suppose to be blank? I'm currently investigating how to get them to write the paths like the <filename> field does.

I think I found the problem, fixed, now the automatic thumbnails are working under Windows too.
try the latest svn. (rev 14)
darxide Wrote:I am unable to get svn rev 12 to launch anything. I can use ver 1.01 to work fine. any ideas why?

can you explain more? maybe can you send the xbmc.log output?
micster, the AEON skin integration looks great.
did you connect the background image to the selected rom? if so, how?
Thanks Leo,
It was tricky getting Aeon to display all of the correct headings and images for each section. Unfortunately it doesn't change the background wallpaper art when you select a new ROM. It does do that for my movies though, so I suppose it would be possible to include a "fanart" image but I'm not too interested in this because I really like the default behavior.

I especially like the way that Aeon only displays one thumbnail at a time and it's really big with transparency along the edge. The problem is that it does not support wide thumbnails, so most of my boxart looks squished. I was planning on creating new thumbnails like I did for my "7th Saga" ROM in the example above with the original box art on top with an animated gif below so that the whole thumbnail is the proper aspect ratio. Alas, XBMC support for animated images or video thumbnails is kinda limited. It's still possible but rather time consuming.

Here is a little more info on how I have Aeon set up. I create a folder for each of my media categories (Arcade, Movies, Comics, Music, etc.) and only load it up with the images I want. Aeon by default will fade between whatever images it finds in that folder. It would probably be a little cooler if I only included background wallpapers of media I actually have, so when you go into my SNES Arcade you would only see giant images of Nintendo games like Zelda and Mario.

By the way thanks for adding those fixes into SVN. I will download the latest and give it a go when I get a chance.
Maybe it's a noob question, but,...
It's possible to use 2 instances of this plugin, one for apps, and the other one for games&emulation ?
how it can be done?
well in rev 14 it seems to be working great. I am assuming that it was the issue with the quotation marks.

Thanks for the great app and support.
khornerz Wrote:Maybe it's a noob question, but,...
It's possible to use 2 instances of this plugin, one for apps, and the other one for games&emulation ?
how it can be done?

correct me if I'm wrong.
yes is the short answer.

to do so have a copy of launcher in the plugins folder and copy it and rename it to whatever you want (eg. apps or launcher1).Then you should be good, as long as the launchers.xml file doesn't save in the same location.
khornerz Wrote:Maybe it's a noob question, but,...
It's possible to use 2 instances of this plugin, one for apps, and the other one for games&emulation ?
how it can be done?
I don't think so, because the launcher files and the settings file is stored in one place, so even if you'll create two instances there will be exactly the same.
but there may be a way - create two users in XBMC and switch between them as necessary, in that case i think each one of the users will have separated settings.
Unfortunately rev 14 is still not working for me, I can't launch roms with spaces in the name...
Quote:Unfortunately rev 14 is still not working for me, I can't launch roms with spaces in the name...
Hey elspero,
I noticed that darxide was also on windows and having an issue with the quotations effecting his ROMs from launching. I would try and remove the Launcher plugin entirely and all of the files it generated in your "UserData" folder, then reinstall the newest version.

If reinstalling the Launcher doesn't fix it, perhaps it has something to do with the way your emulator works and the ROMs it uses.

Try giving as much information about your setup and how it might be different from darxide's (whom seems to have it working).

Leo, Is there any way for you to add an option to put the between the executable path and the rom path? My sega Genisis emulator won't load roms because of that. The emu starts but the rom doesn't load.

It also does appear that elspero is correct too. (atleast in my case) with FCE it will load testme.nes fine but
test me.nes does not start the rom. the emu does open however.