Kodi Community Forum

Full Version: Not compatible with alpha 3
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

I have just installed Alpha3 on my android tv and cannot use IPTV SIMPLE CLIENT as Kodi says is not compatible when trying to activate this addon.

Regards
Marcin
Have you installed any available updates?
Updateds not available.
I have tried uninstall and install the addon again but still the same issue.
Unistalled and installed Kodi alpha 3 - problem solved.
(2020-11-03, 14:52)taksamo Wrote: [ -> ]Unistalled and installed Kodi alpha 3 - problem solved.

Unfortunately for me the problem remains. I installed KODI 19.0-ALPHA3 (18.9.730) on my PC with Fedora 33, I installed SIMPLEIPTV 6.3.0. When I try to activate the message appears saying that it is not compatible with the installed KODI version.
The correct iptvsimple version is 7.0.0 for the alpha3 build.
(2020-11-17, 10:14)phunkyfish Wrote: [ -> ]The correct iptvsimple version is 7.0.0 for the alpha3 build.
I just installed Kodi Matrix Beta.  I have iptvsimple 7.0.0.  

There are 3 dependancies that can't be met - Inputstream FFmpeg DIrect, inputstream.adaptive, and RTMP Input.

Its saying the addon is not compatible with this version of Kodi.
(2020-11-19, 20:09)mhodgson6 Wrote: [ -> ]
(2020-11-17, 10:14)phunkyfish Wrote: [ -> ]The correct iptvsimple version is 7.0.0 for the alpha3 build.
I just installed Kodi Matrix Beta.  I have iptvsimple 7.0.0.  

There are 3 dependancies that can't be met - Inputstream FFmpeg DIrect, inputstream.adaptive, and RTMP Input.

Its saying the addon is not compatible with this version of Kodi.
BUT I completely uninstalled, removed remnants, then re-installed and its working.  So all is good. THanks for your hard work.
Yes, I think there is an auto update issue we need to fix in beta.
inputstream.adaptive is currently broken in Beta (and latest nightly).
Requires a new version to be built against latest kodi api changes.
just need peak to do that.

2020-Nov-07 nightly works with current IA build in repo

@phunkyfish 
Could those dependencies be optional?
They aren't always required.
Just thinking about Mr X with a simple ffmpeg playlist wouldn't need them.
Less dependencies  = less breakage Smile
(2020-11-20, 07:47)matthuisman Wrote: [ -> ]inputstream.adaptive is currently broken in Beta (and latest nightly).
Requires a new version to be built against latest kodi api changes.
just need peak to do that.

2020-Nov-07 nightly works with current IA build in repo

@phunkyfish 
Could those dependencies be optional?
They aren't always required.
Just thinking about Mr X with a simple ffmpeg playlist wouldn't need them.
Less dependencies  = less breakage Smile

They are marked as optional in the addon.xml