Kodi Community Forum

Full Version: HBO Max
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
UPDATE: 0.0.9 just pushed
This fixes playback on non-android hardware.
Note: Max quality is 960x540
For L1 Android devices, you enable to enable "L1 Secure Device" in the add-on settings to allow the full quality

UPDATE:  0.1.0 just pushed
This adds Play Next Episode (default True) setting.
Also Play Next Recommend Movie (default False) setting

UPDATE: 0.1.1 just pushed
This adds support for Franchises (eg. Last Week Tonight with John Oliver)
(2021-03-22, 01:51)matthuisman Wrote: [ -> ]fix for all other platforms should be released over next few days.
Note: They are limited to below 720p now though unfortunately due to HBO Max changes

UPDATE: 
0.0.9 just pushed

This fixes playback on non-android hardware.
Note: Max quality is 960x540
For L1 Android devices, you enable to enable "L1 Secure Device" in the add-on settings to allow the full quality

Now that playback is fixed, I'm happy to spend more time fixing the missing content and also getting upnext working

Thanks for getting the update out so quick.  I'm running the HDMI output from the kodi box through a DVDO iScan micro that upscales the signal to 4K, the iScan micro plugs into a HDMI port of the AVR.   The upscaled video is great, it's not as good as native UHD/4k, but looks really nice.  I am trying to sort out audio issues, regardless of the Kodi audio settings tried the only audio tracks I'm able to get to work are the two 2-channel options, which get to my AVR as 2 channel PCM. The 2 channel PCM doesn't sound too bad getting mixed to an output of 7.2.4. 

Your response to my earlier post  reminding me of the difference in ARM hardware vs. android OS, spurred me to boot into the native android OS of my device and try loading the HBO max android app.  That wasn't very fun, since it turns out google play isn't able to connect correctly with the device, ended up downloading the apk from the HBO Max download site and manually installing the apk.  Maybe it's just my device, or the fact that I had to use an apk download, but the "official" HBO Max app is garbage in my setup.  Practically impossible to navigate and find content, plus never could get it to display a correct aspect ratio, everything was zoomed in. 

The only reason I brought up my experience using the android app on a TV is as a comparison to your kodi plugin.  There really isn't a comparison.  Your plugin is easy to navigate and find content, and everything I started was displayed correctly.  Great work.
I have a firestick and I'm only able to play content in SD. When I try to play videos, after enabling the "L1 Secure Device" setting, I get an inputstream error "Initialize failed (SingleSampleDecrypter)". Is it possible to play HD with a firestick?
odd, i'm pretty sure firestick is L1 device....
Can you get me a full debug log?
It it's not an error from their server - then we have a chance.

Just quickly - you've tried selecting non dolby-vision streams?
(2021-04-01, 00:57)matthuisman Wrote: [ -> ]odd, i'm pretty sure firestick is L1 device....
Can you get me a full debug log?
It it's not an error from their server - then we have a chance.

Just quickly - you've tried selecting non dolby-vision streams?
I have a firestick version 2 but it's a L1 device (I checked with DRM info app).
I was trying to watch a episode of friends so no chance for a DV stream.
Here's the log:
https://paste.kodi.tv/ojunagugis.kodi
To make the log, I opened two streams, the first a non-HD stream and the second is a HD stream.
(2021-01-17, 22:00)matthuisman Wrote: [ -> ]no logs needed.
I can reproduce the issue.

For now, the HBO add-on only works on Android systems.
Seems they have changed their widevine license server and it is no longer accepting the requests from the addon (except for on Android)
hopefully I can find a fix...

I guess it's safe to assume the addon is currently still undergoing issues with Windows 10 Kodi? Gotta luv those Widevine servers!
Nope. Working everywhere now. Just limited to under 720p except android l1
(2021-04-01, 23:44)matthuisman Wrote: [ -> ]Nope. Working everywhere now. Just limited to under 720p except android l1

Sorry to bother but I can not get it to work!

https://paste.kodi.tv/pajumimebe
(2021-04-02, 04:49)mancrew Wrote: [ -> ]
(2021-04-01, 23:44)matthuisman Wrote: [ -> ]Nope. Working everywhere now. Just limited to under 720p except android l1

Sorry to bother but I can not get it to work!

https://paste.kodi.tv/pajumimebe
biggest issue I see is your using 0.1.1
0.1.3 is latest version.

Also, your slyguy common is pretty old.
0.23.7 is latest version.

Get those both up-to date, and hopefully that sorts it.
I recommend having all my add-ons set to auto-update.
@codey2000
Could you enable debug log component > Curl.
then try to play again.
And also, can you play without L1 enabled so I can see what a successful play looks like on your device.

UPDATE:
Actually, I think it may not be using the secure decoder.
I just pushed 0.1.4 - please try that. That forces secure decoder if L1 device is enabled.
I had to do that for Disney+ so I suspect maybe this needs it to.
Try this first before. If still no go, get me the above logs.
(2021-04-02, 06:36)matthuisman Wrote: [ -> ]
(2021-04-02, 04:49)mancrew Wrote: [ -> ]
(2021-04-01, 23:44)matthuisman Wrote: [ -> ]Nope. Working everywhere now. Just limited to under 720p except android l1

Sorry to bother but I can not get it to work!

https://paste.kodi.tv/pajumimebe
biggest issue I see is your using 0.1.1
0.1.3 is latest version.

Also, your slyguy common is pretty old.
0.23.7 is latest version.

Get those both up-to date, and hopefully that sorts it.
I recommend having all my add-ons set to auto-update.

I'm afraid the issue still persist, however the trailers do play!
@mancrew
New debug log please
You are in USA right?
(2021-04-02, 06:42)matthuisman Wrote: [ -> ]@codey2000
Could you enable debug log component > Curl.
then try to play again.
And also, can you play without L1 enabled so I can see what a successful play looks like on your device.

UPDATE:
Actually, I think it may not be using the secure decoder.
I just pushed 0.1.4 - please try that. That forces secure decoder if L1 device is enabled.
I had to do that for Disney+ so I suspect maybe this needs it to.
Try this first before. If still no go, get me the above logs.
I tried the new version still no luck.
Hopefully this is what you requested.
https://paste.kodi.tv/gorawokofe.kodi
(2021-03-19, 05:56)matthuisman Wrote: [ -> ]@vtwin0001
Just pushed 0.0.8 that will fix the multi-language subtitles Smile

THANK YOU VERY MUCH!!!!

Sorry for yelling, but I really appreciate you hard work Smile
@codey2000

Looking at their apps decompiled code, I see they convert the cenc data to level 0 if NONE of the below...
Code:
if (Util.SDK_INT > 22 || schemeData == null || schemeData.data == null || !C.WIDEVINE_UUID.equals(PsshAtomUtil.parseUuid(schemeData.data)) || PsshAtomUtil.parseVersion(schemeData.data) != 1)

Looking at your log, looks like your api level is 22 (which isn't greater than 22.)
So, Ill try convert the cenc data to level 0 and see if that helps.

Can you try this version please:
https://drive.google.com/file/d/18aQuQRQ...sp=sharing
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34