Kodi Community Forum

Full Version: HBO Max
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43
I did the apt update. I then updated Kodi from binary in the RetroPie setup, but it kept the same version of Kodi.
Looks like the show Euphoria Season 2 throws a NoneType object error. I'm not sure if any other shows are having a similar issue. It's not a huge problem for me, but a sad girlfriend is no fun. Pasted my log for reference. LibreELEC10.1/HBOMax
thanks for the report and log.

Should now be fixed with version 0.8.0
A feature of this would be useful for shows and collections. Especially old cartoons a la live TV.


Kodi playlist feature works?
Edit: Please forget this post, a whole bunch of settings had mysteriously changed, and one of them was Skip Credits. Kids...
Do i have to skip the “Previously on” content when I watch series?
Is there a button to enable the review content when wating series?
The addon shouldn't be skipping intros....
Is that what your saying it's doing?
Or that's what you want?
In march nc+ in poland will upgrade its hbo integration to hbo max.
Is that something that needs its own addon or can be covered by this addon?
Other regions that switched to HBO max worked fine with this addon. So should be ok Smile
Hi there,

I'm having real trouble playing back HBO Max 4K HDR content with this addon. There are always a bunch of dropped frames no matter what and when. Even if I manually choose a real low bitrate of lets say 8mbit (hence not 4k) it will stutter. On the other hand: If I start a series that has no 4K HDR flag (so max 1080p content) it will play totally fine. Only 4K content has this issue, even if I choose lower resolutions.

My setup:
- FireTV 4k
- last Kodi apk 19.1.0
- HBO Max Addon v0.8.2
- Inputstream Adaptive 19.0.3
- Video settings are set to "Match framerate on start/stop"
- Resolution Whitelist: Marked everything

I can reproduce this Issue with Matrix (1) UHD/4K Dolby Vision the following way:
 - I start the movie and select "best" quality (30Mbit Dolby Vision 20160p): Video stutters all the way and finally stops completely.
 - FireTV Logcat has a lot of lines like this:
049 I MediaCodecLogger: 20944.secure.HW.video.hevc Dropping frame
Then I select "1920x1080 Dolby Vision @ 8.03 Mbit): Result is almost the same... it has less dropped frames, but still loosing frames.

And then I can watch the Watchmen Series at highest quality (1080p 10mbit) without any issues at all. In general, all 1080p sources from HBO Max run perfectly fine. All UHD Sources seem to have issues, one more, one less, but none plays without dropped frames, even If I manually turn down the resolution even below 8 MBit, which is less than regular HD content on HBOmax.

I can reproduce this always, for days now and it did never work without this issue (subscriped HBO MAX a week ago).

Perhaps someone here can repdroduce the same issue?
Please try Kodi 20 nightlies
Thank you @matthuisman 

Tried it right away. Unfortunately the dropout issues still remain but got different. The sound got worse, because audio dropouts the whole time. Video on the other hand seems to have less visible dropouts. All in all I'd say it got worse, cause almost no audio on the 4k streams.
no more ideas from me sorry. 
I suspect there is nothing the add-on can do anyway - its just passing the manifest to kodi etc

i know some android boxes dont like H265 - so you could disable that.
But i think then you wont get any Dolby Vision content
I’m not sure if this helps or not. I just discovered this for Kodi last night and you described the exact issue I experienced with 4K HDR stuttering and freezing. I tried going from “Best” to lower streaming options. I believe the movie was Kimi.

During lunch today I decided to try it again and received the same results. I noticed that when I changed the audio stream, the stutter went away. I tried with a few other movies (Space Jam, etc) and received the same results and resolution seem to correct that. It seems that when the audio stream is atmos, it causes the frames to drop or stutter. I was able to cycle through PCM, DD and DD+ and everything appeared fine. The 4K/HDR worked as expected. I’ll try and experiment further.

A couple of ways to change the audio stream is once it starts playing bring up the menu that allows audio and video options. There is an option that says “eng”. Click on that to experiment. Each stream seems to come with multiple audio options.

Any way, I guess I’m saying it may not be the 4K HDR that’s the issue.

I’m running this on a 2017 Nvidia Shield.

Good luck.
First, thank you for the add-on!

Lately, I noticed that the progress is not synced anymore. Do you have the same issue?
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43