Kodi Community Forum

Full Version: HBO Max
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34
(2022-03-12, 01:40)matthuisman Wrote: [ -> ]Oh. 5.1 widevine on Android has some issues. Can you try on Kodi 20 please.

No point comparing to official app. Kodi system is entirely different.

OK, will try Kodi 20 to see if it works better.
Finally I found the culprit for my problems with h265 streams with enabled 5.1 audio on my Firestick 4k, and solved it, hopefully Smile

First I tried with a fresh installation of Mavens Kodi 20, but situation was even worse. Subtitles not only flickered, but were out of sinc, and 5.1 audio also stuttered.
Then, going through HBO_Max addon settings options I disabled AC3 and left EC3 audio. With this setting everthing started working perfectly.

I tried this on Mavens Kodi 19.4 and it works there also; subtitles and 5.1 audio are OK. But in this version if I choose AC3 option in HBO_Max addon and then in player options (with active stream) choose DD+ audio everything works OK. But then, switching to a Netflix stream I have to select AC3 in player audio settings, otherwise I get subtitle flicker and audio 5.1 stutter exactly the same as with opposite audio settings (AC3 <=> DD+) in HBO streams.

Finally decided to stick to Mavens Kodi 20 (although in very early development stage) because of much better subtitle options/support, which is crucial in my  language region; also it has much better "inputstream adaptive" version. There is a new "OSD" option which works OK, and "Buffer" setting that attracted my attention for further experimenting...
I cannot choose the subtitles. I am using Kodi 18 with a raspberry pi.
Unfortunately, it is not possible to install the newer Kodi on raspberry.
Can it be fixed somehow?
I checked on a computer with Kodi 19 installed and the subtitles are working normally so I can confirm that the problem is with version 18
Shuffle has been added to the browser version of HBOmax. Please add it on the add-on.
https://variety.com/2022/digital/news/hb...1235212836
Hello. I'm on coreelec 19.4 and for a few weeks or 1 month, the playback of any content is laggy and jumps with audio cuts. If I disable the 5.1 option there is no lag, but playback stops every 20-30 seconds to load cache. I have reinstalled the addon and the same thing still happens. It seems as if there is not enough connection from an Internet, but that is not the problem since the rest of the addons work fine, I have my device connected by cable and I have a 1gb connection.
Make sure your widevine version hasn't been updated to latest as that had exact issue your saying

Go to add-ons > services > slyguy common > configure > playback > reinstall widevine version. Then select the latest.

Otherwise Nothing can be done my end sorry. You could Reduce the playback quality
(2022-03-31, 17:02)albertron Wrote: [ -> ]Hello. I'm on coreelec 19.4 and for a few weeks or 1 month, the playback of any content is laggy and jumps with audio cuts. If I disable the 5.1 option there is no lag, but playback stops every 20-30 seconds to load cache. I have reinstalled the addon and the same thing still happens. It seems as if there is not enough connection from an Internet, but that is not the problem since the rest of the addons work fine, I have my device connected by cable and I have a 1gb connection.

On which device are you running CE/Kodi? How is it connected to your router?
Your 1Gb cable internet connection does not guaranty that your Kodi box can use that; what speed do you get in Kodi when checking with SpeedTest addon?
BTW, some HBO-Max streams use rather large bitrates, so your box can be the bottleneck, having such problems with large bitrate streams.
The other thing is processor power needed, since you say that disabling 5.1, which make processing easier, results in no lag..
(2022-03-31, 20:00)matthuisman Wrote: [ -> ]Make sure your widevine version hasn't been updated to latest as that had exact issue your saying

Go to add-ons > services > slyguy common > configure > playback > reinstall widevine version. Then select the latest.

Otherwise Nothing can be done my end sorry. You could Reduce the playback quality

Thanks for answering. I had the latest version of widevine installed. I've tried the above and everything works fine now. Thank you very much!!
(2022-03-31, 20:23)Sholander Wrote: [ -> ]
(2022-03-31, 17:02)albertron Wrote: [ -> ]Hello. I'm on coreelec 19.4 and for a few weeks or 1 month, the playback of any content is laggy and jumps with audio cuts. If I disable the 5.1 option there is no lag, but playback stops every 20-30 seconds to load cache. I have reinstalled the addon and the same thing still happens. It seems as if there is not enough connection from an Internet, but that is not the problem since the rest of the addons work fine, I have my device connected by cable and I have a 1gb connection.

On which device are you running CE/Kodi? How is it connected to your router?
Your 1Gb cable internet connection does not guaranty that your Kodi box can use that; what speed do you get in Kodi when checking with SpeedTest addon?
BTW, some HBO-Max streams use rather large bitrates, so your box can be the bottleneck, having such problems with large bitrate streams.
The other thing is processor power needed, since you say that disabling 5.1, which make processing easier, results in no lag..

Thanks for answering. The problem was from the version of widevine. I have an amlogic S905X3 and I have passed the speed test and it seems that the ethernet port is quite overwhelmed, since "only" 300Mb reaches me.

Image
yes, the newest version of widevine installed by inputstream helper causes buffering issues. Quite a known problem.
There is an issue about it somewhere - but cant find it
Oh, here it is: https://github.com/emilsvennesson/script...issues/497

You can disable inputstream helper, and just allow slyguy to push new widevines if you like.
I manually push them once known to be good or if all others are revoked
Hi, I don't know if anyone here has solved this problem, then I apologize. Every time I play a video, I have the subtitles turned off and I have to turn them on manually. When I turn them on, they turn off again after a while. When I change them to another language and back then they remain displayed.
The second problem that happens is that the subtitles flash occasionally.
Don't know what both of these problems are and how to fix them?
Finally, I want to ask if there is an option to turn on intro skipping. I didn't find it anywhere, although the HBO Max app can do it.
Thank you very much.
(2022-04-11, 23:07)Kravatak76 Wrote: [ -> ]Hi, I don't know if anyone here has solved this problem, then I apologize. Every time I play a video, I have the subtitles turned off and I have to turn them on manually. When I turn them on, they turn off again after a while. When I change them to another language and back then they remain displayed.
The second problem that happens is that the subtitles flash occasionally.
Don't know what both of these problems are and how to fix them?
Concerning subtitles display, C/P:

"Depends on your Kodi audio language setting
Kodi audio setting <=---=> addon meaning
Media default =---= will be used the language set in the current addon profile selected
Original language =---= will be selected the original movie language of the played movie
User interface language =---= depends on the GUI language set
any other language name =---= respect the language set or if missing fallback to the original movie language"

Concerning "flashing subtitles", usually it's due to lack of processor power or overheating; try choosing 2 channel audio or lower video bitrate to see if it helps.
(2022-04-12, 15:40)Sholander Wrote: [ -> ]
(2022-04-11, 23:07)Kravatak76 Wrote: [ -> ]Hi, I don't know if anyone here has solved this problem, then I apologize. Every time I play a video, I have the subtitles turned off and I have to turn them on manually. When I turn them on, they turn off again after a while. When I change them to another language and back then they remain displayed.
The second problem that happens is that the subtitles flash occasionally.
Don't know what both of these problems are and how to fix them?
Concerning subtitles display, C/P:

"Depends on your Kodi audio language setting
Kodi audio setting <=---=> addon meaning
Media default =---= will be used the language set in the current addon profile selected
Original language =---= will be selected the original movie language of the played movie
User interface language =---= depends on the GUI language set
any other language name =---= respect the language set or if missing fallback to the original movie language"

Concerning "flashing subtitles", usually it's due to lack of processor power or overheating; try choosing 2 channel audio or lower video bitrate to see if it helps.

I'm sorry, but I probably don't understand the setting. I have set in Kodi Audio Language Setting, preferred audio language - English and preferred default audio stream - ON and preferred subtitle language - Czech. I don't have any preferred languages filled in the HBO Max addon settings, I don't know if it's necessary ... And I don't know if this setting causes the default subtitles to be turned off at the start of playback. Only the HBO Max addon shows this behavior. Neither Netflix nor PrimeVideo addons automatically start the correct subtitles in Kodi, ie Czech ...
On which device/OS and which version of Kodi are you using? Why don't you set Check language in HBO Max addon?
On my Firestick 4K with Kodi 20a (the same on Kodi Matrix 19.4) I have these settings that work OK:
Preferred audio language => Media default
Preferred default audio stream => On
Preferred subtitle language => MyLanguage, also set the same in HBO Max addon. In addon Playback settings the options for both Forced and Non-forced subs are ON.
All streams that have MyLanguage subtitle turn them on automatically. Streams that don't have MyLanguage don't turn any present subtitle on automatically. I then have to choose which subtitle language to use and turn them on manually.
(2022-04-13, 01:59)Sholander Wrote: [ -> ]On which device/OS and which version of Kodi are you using? Why don't you set Check language in HBO Max addon?
On my Firestick 4K with Kodi 20a (the same on Kodi Matrix 19.4) I have these settings that work OK:
Preferred audio language => Media default
Preferred default audio stream => On
Preferred subtitle language => MyLanguage, also set the same in HBO Max addon. In addon Playback settings the options for both Forced and Non-forced subs are ON.
All streams that have MyLanguage subtitle turn them on automatically. Streams that don't have MyLanguage don't turn any present subtitle on automatically. I then have to choose which subtitle language to use and turn them on manually.

i have google chromecast with google tv and Kodi Matrix 19.4. I don't see the difference between the Preferred audio language => Media default and English settings when the HBO Max addon is set to English but I set it to media default ... and what the Preferred subtitle language => MyLanguage means and I mean that MyLanguage, so in my case does that mean Czech? But I have it set up like this ... the other settings you recommend in the HBO MAX addon are also set. Nevertheless, the video starts playing and the subtitles are still switched off, even if I then go to the subtitle settings, the subtitles of my language are selected but they are still simply switched off ... i dont understant that because other addons works correctly...
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34