Kodi Community Forum

Full Version: Kodi doesn't show the cast for newly added movies.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi everyone. I use Kodi for a long time and never realy got big problems with it.

Recently, I added 2 new movies in my movie folders. Kodi recognized them correctly, but I'm unable to see the cast of these two movies (the old one's are OK).

I saw nothing relevant on the logs, but I could have overlook something, not a expert here =)

I was running 18.8, but updated to 18.9 to see if it could solve the problem, but no go.

I'm running on Windows 10 fully updated, Ryzen 5 3400G with the onboard graphics.

Any help is appreciated
This might be best moved to the metadata information providers part of the forum, but the short story is that TMDb changed the way some data is returned via the API, so the scrapers are being updated. I know we just released an updated TV show scraper (because I maintain the Python version), but I'm not 100% sure about the movie scraper. And it depends a bit on whether you're using the older XML one (that is the default scraper for Kodi 18) or the new Python one.  You should check here:

https://forum.kodi.tv/forumdisplay.php?fid=302
(2020-11-18, 20:58)chesterman Wrote: [ -> ]I saw nothing relevant on the logs, but I could have overlook something, not a expert here =)
Then why don't you provide us the logs?
(2020-11-18, 21:03)Karellen Wrote: [ -> ]
(2020-11-18, 20:58)chesterman Wrote: [ -> ]I saw nothing relevant on the logs, but I could have overlook something, not a expert here =)
Then why don't you provide us the logs?

I was in the process to do it, then i had the brilliant idea of deleting the movies from the catalog and rescan then for the 10th time to see if something could go different this time and... it worked!


Sorry to bother guys. It's working now =)
Thread marked solved.