Kodi Community Forum

Full Version: Universal Movie Scraper and Light IMDb Ratings Update Problem
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm scraping my movies and tv shows with Universal Movie Scraper and using Light IMDb Ratings Update 4.2.2 but I've a problem when updating these using the ratings plugin.

Its update.log shows this for all my collection.

Zoolander (IMDb ID: n/a, TVDB ID: n/a, TMDB ID: n/a)
Breaking Bad (IMDb ID: n/a, TVDB ID: n/a, TMDB ID: n/a)
Method get_tvshow_IMDb_ID - Breaking Bad (IMDb ID: n/a, TVDB ID: n/a, TMDB ID: n/a)
Method get_IMDb_ID_from_theTVDB - Missing TVDB ID
Method get_IMDb_ID_from_TMDb - Missing TMDB ID

This appears to be a problem somewhere with the Universal Movie Scraper but I'm not 100% sure going by the reply on the rating thread here. https://forum.kodi.tv/showthread.php?tid...pid2989748

Does anyone know what may be the issue here?
@stephen147

We would need to see your database, rather than an extract from a 3rd party addon log. Zip up your MyVidoesxx.db file and post the link or PM me the link if you want to keep it private. Or if you know your way around SQL, check the UniqueID table.

Breaking Bad is a TV show, so you could not have used Universal Movie Scraper to scrape it, which suggests it is more likely a problem with the addon, not with the scraping process.
(2020-11-20, 22:42)Karellen Wrote: [ -> ]@stephen147

We would need to see your database, rather than an extract from a 3rd party addon log. Zip up your MyVidoesxx.db file and post the link or PM me the link if you want to keep it private. Or if you know your way around SQL, check the UniqueID table.

Breaking Bad is a TV show, so you could not have used Universal Movie Scraper to scrape it, which suggests it is more likely a problem with the addon, not with the scraping process.

Yes, you're right about the TV shows. As you can see from the screenshot of the uniqueid table, only 8 movies are in the db but I've 100s' of movies. Edit. Silly me, the movies are there only they're on different pages. If I filter the media_type column to movies, there's 8 out of 856 that are missing. Don't mind the text I wrote in the screenshot below. This was before I realised this.

I'll pm you the db too.

Image
Ok, you have your uniqueID's but the problem is the type is wrong. That unknown is indicative of using a media manager to create nfo files that are scanned into the library. A lot of the media managers do it wrong, which then has consequences for Kodi.

The Kodi scrapers do not use unknown. Instead they use the correct type of tmdb, tvdb, imdb tvmaze, and tvrage depending on which scraper you use.

I note that you do have some titles that have the correct type, but most are the unknown type.

This is why LightIMDB cannot look up your ratings, because it is looking for the entry for imdb, tvdb and tmdb and instead all it finds is unknown.
(2020-11-21, 02:06)Karellen Wrote: [ -> ]Ok, you have your uniqueID's but the problem is the type is wrong. That unknown is indicative of using a media manager to create nfo files that are scanned into the library. A lot of the media managers do it wrong, which then has consequences for Kodi.

The Kodi scrapers do not use unknown. Instead they use the correct type of tmdb, tvdb, imdb tvmaze, and tvrage depending on which scraper you use.

I note that you do have some titles that have the correct type, but most are the unknown type.

This is why LightIMDB cannot look up your ratings, because it is looking for the entry for imdb, tvdb and tmdb and instead all it finds is unknown.
Problem is I don't use a media manager. I do all my scraping with UMS.

I can modify them values myself, the ones with tt at the beginning are imdb and the others would be from tmdb. I'll save a copy of the db before I mess anything up.
(2020-11-21, 02:14)stephen147 Wrote: [ -> ]Problem is I don't use a media manager. I do all my scraping with UMS.
I don't see how that is possible as UMS always saves the correct type which is imdb. TheMovieDB scrapers save both tmdb and imdb. And the tv show version of the scraper saves tmdb, tvdb and imdb.
Yep, I just scraped a couple of movies with UMS and id's are correct.

(2020-11-21, 02:14)stephen147 Wrote: [ -> ]I can modify them values myself, the ones with tt at the beginning are imdb and the others would be from tmdb. I'll save a copy of the db before I mess anything up.
Yep, that is the quickest fix. The imdb ones are easy due to the tt prefix, it is when you start mixing tvdb and tmdb it becomes a bit more difficult.
(2020-11-21, 02:23)Karellen Wrote: [ -> ]I don't see how that is possible as UMS always saves the correct type which is imdb. TheMovieDB scrapers save both tmdb and imdb. And the tv show version of the scraper saves tmdb, tvdb and imdb.
Yep, I just scraped a couple of movies with UMS and id's are correct.
Mmmh, I don't know how this came about. Instead of over 90% of my movies failing all but those 8 I mentioned are failing in the update.log of imdb rating add-on which is much better, so thank you.

I've manually found one movie title which successfully was found with UMS but it's failing to write a value for resulting in imdb rating add-on failing.

It's got this info:
Peter Kay: Stand-Up UKay (IMDb ID: n/a, TVDB ID: n/a, TMDB ID: 26272)
Missing IMDb ID


As you can see it's got the tmdb id but not the imdb. I thought that you said that UMS only gets the imdb ID?
 
(2020-11-21, 02:23)Karellen Wrote: [ -> ]
(2020-11-21, 02:14)stephen147 Wrote: [ -> ]I can modify them values myself, the ones with tt at the beginning are imdb and the others would be from tmdb. I'll save a copy of the db before I mess anything up.
Yep, that is the quickest fix. The imdb ones are easy due to the tt prefix, it is when you start mixing tvdb and tmdb it becomes a bit more difficult.
I can filter out the column media_type I suppose as they'll be either movie or a tv.
(2020-11-21, 03:10)stephen147 Wrote: [ -> ]Mmmh, I don't know how this came about. Instead of over 90% of my movies failing all but those 8 I mentioned are failing in the update.log of imdb rating add-on which is much better, so thank you.
In UMS have you set IMDB or TMDB as the search engine? I think you have set TMDB because looking at TMDB, the IMDB id is missing...

Image
(2020-11-21, 03:24)Karellen Wrote: [ -> ]In UMS have you set IMDB or TMDB as the search engine? I think you have set TMDB because looking at TMDB, the IMDB id is missing...

I have TMDB set. So by adding the imdb id here, it should then work as the add-on checks this?
(2020-11-21, 03:33)stephen147 Wrote: [ -> ]I have TMDB set. So by adding the imdb id here, it should then work as the add-on checks this?
Yes, if you have tmdb set for the search engine, then it will download the tmdb id and if it is available the imdb id. And in this case it was not available.

If you have imdb id set as the search engine, all you get is the imdb id because IMDB don't have a field for ID's from other providers.,
I've only realised that I could do each title individually via the context menu. Update IMDb rating.

So. I ended up going through each tv series one by one and manually adding the tvdb and the imdb when I clicked on the Update IMDb rating context item and added them that way. All are working apart from the special episodes which is no big deal.