Kodi Community Forum

Full Version: How to use Movie Set Artwork in v19
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
(2022-06-17, 04:54)Sponky Wrote: [ -> ]My mistake, I have misinterpreted the warning when exporting my library.
The export saves the modified (lower quality) version from the cache to the local folders.
If you have the Movie Set Information Folder, it will also save the set artwork there.

(2022-06-17, 04:54)Sponky Wrote: [ -> ]'ll try the movie removal from my library and re-scrape trick to get scraped collection artwork. Do I have to remove the nfo file as well?
Ah, that will be your problem- the nfo file.
Open the nfo file. Are there any artwork links? Probably not which is why you don't get any artwork. Did you use a Media Manager to create them, or are they fairly old? Post the nfo contents to Kodi Paste Site and I can check if you are not sure.
You will then need to delete the nfo files and rescrape.

NFO files and local artwork go hand in hand. If you have one, you should have the other. Online artwork and artwork links do expire.

Install Artwork Dump... https://forum.kodi.tv/showthread.php?tid=360078
You need the Movie Set Folder for this.
Set up Artwork Dump to download artwork after scraping.
You will have the original local artwork, and then you can export nfo files from the library. Don't export artwork when asked.
They are old NFO files. Yep there is no set artwork links inside. Just the Set name:


    <set>
        <name>Alien Collection</name>
    </set>

So delete the nfo files, deleted the videos from the library and a rescrape should fix it?
(2022-06-17, 17:12)Sponky Wrote: [ -> ]So delete the nfo files, deleted the videos from the library and a rescrape should fix it?
Yes
I am confused. My local movie set artwork is not loading even after deleting library and rescrapping. I can manually add art for each collection but that would take forever.
I have movie set artwork store in folder Movies- Sets Art. Each subfolder contains poster and fanart

Am I supposed to have a .nfo file in these subfolders?

Each movie subfolder I have has a .nfo file which includes collection name. Is there supposed to be something in file that links artwork location?

I should point out I use Tiny Media Manager 3.1.16
(2022-08-04, 20:48)DAlba Wrote: [ -> ]Am I supposed to have a .nfo file in these subfolders?
No

(2022-08-04, 20:48)DAlba Wrote: [ -> ]Is there supposed to be something in file that links artwork location?
Nope.
Have you set the Movie Set Information Folder in your settings... https://kodi.wiki/view/Settings/Media/Vi...ion_folder
That's what I thought but some comments above made me confused.

Yes I did do that. It doesn't scrap a single one. I can manually add artwork and it immediately shows up under Local.

I've tried removing one movie from set and rescan as well as changing content type of source to none to clear out library and then change content back to movies to rescan.
I am using MySQL if that makes a difference.
(2022-08-04, 21:33)DAlba Wrote: [ -> ]I am using MySQL if that makes a difference.
Yea, I think it does. Maybe @Klojum can help out.
Pages: 1 2 3