Kodi Community Forum

Full Version: Player crashes on every video
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi everybody,

I just downloaded the player, but it keeps crashing for every video file I try to play.

You can find the debug log here: https://pastebin.com/Z1A55fen

Can you help me? I don't even find a descriptive error message in the log (at least to my novice eyes), where I could see what the root cause is.

Thank you for your help.
Stream #0:0(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p(tv, bt709/bt709/iec61966-2-4), 1920x1080 [SAR 1:1 DAR 16:9], 49306 kb/s, 50 fps, 50 tbr, 50k tbn, 100 tbc (default)

That's a FullHD h264 video doing 49Mbit/s at 50fps ...Rather on the high side but not impossible considering the PC hardware, I'd say. Is it a video that you yourself created with a (phone) camera, or "just another video you picked up from the Internet"?

I'm not a video guru, so others will have to step in for the finer details.
That's a video I took myself on my mobile phone.

Note, that this video plays just fine in VLC - so I don't think its less a performance issue but more a configuration issue in Kodi. I just wanted to move to Kodi because I plan to use it on an Nvidia Shield and wanted to use the same solution on my PC.
(2020-12-29, 13:10)bublitz Wrote: [ -> ]That's a video I took myself on my mobile phone.

Note, that this video plays just fine in VLC - so I don't think its less a performance issue but more a configuration issue in Kodi. I just wanted to move to Kodi because I plan to use it on an Nvidia Shield and wanted to use the same solution on my PC.

Other points to consider:
  • Does it matter to Kodi if I have multiple screens?
  • What about multiple audio devices? (Headphones, Speakers) - could they have an impact on playback?
  • Could there a some decoders missing? The file I try to play is an mp4 file - so there might be an extension missing?