Kodi Community Forum

Full Version: No sound in xbmc
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Linux: Ubuntu 8.04 i686
revision: 14921 (PPA)
log: http://www.pastebin.ca/1173828
problem: No sound at all in xbmc (not in the menus, not playing audio or video (mp3 as well as dts.))
Using device "default" which according to aplay -L should be the correct one, have also tried "front" to no avail. Otherwise sound is working fine on ubuntu, in mplayer, gstreamer, ...
This on an analog device, I'm not using spdif.
Have also tried with digital to "default", obviously didn't work either.

A better look at aplay -L showed I actually have two "default" devices.

Setting the device in xbmc to "default:CARD=CMI8768" solved it for me.

(May I suggest this a helpful entry to the manual somewhere?)
Sound was working, and then with the change of a gfx card, sound no longer worked in xbmc.

I checked on the console (mpg123 file.mp3) and it was all okay.

aplay -L only showed one default entry.

Changing the XBMC Audio device to default:CARD=VT82xx resolved the problem and I had sound again. (odd).

Ubuntu 7.10
Custom Build XBMC SVNRev: 13972 (Compiled Jul 13 2008)
This happens to me on Intel-based sound cards. What fixes it is a "rmmod snd-pcm-oss".