Kodi Community Forum

Full Version: Stop main menu animation on idle
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Manfeed, these days I moved to 4K and I noticed the gpu usage seems high (30%) on the main menu. If I enter a section like Settings, then the gpu usage goes to 0.1%.
I suspect it may be due to the rainbow animation on the main screen. I like the animation but that usage 24h a day is excessive.
Would it be possible to stop the animation on idle, or provide an option to disable it (and maybe then only change color when the menu moves)?
(2021-06-09, 10:09)Maboz Wrote: [ -> ]Hi Manfeed, these days I moved to 4K and I noticed the gpu usage seems high (30%) on the main menu. If I enter a section like Settings, then the gpu usage goes to 0.1%.
I suspect it may be due to the rainbow animation on the main screen. I like the animation but that usage 24h a day is excessive.
Would it be possible to stop the animation on idle, or provide an option to disable it (and maybe then only change color when the menu moves)?

Did you try changing the background to a static image?

Also, if you’re going to have your device turned on 24/7 you could use a black screensaver.
(2021-06-09, 11:25)manfeed Wrote: [ -> ]
(2021-06-09, 10:09)Maboz Wrote: [ -> ]Hi Manfeed, these days I moved to 4K and I noticed the gpu usage seems high (30%) on the main menu. If I enter a section like Settings, then the gpu usage goes to 0.1%.
I suspect it may be due to the rainbow animation on the main screen. I like the animation but that usage 24h a day is excessive.
Would it be possible to stop the animation on idle, or provide an option to disable it (and maybe then only change color when the menu moves)?

Did you try changing the background to a static image?

Also, if you’re going to have your device turned on 24/7 you could use a black screensaver.

The background is a static image, doesn't make a difference, still high gpu usage.
I tried using the black screensaver, and that works, but it conflicts with my AVR, in a way that most of the times I cannot exit from the screensaver and I must restart Kodi... Most of the time we can't say if the screensaver is running, or kodi is frozen, or there's no signal.
Yes, my device is on 24/7.
@Maboz Just wondering what type of electricity-guzzling Kodi device you are using with that high gpu usage.
I was thinking maybe I could add a python script to EventGhost to start/stop kodi when the TV enters/exit the network. Then I'd have Kodi running only while the TV is on.
(2021-06-11, 18:21)Klojum Wrote: [ -> ]@Maboz Just wondering what type of electricity-guzzling Kodi device you are using with that high gpu usage.

it's an Athlon X4 845 + a Geforce GT 1030 (I plan to replace these once an APU with AV1 decoding will be available)
Yours it's a very particular issue, if you're willing to edit a xml file, you could try changing  lines 241 and 248 of Home.xml, from...

xml:
<texture diffuse="homemenu_back2.png">tajo/backani.gif</texture>

...to...

xml:
<texture diffuse="homemenu_back2.png">tajo/white.jpg</texture>
Thanks, your suggested fix was working, but then I'd have to repeat it every time the theme is updated.
For now I have setup EventGhost to open Kodi when the TV is switched on, and close it when it's turned off. That should be enough, I hope Smile
Hello!
This problem also affected me (running on a raspberry 3b the skin was working too slow with the default background).
I tried the solution of changing the gif to tajo/white.jpg but it didn't have any effect, it still showed the animated background (I didn't check if the file exists).

Fortunately I verified that if I change all the backgrounds to static images (one by one from the menu settings) the addon speed improves a lot and I can enjoy this excellent skin.

Please consider adding an option to disable the animated image, this would make this excellent skin more usable on small computers.

Thanks
Best regards
Gabriel
(2022-04-11, 15:52)gabriel_tandil Wrote: [ -> ]Hello!
This problem also affected me (running on a raspberry 3b the skin was working too slow with the default background).
I tried the solution of changing the gif to tajo/white.jpg but it didn't have any effect, it still showed the animated background (I didn't check if the file exists).

Fortunately I verified that if I change all the backgrounds to static images (one by one from the menu settings) the addon speed improves a lot and I can enjoy this excellent skin.

Please consider adding an option to disable the animated image, this would make this excellent skin more usable on small computers.

Thanks
Best regards
Gabriel

An option is to select your own backgrounds...
Hi @Edworld, thanks for your answer
select my own background is what I did and it works fine for the menu (there are other screens where I can't or don't know how to change it).

What I propose is a suggestion to make this amazing skin more comfortable to use on small computers.

Best regards
Gabriel