Kodi Community Forum

Full Version: [Win][v19+] Intel HTPCs/NUCs & Kodi-native 3D MVC Playback
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
What are your Intel driver and Windows OS versions?

I re-installed the 18.1 fork and ran a test. Avengers played full through with no issues, including lossless audio passthrough.

I'm thinking this new version requires the newer drivers/OS but it's a lot of work to update all of that to test and find out it fails. Rolling back is a PITA.
(2022-10-23, 10:48)K0D1User1138 Wrote: [ -> ]Checked back on this board for previous solutions and saw I had to re-install the Intel driver before and that got things working again. Followed those old directions and reboots Windows. Went into the Display settings and 3D mode was selectable. Selected it and went into Kodi to re-test the same movie. Video plays, Kodi OSD goes into 3D but the video is flat. Exit the movie and Kodi and check Windows display options. 3D mode is now gone. Quite everything, re-start Windows, follow the above process and once again movie plays with passthrough audio but no 3D video. Quit Kodi and 3D mode in display settings is gone.

No idea what is going on now. I don't recall encountering this issue previously.

Under kodi->system->display you should enable "auto control 3d" feature and dont modify the windows' display 3d settings manually. everything is done automatically by kodi after you enable that flag.

For that flag there are 2 known issues.
1) If kodi starts up when windows is in 3d mode it becomes unpredictable - nothing i can do to fix this issue at the moment as it is by how kodi's directx integration is designed and implemented.
2) when enabling auto-control you need to return to kodi's main screen and re-enter kodi->system->display to be able to select "HW based" under preferred stereoscopic mode.

If kodi's HW based status contradict windows 3d status you get unexpected issues.
(2022-10-23, 15:55)udobroemme Wrote: [ -> ]I also tried your new build (Alder Lake Pentium, 21H2, latest Intel drivers). Playback of MVC content works perfectly with hardware output. I'm having a few issues with some BD menus. 3D menus are displayed correctly. But when I start the film, the display switches to hw accelerated 3D but shows only a 2D image. Is it maybe one of the mentioned menu related bugs? Smile.\
On 3D discs some menus are in 2D.
I know, I was surprised to find it as well.

I tried duplicating the frame to convert it into flat 3D so both eyes will get the same frame but it caused a whole mess of crashes that originated by Intel's MFX requiring cache of more than 26 frame, and that contradicts the existing design of kodi's inputstream which in bluray uses blurayinputstream and ffmpeginputstream in tandem and has issues to be aware of multiframed 3D that might arrive in the current or following clip.
(2022-10-24, 07:07)damagedspline Wrote: [ -> ]
(2022-10-23, 10:48)K0D1User1138 Wrote: [ -> ]Checked back on this board for previous solutions and saw I had to re-install the Intel driver before and that got things working again. Followed those old directions and reboots Windows. Went into the Display settings and 3D mode was selectable. Selected it and went into Kodi to re-test the same movie. Video plays, Kodi OSD goes into 3D but the video is flat. Exit the movie and Kodi and check Windows display options. 3D mode is now gone. Quite everything, re-start Windows, follow the above process and once again movie plays with passthrough audio but no 3D video. Quit Kodi and 3D mode in display settings is gone.

No idea what is going on now. I don't recall encountering this issue previously.

Under kodi->system->display you should enable "auto control 3d" feature and dont modify the windows' display 3d settings manually. everything is done automatically by kodi after you enable that flag.

For that flag there are 2 known issues.
1) If kodi starts up when windows is in 3d mode it becomes unpredictable - nothing i can do to fix this issue at the moment as it is by how kodi's directx integration is designed and implemented.
2) when enabling auto-control you need to return to kodi's main screen and re-enter kodi->system->display to be able to select "HW based" under preferred stereoscopic mode.

If kodi's HW based status contradict windows 3d status you get unexpected issues.

What Windows OS version and Intel graphics drivers are recommended for v20? Are we still best served keeping the older versions of both?
(2022-10-23, 10:12)Morpog Wrote: [ -> ]@damagedspline 
I tried with ask and prefered setting and both worked fine!
If color management is enabled, I only get a black screen in the movie (menu show correct). Maybe good to tell others to disable it if they have black movie.
MFX level seems to end at 35, my driver MFX level is 36. Not really a problem.

I couldn't test Blu-ray Menus at all, as Kodi tells it doesn't detect a Java Installation. I have Oracle Java 8 JRE latest update installed though.

If 3D gets enabled by Kodi and I don't set that after the movie ends it should end 3D and after that I close Kodi, then I got a black screen on Desktop. Had to log in with RDP and restart the machine.

Everything else is working fine!

Please try to exit kodi, set the JAVA_HOME environment variable to the java path (excluding bin and exe subdirs, like: c:\program files\Java\1.8), rerun kodi and retry.
I use java 1.6 as it has the best compatibility as far as i noticed...
(2022-10-23, 10:48)K0D1User1138 Wrote: [ -> ]Can this new version of Kodi-MVC run on more recent Intel drivers and Windows 10 versions? What else may I be missing here?
I am using Windows 11 22H2 and latest Intel drivers
(2022-10-24, 07:19)damagedspline Wrote: [ -> ]Please try to exit kodi, set the JAVA_HOME environment variable to the java path (excluding bin and exe subdirs, like: c:\program files\Java\1.8), rerun kodi and retry.
I use java 1.6 as it has the best compatibility as far as i noticed...
I tried it with latest JAVA 8 JRE and JDK (both 64Bit) it still tells it couldn't detect a Java installation.
Just did more testing. Updated the PC to the latest Windows 10 updates and Intel graphics driver. Settings in Kodi as noted above. Still the same result. Playing MVC MKV puts Kodi into a 3D mode which triggers the TV to 3D mode but there is no 3D image. Testing HSBS and HTAB MKV files and both trigger Kodi and the TV to 3D and present a 3D image. Not sure what is failing or what settings to be looking for now.
Check if color Management is enabled in Kodi. Disable it.
(2022-10-24, 13:46)Morpog Wrote: [ -> ]
(2022-10-24, 07:19)damagedspline Wrote: [ -> ]Please try to exit kodi, set the JAVA_HOME environment variable to the java path (excluding bin and exe subdirs, like: c:\program files\Java\1.8), rerun kodi and retry.
I use java 1.6 as it has the best compatibility as far as i noticed...
I tried it with latest JAVA 8 JRE and JDK (both 64Bit) it still tells it couldn't detect a Java installation.
I tried a clean install - I use JRE 1.6 for Windows x64 from here -  under the "Java SE Runtime Environment 6u45" section.
(2022-10-24, 22:40)Morpog Wrote: [ -> ]Check if color Management is enabled in Kodi. Disable it.

It is and was disabled. Still no MVC 3D.

Is there anything in the logs I should be looking for?
What value did you set as MFX level?
(2022-10-25, 04:56)K0D1User1138 Wrote: [ -> ]It is and was disabled. Still no MVC 3D.

Is there anything in the logs I should be looking for?

Enable kodi logging (under system->logging), play your clip and exit.
Open the kodi log file (%appdata%\kodi\kodi.log) in notepad and search for the word MFX - you should see MSDK initialized, MSDK uses D3D11 API and that HW accelerated implementation is used.
Either you see these messages or errors, you might want to try to lower your MFX level in the settings. open kodi and go to settings->player->video and at the bottom set MFXLevel to 4 and retry. if 4 does not work, try 10 and later 16 and then 23. between each attempt you should make sure that no clip is running.

Additionally, if you verified that 3D display is working at windows level, you should note the FPS at which it is wokring at. Some HW restrict the 3D support at 24FPS - at this case you should mark/unmark the lock FPS flag under kodi->settings->player->video.

I will try and think of more things to try out.

I have verified the color management issue to be present at my older builds as well - working on it.
I set the MFX Level to 4 and that triggered 3D for MVC. Testing now to ensure a full movie plays with lossless audio output or if I run into the previous audio error issue.

Edit * Seemed to be working alright. I'll do more testing but got Avengers to play all the way through without any crashing or audio issues. Now just need to work on bringing a few add-ons up to v20.
Color management didn't work for me because i didnt provide 3D Lut or ICC file. once I set the ICC file, i stopped getting the black screen when CMS is enabled.
FYI.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29