Kodi Community Forum

Full Version: [Win][v19+] Intel HTPCs/NUCs & Kodi-native 3D MVC Playback
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29
(2023-03-08, 10:26)Aphykit2006 Wrote: [ -> ]Hi, Ok.
the LG TV ??

And =>  MFX level setting = ?  
for exemple :   before i use 20. and block updates since 2 years ...  (work fine) .
.. but since last upate (windows 10) : no more 3d

this morning, i take a look in intel's report :

Processor: Intel® Core™ i7-8565U CPU @ 1.80GHz
Processor Speed: 1992  MHz
GFX Driver Name: Intel® UHD Graphics 620
Shader Version: 5.1
OpenCL* Version: 3.0
* Microsoft DirectX* *
Runtime Version: 12
Hardware-Supported Version: 12.

So, i put this value (12) into kodi's configuration.   test tonight.

regards

Hi, 

where can you find this intel report? 

Kind regards
Hi.
Intel graphics display  /  Intel Graphics Command Center.
From memory hummmm =>  in the graphics control panel of the Intel chip. There is an option (hardware) :  Generate a report  (.txt)

Something like this : (another computer)
Image
Kind regards
(2023-03-08, 10:26)Aphykit2006 Wrote: [ -> ]Hi, Ok.
the LG TV ??

And =>  MFX level setting = ?  
for exemple :   before i use 20. and block updates since 2 years ...  (work fine) .
.. but since last upate (windows 10) : no more 3d

this morning, i take a look in intel's report :

Processor: Intel® Core™ i7-8565U CPU @ 1.80GHz
Processor Speed: 1992  MHz
GFX Driver Name: Intel® UHD Graphics 620
Shader Version: 5.1
OpenCL* Version: 3.0
* Microsoft DirectX* *
Runtime Version: 12
Hardware-Supported Version: 12.

So, i put this value (12) into kodi's configuration.   test tonight.

regards
What do you mean by MFX Level Setting?  Are you referring to the "3D MVC Decoder HW Support Level"?  I have that set at 10.

The value you're talking about from the Intel report "Hardware-Supported Version: 12", refers to the Direct X support.  It has nothing to do with MVC support
Hello
Thanks for the information. I'm still figuring out how to get it.
On the same machine : 
Windows V 1883: 3d OK
V 21H1: 3D KO.

I tested with some values (10 12 16 20  22) for 3Dmvc support level, but nothing : Only one eyes in 3d.
Should we restart between each change?
Type 'o' : OK for decoding mvc , but only right eye.
tested witth kodi mvc 19.4 and 20 : ko

Other computer windows 11 ( i5-10500T)  : 3D : OK   (level 20)

Regards
(2023-02-28, 02:57)K0D1User1138 Wrote: [ -> ]Hey, I will have to test later tonight or tomorrow and get back to you. I'm not sure I have it working properly at the moment. Stay tuned.

So, I found two posts which might be similar to my problem: 
https://forum.kodi.tv/showthread.php?tid...pid2856733
--> unfortunately i can't find this driver version which works for my Gen4 Intel CPU (it's hd4600 so it should be the same than yours)

https://forum.kodi.tv/showthread.php?tid...pid3060162
--> my 3D MVC also crashing at 7 minutes but they should be h.264 and not h.265 like damagespline.
Hi
i made some test with 3 Computers


GFX Driver Name: Intel® UHD Graphics 620   - HD 4600 and HD 630
Mfx level = 20 to 34 : same result

Windows 10 version 1607 and 1809 : 3D OK (Kodi 18 ,19, 20)  ( test on HD 4600 and HD 620)
Windows 10 version 1909 and  21H1 : 3D KO (Kodi 18 ,19, 20)  ( test on HD 4600 and HD 620)
Windows 11 Version  22H1 : 3D OK  (Kodi  20)  ( test on HD 4600 , HD 620 and HD630)


Regards
(2023-03-14, 10:48)Aphykit2006 Wrote: [ -> ]Hi
i made some test with 3 Computers


GFX Driver Name: Intel® UHD Graphics 620   - HD 4600 and HD 630
Mfx level = 20 to 34 : same result

Windows 10 version 1607 and 1809 : 3D OK (Kodi 18 ,19, 20)  ( test on HD 4600 and HD 620)
Windows 10 version 1909 and  21H1 : 3D KO (Kodi 18 ,19, 20)  ( test on HD 4600 and HD 620)
Windows 11 Version  22H1 : 3D OK  (Kodi  20)  ( test on HD 4600 , HD 620 and HD630)


Regards
I think you should post the actual CPU you're using, because a lot of folks might not be familiar with the actual IgFX. 

The Intel HD 4600 GPU was part of the 4th Gen CPus (Haswell).  The Intel HD 620 is part of the ultramobile 7th Gen CPUs (Kaby Lake U).  The HD 630 is the GPU in the desktop 7th Gen CPUs (Kaby Lake).

Windows 10 version 1909 and  21H1 : 3D KO .  Does this mean it's Not working?  Or was that a typo and you meant it was OK?

Please elaborate on what works and what does not.
Hello
Indeed, I will try to be more specific.
But in summary: I have new equipment, and I took the opportunity to test the old ones.
It turns out that Windows 10 versions above 1800: I can't get 3D MVC to work there.
With Windows 11 3D MVC decoding works fine.
-------------------------------
New Computer: Dell3080
 Intel® Core™ i5-10500T CPU @ 2.30GHz
GFX Driver Name: Intel® UHD Graphics 630

Microsoft Windows 11 Professional 22H2 MVC 3D decoding: OK
test with Kodi 20
Todo: make it start with the remote control (I'm working on it)

-----------------------------
The older machine:
I've been watching 3D for 3 years
Fanless model modified to add light ventilation and remote control receivers.
Processor: Intel® Core™ i7-8565U CPU @ 1.80GHz
GFX Driver Name: Intel® UHD Graphics 620

Microsoft Windows 10 Professional 1803: 3D MVC Decoding: OK
test with Kodi 17 / 18 / 19 / 20 
Update to Microsoft Windows 10 Professional 1909: 3D MVC decoding: NOT OK
test with Kodi 19 / 20
Update to Microsoft Windows 10 Professional 21H1: 3D MVC decoding: NOT OK
test with Kodi 19 / 20
Update to Microsoft Windows 11 Professional 22H2: 3D MVC decoding: OK
test with Kodi 19 / 20

ToDo: resell it
---------------------------------
Very old machine
Personal editing: Used for video recording and miscellaneous.
Processor Intel® Core™ i3-4340 CPU @ 3.60 GHz
GFX Driver Name: Intel® HD Graphics 4600

Microsoft Windows 10 Professional 1803: 3D MVC Decoding: OK
test with Kodi 18
Update to Microsoft Windows 10 Professional 1909: 3D MVC decoding: NOT OK
test with Kodi 19 / 20
Update to Microsoft Windows 10 Professional 21H1: 3D MVC decoding: NOT OK
test with Kodi 19 / 20
Update to Microsoft Windows 11 Professional 22H2: 3D MVC decoding: OK
test with Kodi 19 / 20

ToDo: make the Imon / harmony remote work better

For information I installed Windows 11 on old machines (which do not have the necessary configuration, no TPM) using a tool: MediaCreationTool.bat
That's it, if it helps.

Regards
Good to know win 11 works.

I’m still hoping someone can confirm a 12 or 13 Gen will work as I’d like to get one computer to play all and I’d prefer newer than 10th Gen for 4k
(2023-03-15, 12:15)Aphykit2006 Wrote: [ -> ]Hello
Indeed, I will try to be more specific.
But in summary: I have new equipment, and I took the opportunity to test the old ones.
It turns out that Windows 10 versions above 1800: I can't get 3D MVC to work there.
With Windows 11 3D MVC decoding works fine.
-------------------------------
.....
You did not mention the make and model of your 3D TV.

FWIW, I can get an Intel NUC6i3SYK, a NUC6i5SYK and a NUC8i3BEH to work on Windows 10 Enterprise LTSC 21H2, but they all work on a Vizio 3D TV, they do not work at all on a LG 3D TV.  The 3D "hardware mode" on the LG TV either crashes KODI, or depending on the setting falls back to non-hardware mode and shows MVC videos as Over/Under.

So I think it's important to also mention the TV you are using.

I also tested a couple of other mini PCs.  One with a Celeron J4125, and one with a Core i5-1145G7.  Since these already had an OS installed I used it and installed KODI 20 MVC. 

The J4125 has Windows 10 Pro 20H2 (Intel UHD 600 Graphics).  When enabling 3D hardware mode, it triggers the Vizio's 3D mode, but the left eye is dark.  I can press "\" to go into a windowed mode, and then the 3D image looks right, but it's not working right as far as I'm concerned.  Selecting software modes (side-by-side, or Over/Under) manually works fine.

The core i5-1145G7 had Windows 10 Enterprise SAC 22H2 (Intel Iris Plus 655).  When enabling 3D hardware mode, it starts playback, it enables 3D mode in the TV, but the screen is blank.  I get audio, but no video.  Going into software 3D modes works fine.

These last tests were done on the Vizio TV.  I also tested the Celeron J4125 on the LG, and it didn't work either.  It doesn't trigger the 3D mode of the TV, and it automatically reverts to software mode (HSBS or HTAB/OU)
After lots of delays for various reasons I ended up having a very difficult time sorting out some issues on the system I built for my dad that caused me to give up and do a complete drive wipe and re-install. Got things working again, I believe, to the state they were before I tried experimenting with version 20. See info below:

OptiPlex 7020 refurbished system
Intel i3-4150
8GB RAM
Windows 10 version 1809
Intel HD Graphics 4400

Kodi 18.1 RC1 MVC Fork. (Can't seem to find a full 18.1 MVC fork build)
Jellyfin Kodi (to run the Kodi database off my Jellyfin server in add-on mode)

StopUpdates10 to prevent Windows from completing any newer updates.


I stuck with wat had been working fine for a long time in going with version 18.1. I did not have to do any additional set-up for the graphics drivers. Windows just installed it and I ran the Intel Driver & Support Assistant install but nothing further. I was able to test Ant-Man 3D with Atmos and it played 80% through before I had to stop the test. Will be testing again to make sure there are no Large Audio Sync errors. Once I know this is working stable I will try to update to the latest v20 MVC build and test but this was a lot of work to get going again due to network errors and other circumstances.

Running more tests and found when setting the 3D mode to Hardware Based the audio is out of sync but setting to Same as Movie the audio was fine.

Also found the right-eye first movies won't actually be in 3D so have to look into that issue again.
(2023-03-15, 01:27)Dudeman Wrote: [ -> ]
(2023-03-14, 10:48)Aphykit2006 Wrote: [ -> ]Hi
i made some test with 3 Computers


GFX Driver Name: Intel® UHD Graphics 620   - HD 4600 and HD 630
Mfx level = 20 to 34 : same result

Windows 10 version 1607 and 1809 : 3D OK (Kodi 18 ,19, 20)  ( test on HD 4600 and HD 620)
Windows 10 version 1909 and  21H1 : 3D KO (Kodi 18 ,19, 20)  ( test on HD 4600 and HD 620)
Windows 11 Version  22H1 : 3D OK  (Kodi  20)  ( test on HD 4600 , HD 620 and HD630)


Regards
I think you should post the actual CPU you're using, because a lot of folks might not be familiar with the actual IgFX. 

The Intel HD 4600 GPU was part of the 4th Gen CPus (Haswell).  The Intel HD 620 is part of the ultramobile 7th Gen CPUs (Kaby Lake U).  The HD 630 is the GPU in the desktop 7th Gen CPUs (Kaby Lake).

Windows 10 version 1909 and  21H1 : 3D KO .  Does this mean it's Not working?  Or was that a typo and you meant it was OK?

Please elaborate on what works and what does not.
Hi, 

thx for your tests. On my 4th gen Intel 3D works but crashes after 7 Minutes. Same behavior on your system, or does it not start at all?

Kind regards
@Dudeman:

i have a LG 55C6V and i'll do some tests this evening Kodi 20 MVC build and post results (i have many 3D MVC iso and many Full-TAB and Full-SBS mkv files).

until now, here is my config and what's working or not:

HTPC1 : i5-4590 , GTX1060 (not used for 3D), Win10 22H2
i'm able to play Full-TAB 3D mkv with the actual 20.1 standard built on the LG TV in full 3D 1080p Frame Packed (kodi hardware mode).
Full-SBS mkv with same kodi build in "hardware mode" works fine for a few min and then kodi crash (i have actually on thread on this problem in the forum).
I can play all my Full 3D MVC ISO files with MPC-HC/MadVR, HDMI output signal is full 3D 1080p Frame Packed mode.

HTPC2 : i7-10750h with Quadro T1000, latest nvidia drivers, win11 22H2 and kodi 20.1 std build
Exact same behaviour than with HTPC1 :-)
EDIT: Quadro T1000 on that laptop is a combined intel iGPU + Quadro T1000, intel drivers for iGPU has just been updated and Kodi doesn't crash anymore with Full-SBS, i'll do more testing tomorrow.

Flow :    HTPCx => TX-NR609 AVR => LG 55C6V or SONY VPL-HW65ES
Hi all
I'll try to answer without gg trad ;-) ( sorry)
Al my tests are made with .mkv with mvc
Converted from original .iso with makemkv or another tool
I don't use TaB or SbS
I don't use extrenal videocard, only intel' integred chipset.
3D Ko is : not good decoding (only right eye) seems 2d but beamer switch in hardware decoding
I don' have a 3d tv but epson 8200 beamer
Tv ( samsung) is power off when beamer is running
Regards
(2023-03-17, 20:52)Aphykit2006 Wrote: [ -> ]Hi all
I'll try to answer without gg trad ;-) ( sorry)
Al my tests are made with .mkv with mvc
Converted from original .iso with makemkv or another tool
I don't use TaB or SbS
I don't use extrenal videocard, only intel' integred chipset.
3D Ko is : not good decoding (only right eye) seems 2d but beamer switch in hardware decoding
I don' have a 3d tv but epson 8200 beamer
Tv ( samsung) is power off when beamer is running
Regards
Huh??
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29