Kodi Community Forum

Full Version: Set content over UPNP??
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5
@psrkallez06,
MediaImport is a feature that allows an instance of Kodi to act as a client which can import media items from a media server. Servers that are currently supported are
  • Another Kodi Instance (via UPnP)
  • Emby and/or Jellyfin Server
  • Plex Server
In your case you will be using the main machine as your server.

Before trying this out, use the LibreELEC backup feature to backup your install (Settings>LibreELEC>System>Create System and Kodi Backup)

Install this build on the both machines. It is compiled by me and based on LibreELEC 10.01 and Kodi 19.3 + MediaImport.
If your current install is LibreELEC 10 just upgrade, if it is LibreELEC 9, the advice from the LibreELEC Team is a clean install.

You may need to rescan your library.

For UPnP Sharing,
Settings>Services>UPnP/DNLA  Enable UPnP Support  (Both Machines)
and Import media items from UPnP Servers - Enabled  (Client)

Then add your imports
Settings>Media Sources (Client)
Thank you very much for your answer. I Will try this tonight Big Grin
@LongMan Do you have this in a img file also?
@psrkallez06,
I assume you wanted the same file but the img file
@LongMan 

Yes thank you very much, will report back after i have tried it!
@LongMan so i have it installed on both machines, followed your intructions. When i click Media sources > all media providers, the list it empty. any ideas?
Settings>Services>UPnP/DNLA  Enable UPnP Support  (Both Machines)
and Import media items from UPnP Servers - Enabled  (Client)


These two steps? The client should respond as soon as you enable
If i add a source from UPNP as normal i can find my main device. But in media sources i don't find anything. hmm
<setting id="services.upnp">true</setting>
    <setting id="services.upnpserver">true</setting>
    <setting id="services.upnpannounce" default="true">true</setting>
    <setting id="services.upnplookforexternalsubtitles" default="true">false</setting>
    <setting id="services.upnpcontroller" default="true">false</setting>
    <setting id="services.upnprenderer">true</setting>
    <setting id="services.upnpimport" default="true">true</setting>
Where do i add that?
Just check that you have the same values under Settings>Services>UPnP/DLNA. These are from guisettings file but you are not making changes there, make the changes on the settings page. The names are similar to the settings listed
Double checked. I have the same settings as above on both my devices, restarted multiple times. But the media providers list is still empty.. Any more ideas? Smile
And the are on the same network? I assume you can see the other machine over regular UPnP
Pages: 1 2 3 4 5