Kodi Community Forum

Full Version: Movies are in the database, but not displayed on Kodi - TMDB Python error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hello, I'm struggling with this problem since quite a while. All my movies are in the database, but not displayed on kodi.
I've setup all my movies in one big folder named "movies", and inside it, each movie is in its own folder. 
Image
In the media settings, I have the folder and everything seems to be configured correctly (I have manually access to the movies). Also, each time I restart Kodi, Kodi automatically fetch new contents and add it to the database.
Image
I also carefully checked the above setting specifiying that my movies are in separate folders.


Finally, in my database (which is a shared database), Kodi has indeed fetched every movies correctly:
Image
So if anyone has any idea Smile
Image
Seems it's not connecting to the shared database then. I don't use one myself so I'd suggest you double check everything here -

https://kodi.wiki/view/Syncing_and_shari...20protocol.
Good thing you added the red arrow (or cross), otherwise we might have missed things... Rofl

Start providing Kodi's debug log (wiki) (debug enabled), and the working or failing database connection should be apparent.
Thanks for your answers. (yeah sorry I've only mentionned my problem explicitly in the title of the thread).

I've looked at the logs and I have these errors :


2022-04-03 14:24:09.683 T:59008 ERROR : SQL: [MyVideos119] The table does not exist Query: select * from movie_view WHERE ((movie_view.playCount IS NULL OR movie_view.playCount = 0))
2022-04-03 14:24:09.683 T:59008 ERROR : CVideoDatabase::GetMoviesByWhere failed
2022-04-03 14:24:09.683 T:59008 ERROR : XFILE::CDirectory::GetDirectory - Error getting special://skin/playlists/unwatched_movies.xsp
2022-04-03 14:24:09.683 T:59008 DEBUG : dbiplus::MysqlDatabase::connect replacing configured host XXX.XXX.XXX.XXX with resolved host XXX.XXX.XXX.XXX
2022-04-03 14:24:09.700 T:65224 ERROR : SQL: [MyVideos119] The table does not exist Query: select * from movie_view
2022-04-03 14:24:09.700 T:65224 ERROR : CVideoDatabase::GetMoviesByWhere failed
2022-04-03 14:24:09.700 T:65224 ERROR : XFILE::CDirectory::GetDirectory - Error getting special://skin/playlists/random_movies.xsp]


which is weird because Kodi can actually write and access to it to add new movies (as I explained earlier).
It's like if Kodi has write access but not read access. I will search again and probably reconfigure my entire database.
We prefer to get the full kodi.log to via a pastebin-type website (so the forum server does not get cluttered, see the bold red text above the Post button). That way we get all the puzzle pieces.

So far, AFAICT:
- It's a MySQL database
- It is running okay since PHPMyAdmin is working.
- Kodi throws an error "The table does not exist".
- Possibly all database views have not been created properly because of insufficient database user rights.
- Run the query (select * from movie_view) from PHPMyAdmin to confirm to views' situation.
Okay, Here are the complete logs: kodi.log

In fact the subfolder movie_view doesn't exist. But the question is why? As everything should hav been created automatically, this one failed? 
ImageImage

My user rights are:

Image

(I also tried to connect with the root user but same result)
You should have the following views:
Image

In case you don't know: a database view is merely a set of combined fields from one or more tables. So all the database tables may exist, a "view" is created separately.

Apparently all the user rights seem fine, but creating the views is still a problem.
Can you exit Kodi, rename the MyVideos119 database to something else temporarily, and restart Kodi. That should prove if the views are created properly.
I've just deleted the databases, deleted my kodi user, uninstalled Kodi on my desktop, recreated the kodi user, reinstalled kodi.
So kodi was able to connect to mariadb, kodi just created automatically the two databases MyVideos119 and MyMusics82. I didn't touch anything, and here they are:

Image

They are still empty (neither musics, movies nor tvshows registered in there).
I'm gonna try what you suggest in a minute
Okay I've just found what was wrong. 
When I opened Kodi and Kodi was supposed to automatically create either MyVideo or MyMusic or both, Kodi would crash during the creation. Because of the crash, Windows automatically closed Kodi which prevented the creation of the databases from being completed.
Now I have all the databases, including the views. No more problem on this side.

But now I have another problem. Kodi doesn't write in the databases anymore.
I have this error while scanning movies using TMDB (happens recursively).
Image

the logs
Just wondering: What OS/NAS are you running MySQL/MariaDB on, and which version?
I'm running MariaDB on a DS920+ (with 4+16GB of RAM) on docker with a docker-compose file. 
I use the latest version: linuxserver/mariadb:latest which is 3.14
(2022-04-03, 17:57)thibaudbrg Wrote: [ -> ]I have this error while scanning movies using TMDB (happens recursively).

The complete debug log, please. We're not that fond of puzzling with only 1 or 2 pieces.
Sorry, I thought I was doing right..
Here are there: the logs
I've spent quite a lot of time on the forum and the github of TMDBPython and this issue seems to be quite frequent. But each time, a new release patches the bug. I currently have the latest version of TMDPython.
Also, the TV shows are working well on kodi. The thumbails are correctly loaded, but I don't think it's related, as it's TMDBTV shows and not TMDBPython.
@thibaudbrg

TMDBPython is the movie scraper. Your log shows no errors and no scraping of any movies.
Failing to write the database has nothing to do with the scrapers. That sounds like a MySQL problem.
Pages: 1 2