Kodi Community Forum

Full Version: [WINDOWS] HOW-TO use MCE remote in XBMC under Windows XP with IR Server Suite
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7
did anyone come into any issues, where your remote control wont work under vista media center now?

I needed to go back to using VMC, due to HD playback issues, VMC will not work with my remote.. i even uninstalled Server Suite and still have no luck

any ideas??
Does anyone has a map of all the keys on the MCE remote and what they are called
so we can use and configure keymap.xml file?
If you don't want to mess with the keymap.xml and also want to use your remote for Winamp, WMP classic and many more applications have a look at the following thread:
http://forum.xbmc.org/showthread.php?tid=38579
Thx a bunch. Worked like a charm =) Even got my harmony to work, perfect.
niko7865 Wrote:I upped the hold to repeat delay to 1,000ms, seemed to fix it.

Tried this and it still skips, anyone else found a way round it, ive also tried setting it to use the keyboard rateand this still dont work.

Really buggin me now lol was loving the fact that it works.

Cheers
sharktech Wrote:Tried this and it still skips, anyone else found a way round it, ive also tried setting it to use the keyboard rateand this still dont work.

Really buggin me now lol was loving the fact that it works.

Cheers

Hi there,
had the same problem. Fixed it with deregistering the mappings for those buttons. Try to just delete the lines up, down, left, right and select off your xbmc/system/IRSSMap.xml.
I think the problem was that windows also registers these buttons as keyboard handlers, so XBMC received them both.


btw. i LOVE xbmc for windows. Just started today because last version was kinda buggy for me Smile
thank you very much for porting
Hello,

I'm new to XBMC and currently using Mediaportal on my HTPC but a few days ago i stumbled upon the Atlantis 2 Beta release and installed it.

I played around, found the xTV skin and installed it and I must say wow, what an unbelievable look and feel Big Grin If XBMC is working properly, i will replace Mediaportal with it...

Now i'm trying to get my HP remote to run with XBMC. The basic navigation works but i cannot terminate a playing video and i'm not able to get the context menus inside Movies etc.

As far as understand the Keymap.xml is responsable for this and my question is if anybody already has an adapted XML file for my remote ?

Edit: I got it to work with the description and IR Serversuite (did not recognize it directely, sorry). Wink

Greetings
angryjack
I still have one little problem with my HP-MCE clone

Image

Everything works so far except the power down button but pressing the record button causes a proper shutdown

Code:
<remote>
<power>XBMC.ShutDown()</power>
<stop>Stop</stop>
<record>XBMC.ShutDown()</record>

Any idea what i can do to get the Power button to work ? Is there a program for XP where i can determine the button codes ?

angryjack
I'll second that for people finding this post. Ditch IR Server Suite and switch to EventGhost. I had nothing but problems with IRSS and EventGhost is easier to use and far more flexible. Includes a plugin for XBMC.
I followed the tutorial, but at the end when I start the.cmd file I get the following error message:

"Systemfehler 1060 augetreten"
Der angegebene Dienst ist kein installierter Dienst.
Der Name für den Dienst ist ungültig."

Now I try to translate Big Grin

"system failure 1060 occured.
service is not an installed service.
name of the service is not valid"

Anybody know where the problem is?


edit:
I found the solution: I had only .Net Framework 2.0 installed. With 3.5 everything is fine. RTFM Wink
sanssome Wrote:I'll second that for people finding this post. Ditch IR Server Suite and switch to EventGhost. I had nothing but problems with IRSS and EventGhost is easier to use and far more flexible. Includes a plugin for XBMC.

After several requests to the developer of IRSS, and several empty promises from him/her/them for a fix to the known issues, I have to agree.

EG is an active project and is a perfect fit with XBMC.
Is it just me or what? When I run XBMC without the IR server, all the data and configs are gone, so like it's a different profile. What the heck?

I also can't assign the power button. It doesn't work.
For some reason when I install those drivers, I get really snappy response from my remote, but once I reboot the system it gets all sluggish and the mute/volume buttons don't work in windows. If I update the transceiver driver again, it gets snappy again and the mute/volume works again. What gives?
How can I shutdown my pc, so not just shutting down XBMC, but the whole pc fromout a command?
Use this command in a command window or click Start, click Run and use it there.

C:\WINDOWS\SYSTEM32\TSSHUTDN.EXE 0 /DELAY:0 /POWERDOWN

It will stop all programs and shut doen the PC.

You can also try then command

SHUTDOWN -s -t 01
Pages: 1 2 3 4 5 6 7