Kodi Community Forum

Full Version: Vsync locks hd files at 20fps?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4
OK, so I spent the better part of this weekend building a box for xbmc and after an unbelievable amount of aggravation (getting linux to play nice with my hardware, not xbmc-related), I've managed to get most everything working. My problem is that if I enable VSync, HD movie files cap at exactly 20fps. SD files play fine, and if I disable VSync, HD files are fine too, but I get really irritating tearing.

It's definitely not a lack of CPU power (Core 2 Duo overclocked to 3.33) but I do worry it may be related to the video card (or lack thereof). Hardware acceleration is working in Ubuntu and I can use all the fancy compiz effects (they're disabled for running xbmc). Obviously it's not as powerful as anything nVidia or ATI makes, but it should be enough.

As a side note I'm happy to help others with some of the stuff I HAVE gotten to work properly, notably lirc working with a Harmony 880 and the built in IR receiver on my Fusion 430. I can even boot and shutdown the computer with the remote. That whole process sucked, but after a lot of trial and error and editing config files it works like a dream. I'm also pretty pleased at how easy digital out was to get working.

For reference I'm using
Ubuntu 8.10 Alpha6 (need it for hardware support)
Core 2 Duo E7200 overclocked from 2.53 to 3.33 (plenty of headroom left too)
Asus P5Q EM HDMI motheboard (Intel G45 based)
Pioneer PDP 5070 (fed by VGA running at 1360x760) because HDMI hates me)
2GB DDR2 800
Antec Fusion 430
Harmony 880
Just noticed something strange - I have a couple divx 720p files, and they play at their normal framerate (25fps). The rest of my hd files are h264, and lock at exactly 20.0 fps. If this were a performance thing, I'd imagine that number would vary at least a little. h264 sd content plays fine.
Got it (maybe I posted too quickly). Disabling high quality upscaling (Lanzcos) for HD content (left it on for SD) seems to have solved my problem. Not sure if this is a bug in xbmc or not...
Try something else than Lanzcos method

Vsync tries to lock at source fps, if that fails (due to hardware not keeping up --not necessarily CPU!) it clocks down.
It's generally an issue with 1080p output and Intel IGP gfx (due to poor drivers)

I am a bit surprised to learn G45 is having issues, but try something easier than Lanzcos
I'm having the same problem. 20 fps when using upscaling. Not a CPU problem. Didn't have the problem until I just upgraded to the latest PPA. Doesn't seem to matter which scaling method I use.
I see the same problem too.
has anyone found a fix for this (other than disabling the upscaling)?

I have vsync on in the ATI catalyst control center (this is to prevent general video tearing) - but when upscaling for SD content is on, framerate is locked at 20fps. I've loads of cpu to spare...
triple buffering may help, it's worth a shot anyways.
I see there is a bug filed for this item (or something similar)

It looks like it was dismissed out of hand as not being an issue.
Well it certiainly is - I think this bug should be re-opened.

The issue is simple, in a system with plenty of horsepower, with upscaling for SD content (what defines the 'SD' threshold) - some movies are locked to 20fps - and the cpu is not even taxed - maybe 30% usage..

My setup is outputting 1080p, ATI 4850 HD card, Q6600 @ 2.6G, but as I say, there is loads of cpu power left.

An interesting thing to note - even with upscaling for SD content on, and I play a medium resolution clip, I do not see this 20fps limitation - it only seems to be with certain clips.

Does anyone else see this - or are we a small minority here? Any developers or gurus out there that have low quality content that is affected by this?

Is there any switch or way to tell if upscaling is on or off for a particular clip?

I'm willing to try any and all exeriments. I would try tripple buffering, if only I knew how to turn it on!

why don't you do yourself a favor and examine the SOURCE FPS of said clips.

be they 23.97, 25 or 30fps ? make a list of this (it's VERY important) including CODEC and source resolution, and then we can continue the discussion
Good Idea, I'll do a comprehensive check for you and report back asap (hopefully after work tonight!)
I did a little digging on this -

Is there a way to upload screenshots here? I took screen dumps showing the frame-rate.

Anyway -
clip1- the office - xvid 624x352 - 24fps clip
clip2- iron man - xvid 640x252 - 24fps

Play both clips with upscaling for SD content-
clip 1: fps 19.5 - cpu % was fluctuating but max seen was 80%
clip 2: fps 23.95 - cpu 45%

turn off upscaling
clip1: fps 23.95 - cpu 9%
clip2: fps 23.95 - cpu 10%

system -ubuntu 8.04 32-bit - compiled from svn (updated yesterday), intel Q6600 (core2 quad, 2.6Ghz), ATI 4850 HD, 4 Gb ram (1gb sticks).
codes were installed from apt-get install (w32codecs).

Are there any special compile options I could try out to make this perform a bit better? Any other suggestions?
we don't use any external codecs, we only use ffmpeg.

which upscale option are you using ?

what brand & model of GFX card ?
I used the bicubic upscaling.
sinc - 5fps!
lanzcos - 15fps

Is this exepected?

maybe the cpu is a factor..REALLY surprising. I would have thought a core2 quad could do it. The code may not be multi-threaded, and I definitely did not compile with any mult-core options (if there are any).

I have an ATI 4850 HD card with 256Megs. Using catalyst 8.8 binary drivers.
I am seeing similar issues with my videos now that I didn't used to see before - I'm not sure what's going on. Video that used to be perfectly smooth not judders during fast movements - but I never drop a frame. I have also suddenly lost stereo audio - surround works. Not sure what happened with this. Last but not least errors about inefficient VFW B frames have shown up in my logs and XBMC will crash to the desktop on some vids. This is all pretty weird afterhaving a system that worked great for so long Sad

Edit: Made some changes... Fixed audio by following the sticky. Not ever had it screw up that way before. Now the music works again and doesn't crash - weird. I turned off V-sync in XBMC and that SEEMS to have helped the juddering. I will have to screw with it more though to be sure, my eyes are buggy from looking at this!
In my experience, issues with HQ SW upscale is either

*Slow Shared (unified, shared cpu and gpu) Ram Memory
*Slow Bus to said Ram
*Crap Drivers
Pages: 1 2 3 4