Kodi Community Forum

Full Version: PreRoll PostRoll
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
Hello There Lunatixz,

Just a couple of notes, 
Pre-Roll, Almost never seen, one bumper here or there, but hardly ever, this is with settings from 1% to 100%, no change.
Post-Roll, HEAPS, lots and lots, again wether switched to 1% or 100%, I've seen up to 10 in a row in one channel.
Image

Also, would it be possible to put a switch in the channel manager to switch off pre and post roll in each channel, Although, I love them, A preview or commercial in a music video channel is no good. 
I am also getting a lot of crashes in the last build, but I noticed you updated 0.4.9n today and I havent tested it yet, so, who knows.

Thanks again.
Oz
Copied all the Trailers Commercials and Bumpers all into the Bumpers Directory, Set PreRoll Off and Post Roll to 5%.
Well over one hour to first build channels list. Turning off or the inevitble crash means another update of the channel list.
Changing of Channel logo is also causing a fault in the last update to 0.4.9n
and some more information, I did another Clean install today, The first build of all the channels is pretty quick, maybe 15 minutes for 107 channels, however as it goes through again, pretty much straight after the first build, and updates channels, the build slows to a crawl, taking well over 2 hours to build. With nothing continuing to play from the channel manager while the channels are rebuilding and its not very good.
Also, just to add to that, after it has done a full build and the computer shut down for the night, upon running the next day, when the channels start to update, on 40 to 70% of the channels we get a No Content Found, Skipping Channel message. At this point the only fix, is to do a full rebuild, so this taking around 3 hours makes it unwatchable unless you want to watch a program from the guide, then channel surf to your next show.
Without a log I can not debug... I do not experience these issues. THX
No Worries, will do another clean install and run and provide a log.
Hello Lunatixz,

Did another clean install setting up version 0.4.9p

Play From Here or Switch to Channel not working while updating channels.

Channel Update takes over 2.5 hours with 106 Channels, 70% YouTube Channels and 30% Local Channels. Switching back to 0.4.9j makes this much faster at around 30 to 45 minutes. Down to 15 to 20 minutes switching off Pre and Post Roll.

Can't navigate in the Channel Manager While Updating, Current Selection of program jumps back to the current time line marker when the timeline marker movers.

Pre and Post Roll work better at 0.4.9j than at 0.4.9p. 

To stop Fillers populating certain channels, In the Resource folders for Adds, Trailers and Bumpers I have added a folder Addon, then in the Channel Manager I added the option "Addon" in the media genre section.
However the Fillers just keep adding to every Channel.

I have the option for Fillers set to One Insert Only and Random Change is set to 10%, however I am getting 4 or 5 Trailers in a row.

The Bumpers work fine for the Premade Bumpers, However anything I add to that collection will not show up. I added a few Custom Bumpers here and deleted the premade ones as a test, and then none are showing.
Is there a config somewhere listing the Installed bumpers, or do they have to be in a certain format. I made the Bumpers in MKV at the same size, but still they dont show.

I made a Log file, but at 2.5 hours the log file was HUUUUUGE. However if you still want the log file, I will upload it.
Oh yeah, forgot to add, After the initial channel build. If Kodi is shut down or crashes, when PTVL starts again and does a channel rebuild or Channel update over the old channel list, it will wipe out maybe 20% of channels, getting the message No Content Available, Skipping Channel. At this point you will have to do a clean start from the options menu to rebuild all channels.
Without logs I can not confirm. 

As for your pre/post roll test; PseudoTV was not designed for for multiple "clean starts" and unless done properly you maybe calling cached data.

pre/post rolls only apply to specific content.

Bumpers - TV channel types and content.
Ratings - Movies channel types and content.
Adverts - TV channel types and content.
Trailers - TV/Movie channel types and content
Thanks for the Reply, I see where the difference lies now in Pre-Post Roll, thanks for that.
The Clean Start is done on a build of Kodi with no Add-Ons which i keep in Backup. Then Transfer it to the main drive and add YouTube and PTVL for testing purposes.
Currently I am running 0.4.9j as a functioning build, although I get a few crashes, but It's build time for channels is faster, and it's control over pre-post roll seems better.
I will run another full scale test today and log the results.
Ok, So per your request, I took my working 0.4.9j version and updated to 0.4.9p, turned on logging and Then Ran and let PTVL do its thing. 
https://www.ozdrdj.com/kodi1.log
https://www.ozdrdj.com/settings1.xml
https://www.ozdrdj.com/pseudotv1.m3u
There it is in all its huge glory. Almost an Hour and a half to do it's update. (This is on my Main PC i914900k, 32gb with GeForce 3090ti 12gb, the media machines are older i5s with 16gb and take longer.) I include the settings and m3u, just in case. In this instance PTVL only found 78 of the 106 channels. Telling me the others had no content. However, doing a clean start and running again rebuilding the entire guide, all channels are present. Also in this instance The channels were unwatchable, telling me the guide was out of sync and needed to update, but that wasn't happening while the channels were updating again.

If PTVL hits a deleted video in the playlist, it causes it to hang.

Added content to the Bumpers Channel is not adding in. I tried making them the same sort of length and in the same MKV format, but no. Is there somewhere to tell PTVL there is extra content. Even if I only put my own content there and delete the supplied content they still don't play. 

Channels won't continue to play while channels are updating, but that also happens back at 0.4.9j, is it possible that is to do with IPTV or Kodi or something else?

Can't navigate in the Channel Manager While Updating, Current Selection of program jumps back to the current time line marker when the timeline marker moves. I also have the guide different in that the timeline markers are at 15minute intervals instead of 30mins so that the shorter Music Videos are somewhat visible. I don't know if that makes a difference.

While Channels are rebuilding, you have to be very careful moving around the channel guide or fear a dreaded crash meaning we are doing another restart and the channel guide starts building again.
(2024-06-06, 10:07)OzDrDj Wrote: [ -> ]Ok, So per your request, I took my working 0.4.9j version and updated to 0.4.9p, turned on logging and Then Ran and let PTVL do its thing. 
https://www.ozdrdj.com/kodi1.log
https://www.ozdrdj.com/settings1.xml
https://www.ozdrdj.com/pseudotv1.m3u
There it is in all its huge glory. Almost an Hour and a half to do it's update. (This is on my Main PC i914900k, 32gb with GeForce 3090ti 12gb, the media machines are older i5s with 16gb and take longer.) I include the settings and m3u, just in case. In this instance PTVL only found 78 of the 106 channels. Telling me the others had no content. However, doing a clean start and running again rebuilding the entire guide, all channels are present. Also in this instance The channels were unwatchable, telling me the guide was out of sync and needed to update, but that wasn't happening while the channels were updating again.

If PTVL hits a deleted video in the playlist, it causes it to hang.

Added content to the Bumpers Channel is not adding in. I tried making them the same sort of length and in the same MKV format, but no. Is there somewhere to tell PTVL there is extra content. Even if I only put my own content there and delete the supplied content they still don't play. 

Channels won't continue to play while channels are updating, but that also happens back at 0.4.9j, is it possible that is to do with IPTV or Kodi or something else?

Can't navigate in the Channel Manager While Updating, Current Selection of program jumps back to the current time line marker when the timeline marker moves. I also have the guide different in that the timeline markers are at 15minute intervals instead of 30mins so that the shorter Music Videos are somewhat visible. I don't know if that makes a difference.

While Channels are rebuilding, you have to be very careful moving around the channel guide or fear a dreaded crash meaning we are doing another restart and the channel guide starts building again.

Channels should not take an hour to populate; this to me is a clear sign something is wrong. It looks to me like you are over parsing your youtube playlists... all those calls are slowing things down.
I recommend trying to download youtube content locally.
...and the others?
For the moment i have reduced pagination back to 25 and turned off Fillers running 0.4.9j this is the best speed.
Why do you think it takes only about 15 minutes to build all the channels but 2 hours to update? Plus finding No Content when updating and wiping the channels?
(2024-06-07, 11:33)OzDrDj Wrote: [ -> ]...and the others?
For the moment i have reduced pagination back to 25 and turned off Fillers running 0.4.9j this is the best speed.
Why do you think it takes only about 15 minutes to build all the channels but 2 hours to update? Plus finding No Content when updating and wiping the channels?

There is a lot going on with your log; you've clearly been tinkering...

If you want to heavily use this project for Youtube channels you'll have to start creating strms with nfos or move to locally downloaded youtube content.

The major factor for your slow channel building is your youtube plugin channels and the need to parse it's missing duration meta.
(2024-06-07, 21:08)Lunatixz Wrote: [ -> ]The major factor for your slow channel building is your youtube plugin channels and the need to parse it's missing duration meta.

Is there a reason this is needed? The plugin includes the duration for listitems as part of the video infotag, for both the resume point duration and the actual duration, and also includes the duration for the associated video stream info. Is there somewhere else that PseudoTV Live is trying to get this information?

Perhaps you could write up a brief list of minimum details you need for the plugin to work properly? Also the general method you are using to traverse directory listings from other plugins?

One issue I can see that may contribute to this issue is that the YouTube channels do not have a flat directory structure, and have different nested folders and subfolders for different playlists.
Can any Kodi addon from Rare toon India .net
Please I need it . Can some one make
Pages: 1 2 3