Kodi Community Forum

Full Version: Can the user force XBMC to use user defined SDL_AUDIODRIVER device?
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,

Try to start up xbmc with (preinstalled all necessary libsdl plugins)

env SDL_AUDIODRIVER=esd ESPEAKER=192.168.*.* xbmc

where *.* was replaced by the real ip of the esd/pulseaudio server.

The system sound (usually heard when you press the up/down arrow for instance) can be heard on the espeaker server. However the movie playback is total silent. Is there a specific option in the configuration file to force movie/audio playback use such user defined SDL audio device?

Many thanks.
not sure if it's any help, but have a look at this thread:

http://forum.xbmc.org/showthread.php?tid=30680
s7mx1 Wrote:Hi,

Try to start up xbmc with (preinstalled all necessary libsdl plugins)

env SDL_AUDIODRIVER=esd ESPEAKER=192.168.*.* xbmc

where *.* was replaced by the real ip of the esd/pulseaudio server.

The system sound (usually heard when you press the up/down arrow for instance) can be heard on the espeaker server. However the movie playback is total silent. Is there a specific option in the configuration file to force movie/audio playback use such user defined SDL audio device?

Many thanks.

Movie playback uses the Alsa driver directly, whereas the navigation sounds use SDL. That's why you're able to hear the navigation sounds through your espeaker.

If you can configure Alsa to act as an espeaker then it should work similarly (never tried it though and don't know if Alsa supports it).