Kodi Community Forum

Full Version: Problem Playing a File from DVD
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi all,

I run XBMC Beta2 on Linux (Ubuntu 8.04) and have a problem when trying to play an AVI file, burned on a DVD disk.

I have a file of 1.3 GB in AVI format (named it "SOME FILE NAME.avi") which I wanted to play on HTPC. I burned it on a DVD disk (using the DVD disk as a storage only) and verified on my laptop the disk mounts and the file can be played fine. (The disk was burned on my Fedora 8 laptop using Nautilus - the default Gnome file manager; the file itself is also OK - XBMC can play it over the network from a Samba share).

Next, I inserted the disk in my XBMC box. It auto-mounted the disk (to /mnt/cdrom), but then refused to play it. On-screen message said "Too many consecutive failed items...". I have the XBMC debug log enabled, so here is the output:


I have no problem playing similar AVI files from CDs, but this is the first time I tried a DVD as a storage. In the log, XBMC says it fails to read the disk as iso9660:// - could this be the problem? When mounted on the laptop, mount command says the filesystem type is ISO9660.

Any ideas will be much appreciated.

More on the problem - XBMC fails also with a DVD+R disk - tried a disk with 100+ MP3 files on it. XBMC shows all the directories and files, but refuses to play any of it. Same files are played fine if burned on a CD. Same DVD+R disk is played fine on any other Linux desktop, so it is definitely not the disk itself.

This is getting a serious error for me, having most of my files on DVDs.

Any ideas anybody? Nobody else keeps his files on DVDs?


i have exactly the same problem, too.

Playing Avi/mkv files from DVD doesn't work. It works fine from CDs.

Does anybody know a solution?

I have this problem, too. I can either only play the first movie on the cd/dvd or no movie at all. With most disk I can play the first movie though.

I'm updating my XBMC to the latest svn version atm. I will let you know if the bug is gone.

I wrote a patch to fix this bug: http://trac.xbmc.org/ticket/5296