Kodi Community Forum

Full Version: [LINUX] HOW-TO configure Soundgraph iMON VFD/IR Receiver (used by many HTPC chassis)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19
OK, forth post. Here's how to get the iMon remote and front panel display (iMon PAD and 2x16 VFD display in my case) working in Camelot with minimal effort. This was all done after a fresh install of Camelot (XBMC Live 9.11) so I'm not sure if these instructions will work for an upgraded or non-Live install. YMMV. A lot of the instructions come from here: https://help.ubuntu.com/community/IMON_V...armic_9.10

First off, SSH into your machine or press CTRL+ALT+F1 to get to a command prompt and login. Then:

Code:
sudo dpkg-reconfigure lirc

Scroll through the list to find your remote and display combo and press enter. In my case this was the Soundgraph iMON PAD IR/VFD. Leave the transmitter as none and press enter.

Next, run:

Code:
sudo nano /etc/modprobe.d/lirc.conf

And paste the following:

Code:
options lirc_imon nomouse=1 display_type=1 pad_thresh=5

Refer to the above page for alternate options, especially the display_type, which will depend on your case. Save and exit the file.

Now run:

Code:
sudo /etc/init.d/lirc restart
irw

Now press some buttons on your remote. Assuming you chose the correct option from the first step you should see the commands appear as you press buttons. If not, just go back to the first step and choose a different option. Press CTRL+C to exit irw. You're half way there!

Now run:

Code:
sudo apt-get update
sudo apt-get install lcdproc
sudo nano /etc/LCDd.conf

Scroll to line 44, where you should see a Driver=curses line. Change it to:

Code:
Driver=imon

The above works for the 2x16 VFD displays. If you have an LCD display then you want to use Driver=imonlcd instead.

Further down the file you'll find another line:

Code:
#ServerScreen=no

Remove the # from this line, then save and exit.

Code:
sudo /etc/init.d/LCDd restart

Now you should see the display come to life. That's the hard part done! Now we just need to configure XBMC itself.

Code:
nano ~/.xbmc/userdata/Lircmap.xml

This is where you setup the buttons on the remote to match commands in XBMC. Here's my Lircmap.xml, which works with the iMon PAD remote:

Code:
<lircmap>
    <remote device="iMON-PAD">
        <left>Left</left>
        <right>Right</right>
        <up>Up</up>
        <down>Down</down>
        <select>Enter</select>
        <back>Esc</back>
        <back>Backspace</back>
        <menu>Menu</menu>
        <info>AppExit</info>
        <display>Thumbnail</display>
        <title>MultiMon</title>
        <play>Play</play>
        <pause>Pause</pause>
        <reverse>Rewind</reverse>
        <forward>FastForward</forward>
        <skipplus>NextChapter</skipplus>
        <skipminus>PrevChapter</skipminus>
        <stop>Stop</stop>
        <zero>0</zero>
        <one>1</one>
        <two>2</two>
        <three>3</three>
        <four>4</four>
        <five>5</five>
        <six>6</six>
        <seven>7</seven>
        <eight>8</eight>
        <nine>9</nine>
        <power>Power</power>
        <myTV>MyTV</myTV>
        <mymusic>MyMusic</mymusic>
        <mypictures>MyPhoto</mypictures>
        <myvideo>MyMovie</myvideo>
        <record>Record</record>
        <start>AppLauncher</start>
        <volumeplus>Vol+</volumeplus>
        <volumeminus>Vol-</volumeminus>
        <channelplus>Ch+</channelplus>
        <channelminus>Ch-</channelminus>
        <pageplus>Ch+</pageplus>
        <pageminus>Ch-</pageminus>
        <mute>Mute</mute>
        <star>ShiftTab</star>
        <hash>Tab</hash>
        <subtitle>Caption</subtitle>
        <language>Language</language>
    </remote>
</lircmap>

Tip: To find what to put under remote device and the names of each button for your remote, have a look at the last line of /etc/lirc/lircd.conf to find your remote's config file, then look in that file for your remote's settings. Put whatever appears under name as your remote device and then scroll down to get a list of button names. Also feel free to assign a function to multiple buttons as I've done with the back option.

Save and exit. Now do:

Code:
nano ~/.xbmc/userdata/LCD.xml

And tweak this file to your liking. This file assumes your display has four lines available, but as mine only has two I have to remove some lines and append existing lines with extra commands. It's up to you what you do with this, really. I also like to remove the <disableonplay>video</disableonplay> line so that I still get a display while videos are playing.

And that's it! Restart your system for luck, and make sure you enable the remote and LCD/VFD in XBMC's settings!

Enjoy. Smile
Ok... After 4 hours of try and error I finally got the imonlcd and the remote to work - but I don't like the crappy remote with it's way too less keys and it's special battery.

My case is an antec microfusion 350 - the libconfig the worked is named "Soundgraph iMon Antec Veris"

Is there a way to use another remote ?
Didn't manage irrecord to recognize any of my alternatives Sad
I've got a CoolerMaster CM260 with iMon VFD and PAD remote. Using MaximumFish's post I got everything to work. But when I turn of my XBMC (Live) box then the info on the display remains. How do I get XBMC to turn the VFD off or at least clear it?
MaximumFish' instructions are working in 10.04 as well. Confirmed Smile
Well. Actually after some testing lcd is not working. After installation and restarting daemon for the first time I saw Hello on it. XBMC showed nothing (lcd is on there), after reboot lcd doesn't show anything as well.
Reinstalled it, checked parameters once more.
Doesn't work Sad

Well. That's why sometimes I'm thinking of to throw away this damn ubuntu!
The bug is described here
https://bugs.launchpad.net/ubuntu/+sourc...bug/517956
You have to apply patch manually.
VFD is working correct over here. Only one problem with resuming from hybernate but I had that problem with the 9.11 version too. There's a fix somwhere for that.

My remote isn't working a 100% though. When I use the IR receiver from the iMON and a Logitech remote with MCE settings I can't get it to work Sad When I use the PAD settings in the logitech it's somewhat working but my guide & info buttons are all funky and weird.. I would realy like to use the MCE settings since the've always worked great. Anyone got a tip?
Is there an updated guide for Ubuntu lucid 10.04 ?
(I have a Silverstone ML02)

The following doesnt work for me because there is no such directory:
sudo mount -t usbfs none /proc/bus/usb


So it is not possible for me to finish the guide Sad
Hi guys

I'm using this tutorial to help me configure Imon VFD and remote control in Karmic Koala 9.10. Please any comments about it are welcome!

First, I'm not sure which one is my screen! If is VFD ou LCD. I compared with Image and Image and I don't think that looks like any of these ones! Mine is like this:

Image

...And when I push a button, it changes to this:

Image

That's the result of my lsusb:
Code:
Bus 005 Device 002: ID 15c2:ffdc SoundGraph Inc. iMON PAD Remote Controller

So, each one is mine?

Second, someone can tell me if XBMC use LCDProc to send some message to VFD/LCD? I'm using the SVN version 32246. There's an option in the System configuration, but I don't if XBMC really use the VFD/LCD.

If not, How could I test my VFD/LCD? I'm tried a plugin to amarok but amarok couldn't load it.

Remote control:

First, I'm using this remote Image
but just the knob, power button and the mouse click buttons are working and I don't have any idea how to make the others work. I used the mode2 and corrected the codes in /usr/share/lirc/remotes/imon/lircd.conf.imon-knob.

Code:
#
# this config file was automatically generated
# using lirc-0.8.0(imon_pad) on Sun Apr  2 20:21:17 2006
#
# contributed by
#
# brand: iMON Knob SoundGraph
# model no. of remote control: iMON Knob
# devices being controlled by this remote: iMON Knob
#

begin remote

# name  IMON_KNOB
# bits           32
# eps            30
# aeps          100

  #one             0     0
  #zero            0     0
  #gap          119990
  #toggle_bit      0

name    iMON-PAD
bits            32
eps             30
aeps            100
one             0       0
zero            0       0
gap             235965
min_repeat      1
toggle_bit      0

      begin codes
          AppExit                  0x288195b700003901
          Power                    0x289115b700003901
          Record                   0x298115b700003901
          Play                     0x2a8115b700003901
          Open                     0x29b195b700003901
          KnobVolUp                0x000100ff00003901
          KnobVolDown              0x010000ff00003901
          KnobMute                 0x000008ff00003901
          Rewind                   0x2a8195b700003901
          Pause                    0x2a9115b700003901
          FastForward              0x2b8115b700003901
          PrevChapter              0x2b9115b700003901
          Stop                     0x2b9715b700003901
          NextChapter              0x298195b700003901
          WindowsKey               0x2b8195b700003901
          Backspace                0x28a115b700003901
MouseKeyboard            0x299115b700003901
          SelectSpace              0x2a9315b700003901
          MouseMenu                0x28b715b700003901
          MouseRightClick          0x688481b700003901
          Enter                    0x28a195b700003901
          MouseLeftClick           0x688301b700003901
          CursorLeft               0x6aba81b700003901
          CursorUp                 0x6902f9b700003901
          CursorRight              0x68a2b1b700003901
          CursorDown               0x6882a1b700003901
          Esc                      0x2bb715b700003901
          Eject                    0x299395b700003901
          AppLauncher              0x29b715b700003901
          MultiMon                 0x2sb195b700003901
          TaskSwitcher             0x2s9395b700003901
          Mute                     0x2b9595b700003901
          VolUp                    0x28a395b700003901
          VolDown                  0x28a595b700003901
          ChUp                     0x289395b700003901
          ChDown                   0x288795b700003901
          Timer                    0x2b8395b700003901
          1                        0x28b595b700003901
          2                        0x2bb195b700003901
          3                        0x28b195b700003901
          4                        0x2a8595b700003901
          5                        0x299595b700003901
          6                        0x2aa595b700003901
          7                        0x2b9395b700003901
          8                        0x2a8515b700003901
          9                        0x2aa115b700003901
          ShiftTab                 0x28b515b700003901
          0                        0x2ba595b700003901
          Tab                      0x29a115a700003901
          MyMovie                  0x2a8515a700003901
          MyMusic                  0x299195a700003901
          MyPhoto                  0x2ba115a700003901
          MyTV                     0x28a515b700003901
          Bookmark                 0x288515b700003901
          Thumbnail                0x2ab715b700003901
          AspectRatio              0x29a595b700003901
          FullScreen               0x2aa395b700003901
          MyDVD                    0x29a295b700003901
          Menu                     0x2ba385b700003901
          Caption                  0x298595b700003901
          Language                 0x2B8595b700003901
# these codes may be wrong, but they were included in the first version of
# this config file
          0                        0x2BA595BF
          NextChapter              0x298195BF
          Thumbnail                0x2AB715BF
           FullScreen               0x2AA395BF

    end codes

end remote

Second, I didn't understand how I can change function of the buttons to something useful to me, like to XBMC ou in the Ubuntu itself. Someone could give an example, please?

Thanks!
On this page it says the case has an LCD: "Multimedia control by iMON (NEW iMON LCD)".

Follow this tutorial, choose Soundgraph iMon PAD IR/VFD and set Driver=imonlcd in /etc/LCDd.conf

I'm running XBMC SVN r32246 on Ubuntu Karmic minimal and the tutorial above did the job for me. Setting it up correctly will give you all the controls you need in XBMC.
Well guys, my remote is working, but all of sudden, it doesn't turn off my PC anymore. When I use the red shut down button, use to appear the ubuntu's shutdown window. Now that doesn't work anymore. There are any configuration that makes the shutdown option in XBMC to really shutdown the OS?

And the LCD is alive, but don't show anything from XBMC. I turned on the option in the Settings, but nothing. I tried configuring the info to be the same size of the 12 display of my imon lcd. In the /etc/LCDd.conf, i changed the LCD size to 1x12, but still nothing. What could it be?
OK, so I am a Noob when it comes to Linux and does not know a great deal about how to fix things, but here is my problem:

I used this guide to set up the IR and VFD in my Silverstone LC-16 MR case. It worked like a charm with the remote but then I got into problems with the VFD.
I got it to light up but it only display a lot of garbage and I get this time-out error on the console screen. I think this is due to a timing error between the display and LIRC (based on what I found on other pages) but I do not understand how I can correct this. I said on another page to just insert a delay between the sent characters and that makes sens. But where can I insert this delay? In some config file or ?
Hello , i have ubuntu 10.10 and new version of xbmc

well i have problem with imon and xbmc doesn't work fine (but in my old ubuntu 9.10 work fine),

i have this display in my nox live2 carcase
Image

Quote:Bus 006 Device 002: ID 15c2:0038 SoundGraph Inc. GD01 MX VFD Display/IR Receiver

my lirc config selected
Quote:Soundgraph iMON Antec Veris

with this remote controll

Image


Quote:lircd -v
lircd 0.8.7-pre3

Quote:lcdproc -v
LCDproc 0.5.3

hardware.conf
Quote:# /etc/lirc/hardware.conf
#
#Chosen Remote Control
REMOTE="Soundgraph iMON Antec Veris"
REMOTE_MODULES="lirc_dev lirc_imon"
REMOTE_DRIVER=""
REMOTE_DEVICE="/dev/lirc0"
REMOTE_SOCKET=""
REMOTE_LIRCD_CONF="imon/lircd.conf.imon-antec-veris"
REMOTE_LIRCD_ARGS=""

#Chosen IR Transmitter
TRANSMITTER="None"
TRANSMITTER_MODULES=""
TRANSMITTER_DRIVER=""
TRANSMITTER_DEVICE=""
TRANSMITTER_SOCKET=""
TRANSMITTER_LIRCD_CONF=""
TRANSMITTER_LIRCD_ARGS=""

#Enable lircd
START_LIRCD="true"

#Don't start lircmd even if there seems to be a good config file
#START_LIRCMD="false"

#Try to load appropriate kernel modules
LOAD_MODULES="true"

# Default configuration files for your hardware if any
LIRCMD_CONF=""

#Forcing noninteractive reconfiguration
#If lirc is to be reconfigured by an external application
#that doesn't have a debconf frontend available, the noninteractive
#frontend can be invoked and set to parse REMOTE and TRANSMITTER
#It will then populate all other variables without any user input
#If you would like to configure lirc via standard methods, be sure
#to leave this set to "false"
FORCE_NONINTERACTIVE_RECONFIGURATION="false"
START_LIRCMD=""


lircd.conf
Quote:#
#It includes the default configuration for the remote and/or
#transmitter that you have selected during package installation.
#
#Feel free to add any custom remotes to the configuration
#via additional include directives or below the existing
#Ubuntu include directives from your selected remote and/or
#transmitter.

#Configuration for the Soundgraph iMON Antec Veris remote:
include "/usr/share/lirc/remotes/imon/lircd.conf.imon-antec-veris"

can you help me?

Thank you.
Hi mates
Can anybody help?
I`ve been trying that:
https://help.ubuntu.com/community/IMON_VFD_and_LCD
but without result
now when i restart lirc i get error
Quote:[email protected]:/home/mario_dnb# sudo /etc/init.d/lirc restart
* Stopping remote control daemon(s): LIRC [fail]
* Loading LIRC modules [ OK ]
* Unable to load LIRC kernel modules. Verify your
* selected kernel modules in /etc/lirc/hardware.conf

can anybody help me? please Tongue
can anyone update on how to get this working in ubuntu 11.10?

that would be great !!!Big Grin
can anyone clarify for a noob - do the below instructions work in ubuntu 11.10? or is there now an easier way for non-linux proficient users ?

http://forum.xbmc.org/showpost.php?p=491...tcount=256
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19