Kodi Community Forum

Full Version: [AppleTV] HOW-TO disable the Apple TV auto-update (ATV)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3
1) Open terminal
2) type: ssh appletv.loca" class="mycode_email">[email protected]appletv.local
3) type password: frontrow
4) type: sudo bash -c 'echo "127.0.0.1 mesu.apple.com" >> /etc/hosts'
5) close terminal
Any chance you could tell us how to downgrade from 2.3 to 2.2?

EDIT: found in other post
http://wiki.awkwardtv.org/wiki/OSupdate
zedzed Wrote:Any chance you could tell us how to downgrade from 2.3 to 2.2?

EDIT: found in other post
http://wiki.awkwardtv.org/wiki/OSupdate

Update - I tried to downgrade to 2.2 but got the following error after following the instructions on the page above

Command I enter = sudo ./2Z694-5499.dmg

Error I get = Cannot execute binary file

Update - did a factory restore to v1.0 but the upgrade to 2.2 still does not work
zedzed Wrote:Update - I tried to downgrade to 2.2 but got the following error after following the instructions on the page above

Command I enter = sudo ./2Z694-5499.dmg

Error I get = Cannot execute binary file

Update - did a factory restore to v1.0 but the upgrade to 2.2 still does not work

You need to read the guide again, there is no reference to the above command.

The correct command-line would be
Quote:sudo ./osupdate
My bad since I thought the OSUPDATE was a placeholder for the update file name.
davilla Wrote:1) Open terminal
2) type: ssh appletv.loca" class="mycode_email">[email protected]appletv.local
3) type password: frontrow
4) type: sudo bash -c 'echo "127.0.0.1 mesu.apple.com" >> /etc/hosts'
5) close terminal

<thought>
Couldn't ATV USB Creator do this by default and then there could be an option in XBMC/Boxee Launcher to remove this line to allow updates?
</thought>
^ Following on from that - are there simple instructions on how to re-enable the Update process. Cheers.
PHP Code:
sudo sed '$d' < /etc/hosts file2 sudo mv file2 /etc/hosts 
Whenever I try to SSH into my ATV it immediately says connection closed by <ip of my ATV>... any ideas?
I ran the command to add the loopback for mesu.apple.com and then decided to look at the hosts file. I can see the entry in there twice. Is there a way to remove the 2nd line? I can't locate vi on the ATV, so I'm not sure how to edit the file. Thanks, Eric
flipp3r Wrote:I ran the command to add the loopback for mesu.apple.com and then decided to look at the hosts file. I can see the entry in there twice. Is there a way to remove the 2nd line? I can't locate vi on the ATV, so I'm not sure how to edit the file. Thanks, Eric

sudo nano /etc/hosts

control-x to save and exit
Quick question..... After I've entered the line as well as the frontrow password, how do I know if it works? I just get a -bash-2.05b$ . Am I supposed to see something else, or is this confirmation it' s taken?
Sekou Wrote:Quick question..... After I've entered the line as well as the frontrow password, how do I know if it works? I just get a -bash-2.05b$ . Am I supposed to see something else, or is this confirmation it' s taken?

look and see Smile

cat /etc/hosts
I haven't downgraded to 2.2, I'm still on 2.3, so other than waiting for a new update from Apple, how do I check to see if it's worked?
Sekou Wrote:I haven't downgraded to 2.2, I'm still on 2.3, so other than waiting for a new update from Apple, how do I check to see if it's worked?

Already told you, if it's in /etc/hosts, it's blocked.
Pages: 1 2 3