Kodi Community Forum

Full Version: Crash when changing movie or TV show information.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Altantis / XBMC 8.10, MediaStream Skin 9.7, Ubuntu i686 8.04

The following always crashes the system for any movie or TV Show I try to manually update or override what the search finds on its own. It happens in all skins I have tried and does NOT happen with the same version on my AppleTV.

Library or File mode:
Select a Movie or TV Show
Select "More Information" from the context menu
Choose "Refresh"
Select the title you want to use
Instant Crash

From the debug log:

21:01:11 T:3054122880 M:2977632256 DEBUG: ------------------- GUI_MSG_WINDOW_INIT
21:01:11 T:3054122880 M:2977632256 DEBUG: Progress dialog
21:01:11 T:3054122880 M:2977632256 DEBUG: -------------------
21:01:11 T:3054122880 M:2977632256 DEBUG: Load DialogBigButtonFO.png: 0.5ms (bundled)
21:01:11 T:3054122880 M:2977632256 DEBUG: Load DialogBigButtonNF.png: 0.4ms (bundled)
21:01:11 T:3054122880 M:2977632256 DEBUG: Alloc resources: 1.06ms (0.01 ms skin load, 0.10 ms preload)
21:01:11 T:3054122880 M:2977632256 DEBUG: Load DialogProgressBG.png: 0.9ms (bundled)
21:01:11 T:3054122880 M:2977632256 DEBUG: GetMovieId (/home/jasonk/Videos/Movies/The Godfather/The Godfather (part I).avi), query = select idMovie from movie where idFile=670
21:01:11 T:2876758928 M:2984046592 DEBUG: Running thread 2876758928
21:01:11 T:2876758928 M:2984046592 DEBUG: thread start, auto delete: 0
21:01:11 T:2876758928 M:2984046592 DEBUG: SECTION:LoadDLL(Q:\system\ImageLib-i486-linux.so)
21:01:11 T:2876758928 M:2984046592 DEBUG: Loading: /usr/share/xbmc/system/ImageLib-i486-linux.so
21:01:11 T:2876758928 M:2984046592 INFO: msg: PICTURE::LoadImage: Unable to open image: /home/jasonk/.xbmc/userdata/Thumbnails/Video/Fanart/b1b42381.tbn Error: (2)
21:01:11 T:2876758928 M:2984046592 ERROR: PICTURE: Error loading image /home/jasonk/.xbmc/userdata/Thumbnails/Video/Fanart/b1b42381.tbn
-------------------------------

I have verified that the file it is looking for does not exist. Should it?

Any ideas? Thanks!
Nope, works fine here. Can you post the entire log to pastebin.com or similar? Also, try renaming your ~/.xbmc dir and loading xbmc with fresh defaults (you can replace it later if it doesn't solve anything).
actually i got the same problem and it happens when a movie shares the name with another one. e.g. xbmc recognized the matrix as matrix revolutions and i also have matrix revolutions so when i try to change the first one the the actual title it crashes.

hope you understand what i mean
sandy malteser Wrote:actually i got the same problem and it happens when a movie shares the name with another one. e.g. xbmc recognized the matrix as matrix revolutions and i also have matrix revolutions so when i try to change the first one the the actual title it crashes.

hope you understand what i mean

You are exactly right! Thank you for pointing this out. I had this issue with the Godfather series (it thought both I and II were "Godfather II") and then again with "How The Grinch Stole Christmas" - the TV cartoon and the Jim Carry movie. I just never put two and two together.

The way I have been working around it is to rename the directory or files and do a Library clean then "Scan for new content". So, for the Godfather issue, I renamed the "Godfather I" dir to "Godfather I (1972)" and all was well.

Thanks!
You might want to look into using .NFO files for the problem directories - XBMC Companion can build them for you and it does a pretty good job but is Winders based and a little bit quirky.