Kodi Community Forum

Full Version: can't receive media from UPnP server
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,
I'm trying to set up xbmc so that it picks up the media from my UPnP server. I'm using FreeNAS as the server. Currently I have smb shares mounted on my ubuntu system so I can get my music and videos this way. However I thought I'd try to get UPnP working. I've set up UPnP on FreeNAS. It has a webgui start page that shows remote devices. On xbmc I've enabled UPnP, but nothing shows up on the webgui start page. If I enable UPnP renderer, then the xbmc shows up as a remote device. So there is some communication happening. I don't know exactly what the renderer is though, my intuition tells me that xbmc should pick up the UPnP media with enabling the renderer.

I also edited the sources.xml file and manually added the server details.
Code:
<music>
        <default></default>
        <source>
            <name>NAS</name>
            <path>upnp://192.168.100.148:1901/</path>
        </source>
    </music>

I've tried the above both with and without the 1901 port. I read about that in the wiki but I'm not clear on why the port needs to be included and why it is 1901. I tried another port too, one that matches the FreeNAS upnp port. In any even, clicking on the "NAS" source in my music library doesn't bring up anything.

Any suggestions on what else to try or look at are appreciatd.
thx
I think you need to do add source, and then add a uPNP source, like you would your SMB shares or mounts.
Manually adding path's for upnp is not going to work. If they don't show up when you browse for them, something is not working with them.. Post a debug log.