Kodi Community Forum

Full Version: [RELEASE] MythBox for XBMC - a MythTV Front-end Python Script for XBMC
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I uploaded a german strings.xml for the latest build ....
on the project-side

http://code.google.com/p/mythbox/issues/detail?id=41

very nice script .....

Greetings from switzwerland
Hans
modern69messiah Wrote:OK, I know a little bit more about what I'm doing no so I'll refrase and try a new question Oo

I have managed to create a main menu link to the MythBox script. The problem is I cannot figure out the correct way to launch it..

I have this to work from:



And have tried XBMC.RunScript(....) but that did not appear to work either.

Does anyone possibly have a solution? I'm clearly not sure how to link scripts properly! I might put up a dedicated post about this if I can't find anything else.

try this it worked for me
<onclick>RunScript(/usr/share/xbmc/scripts/mythbox/default.py)</onclick>
Quote:try this it worked for me
<onclick>RunScript(/usr/share/xbmc/scripts/mythbox/default.py)</onclick>

Hmm...well I tried that and it did not work BUT it did lead me to something that did work:

<onclick>RunScript(/home/mattaus/.xbmc/scripts/MythBox/default.py)</onclick)

I had no scripts folder under the xbmc directory in my usr directory. Either way it does the trick!

Now if onlty I could get MythBox to work - it is throwing me an error:

Quote:connect to mysql failed: (1045, "access denied for user 'mythtv'@localhost (using password: yes)")

Now I have deliberately NOT run the mythfilldatabase because the HOWTO I have used has said "Answer NO because we're using the EIT" Even though I am not using EIT and frankly have no idea what doing this achieves!

Thoughts?
Mike34 Wrote:I'm having the problem of just the buffer playing before playback stops. Was the reason ever found out or is it just me not setting something correcty?
Taken me ages so far and the bit i can watch looks great, can't wait to finally get it all working.

Mike

I just stopped watching live tv on this all together. From what I can tell the dev will not look into this any more if the issue is not reopened in the google page with some logs.
ding Wrote:I just stopped watching live tv on this all together. From what I can tell the dev will not look into this any more if the issue is not reopened in the google page with some logs.

Yes i saw the issue after and noticed 'Wont Fix' on it.

To Dev >>> do you want me to re-open this or is it something you wont look at? Huh
EDIT: This comment was out of date. Sorry. Removed.
OK so no one really has any suggestions for my problem then? I'm guessing it has something to do with proper access to the mysql database, except I have no idea where I can set that. I get no menu options what-so-ever when that error comes up so I cannot mess with anything.

Any suggestions?
linuxluemmel Wrote:I uploaded a german strings.xml for the latest build ....
on the project-side

http://code.google.com/p/mythbox/issues/detail?id=41

very nice script .....

Greetings from switzwerland
Hans

thanks for the contribution. will integrate in next release :-)
Mike34 Wrote:Yes i saw the issue after and noticed 'Wont Fix' on it.

To Dev >>> do you want me to re-open this or is it something you wont look at? Huh

I'll look at most anything just as long as your have enough info in the ticket for me to diagnose it. The more info you give me, the better chanches that I can fix it. That includes logs, screenshots, configuration, steps to reproduce, etc.
modern69messiah Wrote:OK so no one really has any suggestions for my problem then? I'm guessing it has something to do with proper access to the mysql database, except I have no idea where I can set that. I get no menu options what-so-ever when that error comes up so I cannot mess with anything.

Any suggestions?

Used the mysql command line client to access your mysql db from the same machine that XBMC is running on. Install phpmyadmin if you want an easy to use admin interface to mysql and you will be able to change permissions appropriately.
Hey thanks for the reply analogue...sorry it took so long for me to reply, I have this set to instant email notification but for some reason it is no working at the moment Confused

I'll give that a shot and let you know how I go.

Cheers.
Sorry to be a pain Analogue but I was wondering if you could give me a few pointers, I'm a little lost.

I opened the command line editor and have the following:
Quote:mysql> show databases;

+--------------------+
| Database |
+--------------------+
| information_schema |
| mysql |
| mythconverg |
+--------------------+
3 rows in set (0.00 sec)

mysql> USE mysql;

mysql> SHOW TABLES;

+---------------------------+
| Tables_in_mysql |
+---------------------------+
| columns_priv |
| db |
| func |
| help_category |
| help_keyword |
| help_relation |
| help_topic |
| host |
| proc |
| procs_priv |
| tables_priv |
| time_zone |
| time_zone_leap_second |
| time_zone_name |
| time_zone_transition |
| time_zone_transition_type |
| user |
+---------------------------+
17 rows in set (0.00 sec)

So how do I go about giving MythBox access to the mythconverg database?

I tried the following to no avail:
Quote:mysql> INSERT INTO user (Host, User, Password, Select_priv) VALUES (' ', '[email protected]', password('mythtvpassword'), 'Y');
mysql> FLUSH PRIVILEGES;
mysql> GRANT ALL PRIVILEGES ON mythconverg.* TO [email protected]localhost;
mysql> FLUSH PRIVILEGES;

Whatever I have done I have broken the damn thing. I can't get into the database from the default MythTV frontend now either. Looks like I'm going to ahve to start from scratch again Sad
Hello analogue,

I've uploaded a spanish translation to your google code issue tracker.

http://code.google.com/p/mythbox/issues/detail?id=43


Nice Work Wink
modern69messiah

Is your Mythtv backend on the same computer that your xbmc?

Which linux distro do you use? by default the ubuntu installation of mysql listen on 127.0.0.1, and if you like to connect from another computer you need to change this setting.

To create the user and add the rights to connect to database you need to:

Xbmc+ mythtv on the same computer

CREATE USER 'xbmcuser'@localhost IDENTIFIED BY 'some_pass';
GRANT ALL PRIVILEGES ON mythconver.* TO 'xbmcuser'@localhost;

Xbmc+ mythtv on different computer

On my.cnf file you need to change the line

# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address = <your mythtv server ip>

Restart mysql and then

CREATE USER 'xbmcuser'@'%' IDENTIFIED BY 'some_pass';
GRANT ALL PRIVILEGES ON mythconverg.* TO 'xbmcuser'@'%';



Cheers
Why won't this damn thread send me an email when people reply?

Anyway, Jurr - thanks for the reply!

XBMC and MythTV are running on the same machine. I am using Ubuntu 9.04. I managed to add the native MythTV support to XBMC without any issues - I just couldn't figure out the mysql editing part for MythBox Huh

I'm still having a problem though...when I added the out-of-the-box MythTV capability to XBMC (added a video source for myth:// ) I used:

Quote:myth://mythtv:[email protected]

That's exactly as I entered it (and it worked first try). Now I figured that mythtv is the xbmcuser you are referring to, and localhost is 127.0.0.1 (der lol)

But still no dice.

Here's what I put into the mysql command line (word for word, quotes and all):
Quote:mysql> CREATE USER 'mythtv'@127.0.0.1 IDENTIFIED BY 'K2dfqXWq';
mysql> GRANT ALL PRIVILEGES ON mythconverg.* TO 'mythtv'@127.0.0.1;

I have an odd feeling my user name field is wrong...

EDIT: If it is not quite clear yet that I don't know much about databases this may give it away:

I need to know what user name, and what password MythBox is trying to access the database with. That way I can add the correct ones! The user name and password I have been trying (as shown above) are the ones that worked for the XBMC built in MythTV front end (mythtv and K2dfqXWq), but they obviously won't work for MythBox. How can I find the right ones? Am I even heading in the right direction?