Kodi Community Forum

Full Version: No audio in xbmc only
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Greetings folks!!

Is audio on the AMD 780 chipset platform broken? Totem plays.

System is amd64 Hardy 8.0.4.2 2.6.24-23-generic #1 SMP Mon Jan 26 01:04:16 UTC 2009 x86_64 GNU/Linux

01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller
Subsystem: ATI Technologies Inc RS780 Azalia controller

00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia
Subsystem: Giga-byte Technology Unknown device a022

I installed using Synaptic xbmc version 8.10 hardy beta.

TIA
uh oh .. the navigation sounds play, its only the flac files and audio tracks on video clips, avi, wmv, hd 720p 1080p vc-1 media etc that do not play

Any clues?

TIA
Maybe the same issue as this one?
http://trac.xbmc.org/ticket/5801

You could try the patch attached to the ticket.
enkil Wrote:Maybe the same issue as this one?
http://trac.xbmc.org/ticket/5801

You could try the patch attached to the ticket.

Looks like I will need to download src and compile for that one. Does the below o/p tell that the card has 16K of memory? I only play 2 channel stereo so 2k should be good right?

Quote:01:05.1 Audio device: ATI Technologies Inc RS780 Azalia controller
Subsystem: ATI Technologies Inc RS780 Azalia controller
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 0, Cache Line Size: 4 bytes
Interrupt: pin B routed to IRQ 19
Region 0: Memory at fdffc000 (32-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 3
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [a0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Address: 0000000000000000 Data: 0000

TIA
Gobbledegeek Wrote:Does the below o/p tell that the card has 16K of memory?
I doubt that.

But since you're using stereo I guess you should be alright. But it can't hurt to try the patch at trac.

Sorry that I can't be of more help...