Kodi Community Forum

Full Version: HOW-TO setup the original Xbox DVD remote the correct way with EventGhost
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13
eclin, this is basically what happens when I start Event Ghost


Any help with this would be very helpful.
Here it is : http://rapidshare.com/files/320170971/XBMC2.xml.html

I'm also using a much older version of Eventghost (Version 0.3.7.r990). Try a older/different version if it gives you problems.
Thanks very much eclin, it works perfectly!
I've tryed the exact version you are using (0.3.7.r990) and the current version (0.3.7.r1262) and it works great in either one.

The main problem I had was due to misreading instructions on how to get XBMCRepeater working, so that was my fault.
Instead of making a new folder in Plugins called XBMCRepeater, I just replaced the files in XBMC with the newer XBMCRepeater files. No wonder I had so many problems.

But it has been all sorted out now. I can finally get back to using XBMC. Smile

Thanks very much for your help!
I appreciate it very much!
By the way, I'm using a production made Xbox converter instead of a home made one that most people are using.

Bought it at a Online UK store a few years ago for about 10 Pounds around there.
Glad you got it working.
I've tried some other remotes and I still like the Original remote best.
Now if Santa leaves me a Ipod Touch I may convert.Big Grin
That converter looks like just what I need so my dongle isn't laying sideways on top of my entertainment unit. I'll see if i can find one here in Canada.
Thanks Migsse.
No problem eclin.
I've only tryed it with the Original Microsoft Xbox Remote DVD Playback kit though and not the 3rd party Remotes.
Hi, I've installed XBMC 911 b2 and as a test to see if i could get the xbox remote working with it I made up a usb lead and attached the xbox Ir dongle to it while using Eventghost 0.3.7.r1262 in XP SP2 with the Ir dongle driver etc the same as it says in this thread. It worked but no up or down volume or mute, and can't access the audio or video menu during video playback, I get odd numbers at the top, wierd. I then found XBMC2.xml renamed and downloaded XBMCRepeater and used Eventghost 0.3.7.r990 but i just get a no actions error. I had put the _init_.py and xbmcclient.py files in a folder named XBMCRepeat(er)? Eventghost says it can't find XBMCRepeater plugin and lists all the actions in red. It says somewhere on here to put the XBMCRepeater plugin within XBMC somehwhere but where? Obviously nothing is ever that straightforward. I searched on here and elsewhere online but found nothing about the error I'm having so is no one having the same error because I'm doing something wrong? If anyone can help me it would be much appreciated as I'm at a loss, thanks in advance.
I think you are using the wrong folder name for XBMCRepeater. it should be XBMCRepeater and not XBMCRepeat(er).

As for the button layout, the numbered keys do give you numbered access, so no volume control or mute. As I remember, eclin is still perfecting his XBMC.xml script, so its basically a work in progress.

For the Video and Audio menu, the button that needs to be pressed is the Menu button. Both menus are listed here.
Cheers for your reply Tongue. I used (er) to denote I had used both names for the folder name. I may have set something up incorrectly maybe I'm not sure.

When I pressed menu it never came up with any menu i don't think. I actually got, where sound and video and play/stop should be, something like a time 12hh 33mm :1:33 then if u press the arrow keys the numbers would count up very odd I can't see to try as I tried XBMClive instead the other night and I guess there is no functionality for the xbox remote in it yet I as I haven't searched yet, anyway, cheers.
Hmm, strange.

For now (or probably forever), you have to use Windows to be able to use the Xbox DVD Remote. Are you using the original Microsoft remote or a 3rd part remote?

Eclin and I both have the Microsoft DVD Remotes and work fine on our system. Only difference we have is I have a production made Xbox to USB converter, while Eclin made his own. See if you can get another converter to test with or even another remote to test as well.

Other than that, I can't think of anything else on why you don't see the Confluence Audio/Video menu.
Hi, yeah I have two original Microsoft DVD Remotes and tried both and they were both the same. I haven't soldered the usb wires to the ir dongle yet, I have the connector from an old xbox with the dongle plugged in that and wires just wound round each other which works but of course is not exactly the best way, although I've opened the dongle to do so at some point. I'll buy a converter at some point if it doesn't work right.
So Anyway, I'll switch back to XBMC on windows and solder the dongle properly and try again. Thanks again guys. Big Grin
OK good news on the remote front, it's working exactly as you may expect the ir would or hope to want it to on the windows XBMC reapack 2. All buttons do what they do on the xbox which is cool. Though its certainly possibly on another version it may not work so well, but I'm thankful for all your help and anyone else on the forums...Big Grin

I have just one problem with the Xbox Remote on my Windows Vista System, that while holding the button down/up for scrolling in a list, that the scrolling stocks after 3 steps and start again.
And that some button press are interpreted as a double press.

I thought long time this is maybe due to the Windows driver V028 of the remote, eventghost or something, but i tried the exact same configuration on an other system and its working really fine like original on a xbox with fast scrolling.

This system is Win7 and than i tried it on an other Win7 system but there it is again like on the Vista System.

It seems that it is not a problem of xbmc but maybe its a problem of the way the data is given to xbmc by eventghost?

I couldnĀ“t find a rule for it and tried many things with eventghost and comparing this 2 systems, but no luck so far. Maybe some USB Port problem?
Maybe someone has a idea where the problem is coming from?

Thats the last step missing at my system, a good working xbox remote, so help would be fine, thanks
eclin Wrote:Here it is : http://rapidshare.com/files/320170971/XBMC2.xml.html

I'm also using a much older version of Eventghost (Version 0.3.7.r990). Try a older/different version if it gives you problems.


Can you please reshare your xml again? It is unavailable on Rapidshare....

Thank you!
Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13