Kodi Community Forum

Full Version: 720p MKV's and internal subtitles
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have been using XBMC's svn versions couple of months and I found that 720p MKV's internal subtitles don't work. When I watch 1080p MKV's, internal subtitles works fine. External subtitles (.SRT) works with 720p and 1080p MKV's. I have tried different svn versions, but there is no difference. Has anybody else noticed same problem? I use XBMC at full screen with 1920x1080 resolution and VDPAU.
There are quite a few issues with subtitles and they stem from the various methods and organizations of the information inside the varying containers among other things. It's a big world out there and there are lots of ways to do the same thing. What would be most helpful is for you to provide a debug log of the behavior in question, and samples for the devs to experiment with (IE: The media files in question.). Also search trac for a ticket regarding the specific issue, and if there is no ticket then create one for it.

http://trac.xbmc.org
noeikujoo Wrote:I have been using XBMC's svn versions couple of months and I found that 720p MKV's internal subtitles don't work. When I watch 1080p MKV's, internal subtitles works fine. External subtitles (.SRT) works with 720p and 1080p MKV's. I have tried different svn versions, but there is no difference. Has anybody else noticed same problem? I use XBMC at full screen with 1920x1080 resolution and VDPAU.

I just tryed XBMC with VDPAU and also for me, .mkv with embedded subs DONT work. Theres no problems with .srt.

All subs worked before VDPAU.

/Söder
Switching back to software rendering is a work-around (At least you can watch your precious anime). So it must (could) be a issue with vdpau and the libass renderer.
Po0ky Wrote:Switching back to software rendering is a work-around (At least you can watch your precious anime). So it must (could) be a issue with vdpau and the libass renderer.

I think theres problem with DXVA in windows with vobsub, vsfilter to.
But with both .srt and embedded...

/Söder