Kodi Community Forum

Full Version: XBMC hangs when stopping any video playback
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,

I'm running XBMC (current as of 4/09/09) on Ubuntu 8.10 on a x86 machine. I looked and there is no debug log.

When I stop playback on any video xbmc will immediately hang -- the sound will loop, and continue to loop even when xbmc is forced quit through system monitor. The only way to get xbmc stable again is to reboot.

I've tried changing the playback option from autodetect to all of the other options (basic shader, advanced shader, software), and no luck. I've tried running at a lower resolution, no luck. I've tried it with both the proprietary and open source driver... no luck.

Also, I have desktop effects disabled.

I only get this bug when playback is stopped on the currently playing video.

Any help would be much appreciated!
With newer builds they've relocated the log to ~/.xbmc
Did some more hunting around the forums and I think my problem might be related to the pulseaudio problem (though the sticky here is very unintuitive about solutions, I managed to find some other threads).

I'll see if disabling pulseaudio fixes the issue when I get home.

@Maxim

I looked at ~/.xbmc last night and there was no temp folder (the sticky guide said they were located at ~/.xbmc/temp/xbmc.log but the folder doesn't even exist...)
Ok, well i tried to get rid of pulseaudio in the terminal and ended up with this:

[email protected]esktop:~$ pulseaudio -k
W: ltdl-bind-now.c: Failed to find original dlopen loader.
E: main.c: Failed to kill daemon.


I have no idea where to go from here...help!
Have you set auto adjust refresh rate in video settings? What hardware?, are you using vdpau?

cheers
@harryzimm

Yeah, I tried all of that.

I just tried reinstalling, but now xbmc hangs whenever I try to add something to the library...

I think I'm going to give up on this one. Sad

I wish I could post the debug log, but it doesn't exist. *shrug* I wish I could help others out who might be having these problems, but it seems I can't even do that.


I think what I might do is use my Windows partition for my media and video games because I really enjoy using the compiz fusion settings -- which if I want to reliably play any video, I have to disable.

On the other hand, I can't get xbmc to add any TV shows on Windows atm... I think that might have to do with the TVDB being down lately though...

Thanks for the help thus far everyone.
Hey buddy, I used to have the exact same problem, and it was related to PulseAudio, an audio driver that crashes xbmc

try googling xbmc pulseaudio, that should help you Wink

( sorry that i dont have an exact link )
Debug log sure does exist.

~/.xbmc/temp/xbmc.log.
Hi there - got a log for this although it is not a debug log.

Watched a movie, movie ended, pressed stop and... XBMC hangs.

Might try one day to reproduce with debug running. Anyway, and in case this is any help... here is the log: CLICK ME
tslayer Wrote:Debug log sure does exist.

~/.xbmc/temp/xbmc.log.

that's exactly it tslayer -- when I went to the ~/.xbmc directory there was no temp directory.

It's unfortunate that pulseaudio breaks XBMC (as well as CCS). Unfortunately, until pulseaudio works with XBMC it's unusable to me in Ubuntu. Even if it did work, I'd have to make another Ubuntu installation for it, because I don't want to give up CCS.

Fortunately I keep a windows installation around for my games and I put XBMC on there... everything works perfectly (except that windows is a bit slower, but once xbmc is running there are no problems).

Good luck everyone, thanks for all the help.