Kodi Community Forum

Full Version: GIGABYTE GA-E7AUM-DS2H video performance issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello,
I am running Ubuntu 8.10 x86_32 with XBMC SVN 19464. Thanks to some usefull information here I managed to setup audio over HDMI (ac3,dts,stereo)
Video worked by default however I do have some performance issues.
My hardware is GIGABYTE GA-E7AUM-DS2H build in NVIDIA GeForce 9400 with Intel Core 2 Duo E8400 3GHz.
I setup video card memory to 512MB. Also I tried several different versions of Nvidia drivers (180.44, 180.50, 185.13,185.19). Vsyns is enabled in nvidia settings for openGL (unless I missed that setting somewhere) Cache is setup to 4096kb.
debug log:
http://pastebin.com/mf32ccc7

Problem:
I am playing "killa sample" from local hard drive and when using VDPAU it drops bunch of frames at the beginning (as expected) and then it plays OK but jumps few times like its lacking the power to play it. CPU usage averages around 10%.
Killa sampla is just an example. I see same behavior in other movies too.

What other settings I can try to get rid of this problem?.
My second system is running older Nvidia 8400GS with old core duo and I have no issues.

thx
You should read this thread http://forum.xbmc.org/showthread.php?tid=34655 about how to post about problems. I'm not getting on your case, you just left out a lot of info ppl need in order to help you.

For starters, what distro and version of Linux are you running. If you're running ubuntu intrepid (64bit) like me, I would suggest you try setting Visual Effects to NONE (located in System > Preferences > Appearance menus.

If that doesn't do it for you, you can also disable vsync in XBMC. If your using Ubuntu with GNOME you would simply type in a console: gedit /home/usernamehere/.xbmc/userdata/guisettings.xml
Search for vsync and set it to 0, if it is not already.
b01 Wrote:You should read this thread http://forum.xbmc.org/showthread.php?tid=34655 about how to post about problems. I'm not getting on your case, you just left out a lot of info ppl need in order to help you.

For starters, what distro and version of Linux are you running. If you're running ubuntu intrepid (64bit) like me, I would suggest you try setting Visual Effects to NONE (located in System > Preferences > Appearance menus.

If that doesn't do it for you, you can also disable vsync in XBMC. If your using Ubuntu with GNOME you would simply type in a console: gedit /home/usernamehere/.xbmc/userdata/guisettings.xml
Search for vsync and set it to 0, if it is not already.

thx b01
However my effects were already setup to NONE.
AFAIK Vsync should be enabled since its causing image tearing when disabled. Just to confirm I disabled it and as expected results are much worse(CPU load near 100 plus image tearing)
I did not included debug log since I am pretty sure that I am just missing some stupid setting somewhere. Maybe GIGABYTE GA-E7AUM-DS2H users went through it already Smile
You run into the famous Intrepid (Jaunty) multitreading problem)

http://forum.xbmc.org/showthread.php?tid...tithreaded

Your x264 decoding goes sequential, so this way it is not using yur cpu fully. On Hardy we don't have this problem.
alanwww1 Wrote:You run into the famous Intrepid (Jaunty) multitreading problem)

http://forum.xbmc.org/showthread.php?tid...tithreaded

Your x264 decoding goes sequential, so this way it is not using yur cpu fully. On Hardy we don't have this problem.

He is using vdpau... so he shouldn't be affeacted by this issue in this case.

The question is: are you really choosed vdpau as a renderer explicitely in video settings? If it is on "auto", than vdpau will not be choosed as default renderer.
Just to be clear, did you disable vsync in nVidia settings, or in XBMC. As I found out, these are 2 distinct settings.
For my systems, I had to enable on my video card settings and disable in XBMC guisettings.xml file. Like I said, I just want to make sure. Something so simple crashed XBMC on my system until I did a reboot.
olympia Wrote:He is using vdpau... so he shouldn't be affeacted by this issue in this case.

The question is: are you really choosed vdpau as a renderer explicitely in video settings? If it is on "auto", than vdpau will not be choosed as default renderer.

It is choosed explicitely "vdpau".
uomiarz Wrote:It is choosed explicitely "vdpau".

I stumbled upon this thread searching for the same thing.... i'm running the same mobo with a Pentium E5200 2.5GHz dual core and 2gb RAM. I was experiencing choppy video with 1080p mkv files, but 720p seemed fine.

I figured I'd mention what I changed that seemed to have fixed the video problems and made everything work much smoother. In the NVIDIA X Server Settings, OpenGL Settings, I noticed Sync to VBlank was NOT checked. I changed this to checked. Then, in XBMC, Settings->Videos->Player, I changed render method to VDPAU. fwiw, under Settings->Appearance->Screen, I have Vertical blank sync set to "Let driver choose", which I believe is <vsync>3</vsync> in the guisettings.

I also changed my cpu performance profile (in CPU Frequency Monitor) from Ondemand to Performance, although this was one of the first changes I tried and was still having the video issues, so I may try changing this back to Ondemand and see if it matters.

Hope this helps... if anyone has any other suggestions on settings for this mobo, please speak up!