Kodi Community Forum

Full Version: Problem of configuration of the /userdata/sources.xml
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi,
I am running XBMC on Linux Debian 5.0 Lenny, and I am trying to add Meta Data for the playlists of xbmc.
I have followed the tutorial located at http://wiki.xbmc.org/?title=Adding_Media_Sources and I have edited the sources.xml file like this:

Code:
<sources>
    <programs>
        <default pathversion="1"></default>
    </programs>
    <video>
        <default pathversion="1"></default>
        <source>
            <name>Video plongee exemple</name>
            <path pathversion="1">/root/.xbmc/thierry_dive_3.mp4</path>
        <thumbnails></thumbnails>
        </source>
    </video>
    <music>
        <default pathversion="1"></default>
    </music>
    <pictures>
        <default pathversion="1"></default>
    </pictures>
    <files>
        <default pathversion="1"></default>
    </files>
</sources>

When running xbmc and trying to display my video (the name is correctly added to the playlist), the following error is encountered:
"Remote Share : Path not found or invalid"

Is there any error with the way I have added the path to the sources.xml file?
Can someone explain me why it does not work?
Thanks a lot for your answers!
Don't manually edit sources.xml. Everything is done via GUI. You've also linked to a file and not a path. It requires a path.

Start over and only use the GUI to add your shares.
ok.
I would like to give more precisions about what I want to achieve;
I would like to have a playlist, but not with the files themselves, only with metadata (title/short description/thumbnails/ and link to get the content) the sources would be a file and not a repository of files. Each metadata linking to the content itself, which can be in the current computer on in another one.
Currently, I can display the film following your advice, and adding a thumbnails for it, but I don't know how to add a short description of the film (which tag?) and the name is with the extension (.avi, .mp4) I want to avoid it.
Don't hesitate to tell me if something is not clear, and thanks a lot for your answer!
You want SMB sources and library mode. Have a read in the wiki.
Read the "Through the Interface" section of this:

http://wiki.xbmc.org/?title=Adding_Media_Sources

Then read this:

http://wiki.xbmc.org/?title=Set_Content_(Video_Library)

Then this (particularly the "Update Library" portion):

http://wiki.xbmc.org/?title=Video_Library
Ok, I have read these documents, and my problem could be solved if I can enable the "Library Mode" as explained there
but I can not use this button. Though, the option "enable library" has been activated. So I have also read that by configuring the sources.xml file, we can then import it, but I am trying to avoid it. Anyway, I will have to sue it if nothing else happends to work :-S
Thanks a lot for your answers and you help!
Balbuzard Wrote:Ok, I have read these documents, and my problem could be solved if I can enable the "Library Mode" as explained there
but I can not use this button. Though, the option "enable library" has been activated. So I have also read that by configuring the sources.xml file, we can then import it, but I am trying to avoid it. Anyway, I will have to sue it if nothing else happends to work :-S
Thanks a lot for your answers and you help!

There's not much more help any one can give you, unfortunately. Everything is clearly written in the Wiki. Add source, Set Content, then Update Library. I think you are probably making it much more difficult than it should be by over thinking things. It takes literally 30 seconds to set it up. lol Take a step back and a deep breath, forget everything that you think you need to do, then read through the links I posted until you understand what they're saying. I posted them in the order that they need to be followed.

EDIT: Before you take another crack at it, be sure to undo all the changes you made to sources.xml
Thanks a lot for your answers, guys, my problem is solved. You have right, nul7, I have made it much more difficult than it should be. Problem solved! Smile