Kodi Community Forum

Full Version: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Thanks. A great plugin, by the way!
thanks. im just one of many who have looked after it over the years. most of the original plugin development wasn't by me.
Really keen to install this. However the instructions in post 1 don't seem clear. They direct to the wiki page on adding add ons which from what I see just says "use the add on manager"

Is there a current idiot proof guide for setting this up? I am in the UK so don't need to spoof IP addresses or anything like that.
Go here: http://code.google.com/p/xbmc-iplayerv2/

Just download and use install from zip file.

Nothing else to do, other than modify settings as required.
does this plugin work with pre-eden 11?
Yes.
Folks -

Some of you will be aware/have been following the thread we've had going about H.264 corruption on post-Dharma ION/VDPAU builds - or, "a green wavy line over the bottom chunk of an HD iPlayer stream", as some of you may know it :-)

Anyway, just looking for a bit of help here from anyone else... FernetMenta has successfully patched XBMC to correctly handle files of this type, and I've successfully played files which were failing before, so it's looking really good (well done, that man!). However, to test it properly, I'd like to see iPlayer HD streams also working as they did in Dharma - but the iPlayer plugin isn't working for me at the moment, even on a clean installation.

While I have a look at this (yes, I'll pull a full debug log if needed ...), I thought I'd throw it open here in case there's a BBC or XBMC change that's already broken the plugin - or whether it's related to FernetMenta's patch - or some Ubuntu updates - or whether it's just me and I should thus take it personally.

The symptom is simply iPlayer video stream not working - silent failure or the "One or more items failed to play..." dialogue box. Radio seems to work (albeit buffer-y).

The only errors I can see in the debug log are some DeprecationWarning statements and then ERROR: Open - failed to open source <...> followed by ERROR: CDVDPlayer::OpenInputStream - error opening [...] before XBMC gives up with ERROR: Playlist Player: skipping unplayable item: 0, path [...].

Time to fiddle with some CDNs, etc., but thoughts/volunteers appreciated in the meantime!
BBC iPlayer installed around Jan 2011 works fine for me with FernetMenta's patch and xbmc-pvr built from current git source. I haven't tried re-installing iPlayer so I can't tell if it's the current distro that's broken.
Okay, apologies - the problem was that I was building XBMC from code and didn't have librtmp-dev installed, hence the complete and abject failure of anything that actually depends on it... like add-ons that process rtmp streams...

I should have spotted the WARNING: CreateLoader - Unsupported protocol(rtmp) message and taken the hint earlier.

I'll go now. Thanks for listening :-)
Hi, I'm hoping somebody may be able to give me some help with the iplayer plugin.

I'm on the latest stable xbmc release 10.1, under Win 7 64bit.

The plugin has worked OK in the past.

Now I am getting an error : "cannot import name walk", and then "script failed plugin.video.iplayer"

I've tried installing straight from the zip file ( both 2.4.12 & 2.4.13 ) downloaded from google code, and also using the hitcher add on repo.

I cant find any references to these errors anywhere on the internet.

Iplayer plugin is the only one that is generating this error.

Could anyone please help? - dont really want to have to do a whole system restore to get back to a working point - thanks in advance.
not without a debug log. I assume you didn't read any of the thread or you would have at least seen you need to post a debug log.

(yes, i am fed up asking for a debug log every single time someone has a problem)
I did speed read the thread, but was obviously looking for something similar to my problem.

Is this what will help?:

http://pastebin.com/27V3Rzpf
Have you previously installed a newer version to try or? Do a complete uninstall of xbmc and a reinstall and try then.

I suspect the issue is installing a newer version over an older without uninstalling the older completely (and there are python library collisions).
Its possible, but I don't remember to be honest.

Prior to a re-install I did do an uninstall of the latest version, I also manually checked that there were no iplayer plugin directories remaining.

Re-install (by either method) still resulted in the same problem.

I was hoping not to have to do a complete re-install of xbmc itself.
aenima46n2 Wrote:Its possible, but I don't remember to be honest.

Prior to a re-install I did do an uninstall of the latest version, I also manually checked that there were no iplayer plugin directories remaining.

Re-install (by either method) still resulted in the same problem.

I was hoping not to have to do a complete re-install of xbmc itself.

Are you saying you reinstalled the addon or xbmc? I'm referring to xbmc. The issue is related to XBMC not the addon. I didn't say to reinstall the addon.

Uninstall XBMC, and check that C:\Program Files\XBMC\ is completely gone/empty and then then reinstall.