Kodi Community Forum

Full Version: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I've been having terrible trouble with this addon and don't quite know what to do:
v.18 keeps stopping every 30s or so when I try to stream programmes.
I don't know how to edit the .py file in the v.17 as described here: http://forum.xbmc.org/showthread.php?tid...pid1437622
(Tried opening the .py file in a text editor and changing the file, then rezipping it. The result got rejected as an unusable zip by XBMC).

Can anyone help? is there a tweaked v.17 zip anyone can upload?
(2013-09-17, 18:35)kieslowski Wrote: [ -> ]I've been having terrible trouble with this addon and don't quite know what to do:
v.18 keeps stopping every 30s or so when I try to stream programmes.
I don't know how to edit the .py file in the v.17 as described here: http://forum.xbmc.org/showthread.php?tid...pid1437622
(Tried opening the .py file in a text editor and changing the file, then rezipping it. The result got rejected as an unusable zip by XBMC).

Can anyone help? is there a tweaked v.17 zip anyone can upload?


Just edit the py file - no need to rezip.
After a total raspbmc failure, I reinstalled the latest.

Added iplayer 2.18. This works EXCEPT for live streams which all produce a script error:

Code:
14:59:51 T:2903815232  NOTICE: Traceback (most recent call last):
14:59:51 T:2903815232  NOTICE:   File "/home/pi/.xbmc/addons/plugin.video.iplayer/default.py", line 1100, in <module>
14:59:51 T:2903815232  NOTICE:     live_tv.play_stream(label, bitrate, showDialog)
14:59:51 T:2903815232  NOTICE:   File "/home/pi/.xbmc/addons/plugin.video.iplayer/lib/live_tv.py", line 120, in play_stream
14:59:51 T:2903815232  NOTICE:     url = fetch_stream_info(channel, bitrate, provider)
14:59:51 T:2903815232  NOTICE:   File "/home/pi/.xbmc/addons/plugin.video.iplayer/lib/live_tv.py", line 43, in fetch_stream_info
14:59:51 T:2903815232  NOTICE:     if   quality == 1: quality_attr = 'pc_stream_audio_video_simulcast_uk_v_lm_p004'
14:59:51 T:2903815232  NOTICE: UnboundLocalError: local variable 'quality' referenced before assignment
14:59:51 T:2903815232   ERROR: EXCEPTION Thrown (PythonToCppException) : -->Python callback/script returned the following error<--
                                             - NOTE: IGNORING THIS CAN LEAD TO MEMORY LEAKS!
                                            Error Type: <type 'exceptions.UnboundLocalError'>
                                            Error Contents: local variable 'quality' referenced before assignment
                                            Traceback (most recent call last):
                                              File "/home/pi/.xbmc/addons/plugin.video.iplayer/default.py", line 1100, in <module>
                                                live_tv.play_stream(label, bitrate, showDialog)
                                              File "/home/pi/.xbmc/addons/plugin.video.iplayer/lib/live_tv.py", line 120, in play_stream
                                                url = fetch_stream_info(channel, bitrate, provider)
                                              File "/home/pi/.xbmc/addons/plugin.video.iplayer/lib/live_tv.py", line 43, in fetch_stream_info
                                                if   quality == 1: quality_attr = 'pc_stream_audio_video_simulcast_uk_v_lm_p004'
                                            UnboundLocalError: local variable 'quality' referenced before assignment
                                            -->End of Python script error report<--

Hmm ... this addon worked okay before the crash.

Any ideas? I get the same script error with the original default.py and the 'alternative' linked elsewhere in the thread.

ps: hope the code is acceptable given it's apparently a specific python error
Hmmm ... got 2.17 working on openelec with swf player edit. But only BBC News plays live - all other channels fail.
Still only getting News, Parliament and Alba live - all other channels fail..
After months of error free use, since yesterday I can only access live the News, P'ment & Alba. All other streams fail with a 'cannot read rtmp header' r 'RTMP_ReadPacket, failed to read RTMP packet body.' message (in the log). No settings changes make any difference.

Baffled.

Using 2.4.17 on Openelec.
Okay - a final attempt to get some feedback.

I tried the addon (version 2.4.18) in Windows. If I select a specific stream quality (eg. 800) then the addon throws a script error. Select Any/Auto and the channels all play. I suspect the error is from the live.py script.

However, in Linux - the same setup produces inconsistent results - some streams load to playing screen, but there's no video. Stopping the stream flashes a bried video before exiting. More often than not selecting a stream produces a 'Failed item' message. To reiterate, News generally plays, but P'ment & Alba are currently reporting that the sream is not available.

On demand stream all work fine.
I cant get it to work at all on OpenELEC
BBC live streams working again this morning. Go figure.
Live streams not working for me. Tried changing from Limelight to Akamai to Auto but no joy. Don't have time to post a debug log before I go to work.
For some unfathomable reason - I can only get live streams using Openelec and 2.4.18 - all other distros and iplayer combos fail.
Forget this - I am an idiot and had set it up wrong.

Plugin works perfectly, which is more than can be said for my brain....
I am using a vpn router from here in the states - I am able to use airplay etc on all my devices with the bbc iplayer over my atv2. the problem is when I try and install the addon in xbmc from the link, and click on it in applications it wont install zip file. The little 'ok' button does not light up either only 'cancel'. Is there something I am missing?
Reinstalled my Pii (B) with Openelec 3.2.2 standard and nothing else except for IPlayer 2.4.18 (and MPEG2 license) but the live streams are still not working. All the non live stuff works great. Has anyone got the live streams working on the PIi and if so what are you running on it?(Raspbmc, Openelec,Xbian ) Do I need to reconfigure something? Thanks.
You may have to play about with the stream settings - akamai vs limelight. They seem to change randomly day by day .... using Openelec 3.2.2. Can't get anything on xbian or raspbmc.