Kodi Community Forum

Full Version: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2014-06-05, 15:35)manmantis Wrote: [ -> ]The only change I've had to make in the last week-or-so is to change the stream setting from RTMP (port 1935) to "Library". Played fine thereafter (although when I go back to the settings having done so it reverts to RTMP (port 1935)).
Is this a change in the add-on settings or in general XBMC settings? I'm using XBMC on ATV2 and the only RTMP settings I see are for port 1935 0r 80. Any help gratefully received
(2014-06-05, 16:16)Sniffer8 Wrote: [ -> ]
(2014-06-05, 15:35)manmantis Wrote: [ -> ]The only change I've had to make in the last week-or-so is to change the stream setting from RTMP (port 1935) to "Library". Played fine thereafter (although when I go back to the settings having done so it reverts to RTMP (port 1935)).
Is this a change in the add-on settings or in general XBMC settings? I'm using XBMC on ATV2 and the only RTMP settings I see are for port 1935 0r 80. Any help gratefully received

Add-on settings. I'm using the latest v2.5.9 & I don't think those stream options have all been there in some earlier versions.

BTW. Reading back through this thread, I note the discussion seems to revolve around LIVE TV. I don't want to unintentionally mislead people. I'm only referring to my ability to play from the BBC iPlayer catch-up listings via this add-on. I don't think I have ever been able to stream Live TV via the iPlayer add-on. I have always used the Ex-Pat TV & FTV add-ons for this.
Hi ManMantis. Thanks for the reply Have updated to 2.5.9 but can't find the setting you mention. I'm using XBMC on ATV2. Is you XBMC on Xbox or PC or anything that would have a different interface and options?
XBMC on PC.

However just to add to the general confusion, I've just gone back looking for the stream protocol settings I mentioned, and they've disappeared. I just added Hitcher's repo (for auto-updating), so not sure if that had anything to do with it. The settings were there right up to when I wrote my second reply!

The protocol choices I had were:
  1. RTMP (prt 1935)
  2. RTMPT (port 80)
  3. Library
  4. Files

The last two (& previously unknown) choices have just vanished. Possibly I spent the last 2 weeks in an alternative universe?

Having said that, with RTMP selected I can still play streams (just not Live TV).

Sorry, I'm not being much help really!
Sounds like something got mixed up because they're video or music sections.
Thanks for the info, MM. I only have XBMC on ATV2 so I don't know if the unblock-us issue is device-specific. If I stick with unblock-us I can airplay from my iPad to the ATV (very variable stream quality) or I can use PLEXMBC on the ATV2 (good quality streams but computer has to be on with OpenVPN running) I've tried out 3 free trials from unblock-us competitors and while all of them allow me to open streams, I get severe buffering problems. I never had any buffering issues with unblock-us before the service stopped working on AVT2 a couple of weeks back. First-world problems, I know, but annoying...
I've been having a lot of problems playing radio streams on the addon. It plays intermittantly other times it hangs and sometimes it has a playback failed error. One time it came up with a playback failed message and when i pressed ok, it immediately played the stream. Extracts from the logfile below

16:50:09 T:1222607968 ERROR: RTMP_ReadPacket, failed to read RTMP packet body. len: 2282194

16:50:09 T:1222607968 ERROR: CDVDPlayer::OpenInputStream - error opening [rtmpt://cp61422.live.edgefcs.net:80/live?auth=daEawaLbEa0aOb6dxbBbqdqb1a9btaubuag-btKCAW-bWG-DnsEAnynFCvHqxJ&aifp=v001&[email protected];[email protected] [email protected]?auth=daEawaLbEa0aOb6dxbBbqdqb1a9btaubuag-btKCAW-bWG-DnsEAnynFCvHqxJ&aifp=v001&[email protected];[email protected] live=1 timeout=30]

and after pressing ok

16:50:15 T:1323091040 INFO: plugin.video.iplayer: URL Fetch took 0.57 sec for http://www.bbc.co.uk/radio/listen/live/r5l.asx

16:50:15 T:1323091040 INFO: plugin.video.iplayer: Listening to url=mms://wmlive-acl.bbc.co.uk/wms/bbc_ami/radio5/radio5_bb_live_ep1_sl0?BBC-UID=75e339413c1781a64cc1247b11e8c6fa1b609053a0a0b1d4544f29a744036374&SSO2-UID=

any ideas?
(2014-06-06, 16:44)wibbilus Wrote: [ -> ]I've been having a lot of problems playing radio streams on the addon. It plays intermittantly other times it hangs and sometimes it has a playback failed error. One time it came up with a playback failed message and when i pressed ok, it immediately played the stream. Extracts from the logfile below

any ideas?

you should post "complete" debug logs via xbmclogs.com or similar, not snippets on the forum.

You are having trouble with that CDN (for what could be any number of reasons). In the addon settings you can try changing the stream source, or change which radio stream to use "try a lower bitrate/different format)
I'd be interested to know what extra info you think a complete log would show instead of the snippets I've posted which give you the relevant information. I had already tried changing all the settings but it was the urls that i was posting about specifically.
Hardware n software versions and other stuff.
(2014-06-07, 22:51)wibbilus Wrote: [ -> ]I'd be interested to know what extra info you think a complete log would show instead of the snippets I've posted which give you the relevant information. I had already tried changing all the settings but it was the urls that i was posting about specifically.
Maybe developers have a better idea of what is relevant than you do? They might be looking for something you've excluded as irrelevant, making dealing with your problem all the more frustrating and thus more likely to be ignored. Rather than argue about it just post the complete log.
If you know better, feel free to help yourself Smile

And what milhousevh said.
Hi all

Just installed Gotham Xbmcbuntu and installed iplayer 2.5.9. I can select a programme but as soon as you click on it all you get is a white cross on the screen. After 5-10seconds xbmc restarts its self (back to home screen). Anyone got any ideas?
Its installed on an asrock ion 330 htpc.

Log is here; log

I have also tried iplayer 2.5.8 but still no joy, it was working fine on frodo 12.2.
I am in uk and iplayer works on laptop (in firefox and xmbc 12.3)

Any help would be great, the misses is starting to moan about me tinkering with things that aren't broken!
Have you tried an updated version of librtmp? It seems to be XBMC crashing inside dvdplayer while processing the rtmp stream - the iplayer addon looks to have successfully done "it's thing" only for XBMC to then drop the ball.

http://forum.xbmc.org/showthread.php?tid=162307
Hi there.

I use the plugin to listen to live radio streams a lot. One of the things I'd like to have is for the current programme/track to be displayed in the UI. I'm happy coding in Python but haven't written a plugin before.

Given that this information is available via webscraping, is it possible in the API, or would it require a skin modification? Any pointers on where to look in the iplayer source would be appreciated. I'm happy to implement this myself if it's possible.

Cheers,
Andrew.