Kodi Community Forum

Full Version: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
(2015-02-18, 18:57)jcorsaut Wrote: [ -> ]I am a non-uk resident, but haven't had issues with my DNS provider before. As well, iplayer works fine in HD using the website or the ios app version. Not sure if there is a difference in how the streams works.

I've just "fixed" a friends PC where Iplayer was displaying all the issues mentioned here recently,
the cure was to disable the smartdns service he was using for overseas streams then all of iplayer worked fine
(2015-02-18, 16:00)Nicolasb Wrote: [ -> ]
(2015-02-18, 01:34)jcorsaut Wrote: [ -> ]
(2015-02-11, 14:11)belrik Wrote: [ -> ]Same solution; setting stream provider to auto was giving errors but manually selecting the Akamai CDN fixed the problem. Looks like the BBC have a bad content provider in their network. Akamai is massive so that should be enough.

Having trouble now with Akamai as well. Can't seem to get any reliable HD streams from this addon anymore. SD streams are working without issue. Anyone else having this problem. If not, what stream settings are you using?

For on-demand streams, Akamai doesn't work for me either, though I haven't tried SD streams. Last Top Gear episode stops after 10 sec whatever the provider

For live TV works as a charm.

This is where I am at with it. Live Streams work perfectly, on demand does not. The same is true if I use the 'BBC iPlayer' addon too, so I guess the issues lie with the BBC. I get big buffering issues on my Chromecast too. I am a UK resident and I am using 76Mbps fibre broadband.
Hi guys,

Currently running a Minix version of XBMC on their Neo x8-h android box.

My daughter loves Cbeebies so we are always playing videos from this channel but some videos randomly won't play? This has only started over the past 2 weeks.

I can get them to play by repeatedly hammering the play button and they eventually start! Like starting a car! It seems that the problem is mainly with standard definition videos, whilst the HD ones are okay and start smoothly.

It can't be the Minix box because i used to run Kodi through a raspberry pi and i had the same problem.

Could it be something to do with the resolution that i am running through XBMC/Kodi?

I should also add that my Minix is run through a Yamaha amp via HDMI before then going to my TV via the amp... could it be this?
(2015-02-24, 10:34)jimardee Wrote: [ -> ]Hi guys,

Currently running a Minix version of XBMC on their Neo x8-h android box.

My daughter loves Cbeebies so we are always playing videos from this channel but some videos randomly won't play? This has only started over the past 2 weeks.

I can get them to play by repeatedly hammering the play button and they eventually start! Like starting a car! It seems that the problem is mainly with standard definition videos, whilst the HD ones are okay and start smoothly.

It can't be the Minix box because i used to run Kodi through a raspberry pi and i had the same problem.

Could it be something to do with the resolution that i am running through XBMC/Kodi?

I should also add that my Minix is run through a Yamaha amp via HDMI before then going to my TV via the amp... could it be this?

Hi,

See above, others (including me) had the same problem, changing source preference to akamai fixed it for me and others.
Out of interest, have you tried the official BBC app in android from the play store?
Hi Mbc0!

Yes! Don't get me started on that... there are all sorts of problems with KitKat, Minix and the official BBC iplayer app at the moment.

When I attempt to use this all i get is sound but a black screen! See this thread http://www.minixforum.com/threads/iplayer.4411/

It's only through XBMC/Kodi that i can get iplayer to work at all! Plus the stream can be in HD through Kodi, but not through the official app... absolute madness!
Currently the BBC streams are all acting very random for me. Sometimes I can now watch in HD again without issue, but other times I cannot. If I switch to just using Akami, that seems to no longer make any difference. The only thing I know for sure at this point is that all live streams work without issue in HD, and if I set the on demand streams to SD, they also all work without issue. I really wish I knew, could figure out, what is going on. Whether it is on my end with my ISP, a BBC issue, or some sort of hardware issue with my machine and windows 8.
I am still having issues even when switching to Akamai... just completely random!

Some video's won't even start, some will but then stop at random points in the playback and some play absolutely fine?
(2015-02-23, 02:27)speedwell68 Wrote: [ -> ]
(2015-02-18, 16:00)Nicolasb Wrote: [ -> ]
(2015-02-18, 01:34)jcorsaut Wrote: [ -> ]Having trouble now with Akamai as well. Can't seem to get any reliable HD streams from this addon anymore. SD streams are working without issue. Anyone else having this problem. If not, what stream settings are you using?

For on-demand streams, Akamai doesn't work for me either, though I haven't tried SD streams. Last Top Gear episode stops after 10 sec whatever the provider

For live TV works as a charm.

This is where I am at with it. Live Streams work perfectly, on demand does not. The same is true if I use the 'BBC iPlayer' addon too, so I guess the issues lie with the BBC. I get big buffering issues on my Chromecast too. I am a UK resident and I am using 76Mbps fibre broadband.

BBC iPlayer appears to be temperamental at best, even using get_iplayer causes similar drop-outs. Like I said before, they are making changes to try and stop people easily accessing media outside of the iPlayer website or official apps for Android, iOS and Tivo.

I'm using 200/100 from within the UK and it still causes problems. Oddly enough, ~70/20 from Austria doesn't cause [edit] as many issues - and I route that through my UK connection.
Just an update as of today. Seems if I set everything back to auto (stream quality, stream source), everything is working fine again. As others have mentioned I'm nearly 100% positive this is an issue at the BBC end, not my machine or the addon.
(2015-03-08, 13:20)jcorsaut Wrote: [ -> ]Just an update as of today. Seems if I set everything back to auto (stream quality, stream source), everything is working fine again. As others have mentioned I'm nearly 100% positive this is an issue at the BBC end, not my machine or the addon.

I tried it last night for the first time in a while and it worked faultlessly. I have been using the 'BBC iPlayer addon', get_iplayer and iPlayer on my Chromecast and the service has been equally hit and miss, which leads me to believe that it was a BBC problem, even get_iplayer was repeatedly timing out or deathly slow.
Raspberry Pi : B
Kodi: 14.0 (?)
Kodi iplayer: 2.6.10
RaspBMC

Like everyone using this add-on, about 6 months ago the Kodi add-on stopped working for me due to changes in iplayer (something to do with BBC data feeds ??).

Anyhow, today I thought I would check back into the Kodi iplayer Add-on and I saw there is a new version, 2.6.10. As I am becoming practised at downloading, getting the zip onto a directory the Raspberry Pi can see, and installing an add-on in Kodi using "install Add-on", I had the new version installed in a few minutes.

I have browsed a few programmes using, categories, channels and alphabetical search. Every programme I selected has played within a few seconds and seems to stream without hiccup.

Well done and thank-you for reinstating this valuable add-on.

Clive
I know the question of getting this on the Official Repository has been answered before, but its so frustrating reading Media Articles about Kodi missing iPlayer functionality because they don't find this add-on.

http://www.theregister.co.uk/2015/03/16/...pi/?page=3

Please submit it to the official repository so people don't miss out Smile
new info / url and so on over here: 221699 (thread)

Perhaps something can be done to redirect people from this thread there by a mod ?

Also I have submitted it for inclusion (It has had a minor update since I wrote this)

Quote:Due to years of people nagging me to submit this, and what with the
close of google code and the annoyance that it caused me (even though it
was horrible and should have been killed years ago), I gave in.

*addon - plugin.video.iplayer
*version - 2.7.0
*url - https://github.com/joolswills/plugin.video.iplayer
*revision - HEAD
*branch - master
*xbmc version - helix

The plugin is in a subfolder plugin.video.iplayer

vent:
I am aware that the plugin still has some hardcoded strings etc - it's
really had far too many devs, and kludges over the years. I just fixed
up live radio streams. No doubt it will all break again soon, the next
time the BBC decide to kill off some of it's older feeds, despite their
new developer api still being closed to licence fee payers.

I'll try and sort the language strings out as time allows.

Thanks (I'm not quite as grumpy as I sound - Honest!)
Thanks a lot mate, this will make a lot of people happy Smile