Kodi Community Forum

Full Version: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi Folks

Minor bug fix : When display dialog option was selected live tv would fail.

2010-01-29 update available at http://code.google.com/p/xbmc-iplayerv2/ and via SVN installer.

Cheers
Dink
dink Wrote:Looks like XBMC has thrown a wobbly. Can you try a later version?


Cheers
Dink
I'm using the latest nightly, I might go back a few builds because now the audio is out of sync.
So it looks like all of the important stuff from the last month or so got lost in the "lightning strike". :-(

Quick summary:
BBC implemented SWF verification on the streams, which broke the plugin.
We all went ballistic and spammed Auntie and the Auntie Trust.
Some clever people worked out how to workaround the issue using get_iplayer.
Some other people patched XBMC builds with 'hookey' hashing codes, so there are two workarounds.
The dev behind get_iplayer pulled it*.
XBMC web site crashed spectacularly.
Errr, that's it.


*Try here for debian (inc. Ubuntu) package: http://bit.ly/cIfPDc
Would anyone care to repost the workarounds to get the plugin working again?

I'd be most grateful. Sadly I would rather get what works best working again, than keep waiting in hope that the BBC will see the light.
I guess the BBC used their "weather control" device against us, scary!
flitclicker Wrote:Would anyone care to repost the workarounds to get the plugin working again?

I'd be most grateful. Sadly I would rather get what works best working again, than keep waiting in hope that the BBC will see the light.
Google has cached some of it, http://66.102.9.132/search?q=cache:Lhybf...nd+iplayer

Can't find the first page, though. (Edit) Instructions from first page now found by 'gobbledigook':
http://209.85.229.132/search?q=cache:dyR...er+web+PVR

Note that the instruction to wget get_iplayer from linuxcentre will no longer work since the developer pulled it.
Debian linux (Ubuntu) users can get it from here instead:
http://bit.ly/cIfPDc
Yeah the google cache does leave a bit to be desired.

Was it even possible for those of us running on an XBox?
IPlayer hackery info and files for xbox1 users are available on my homepage url (on my forum profile)! or msg me.

I also have a build with some patches from the librtmp guys for linux, but currently it crashes. I was about to discuss this with the patch creator when the site went down. His patches are on trac anyway. search for rtmp.

looking at implementing the automatic hash generation stuff similar to what librtmp uses with the xbox build too.
exobuzz Wrote:IPlayer hackery info and files for xbox1 users are available on my homepage url (on my forum profile)! or msg me.

Sweet! Thanks Exobuzz.

Losing iPlayer made me realize it was pretty much my main use for xbox!

4 mins into TV prog and counting... seems to be working great.

C
flitclicker Wrote:Yeah the google cache does leave a bit to be desired.

Was it even possible for those of us running on an XBox?
Yes, in both the ways I mentioned.
Exobuzz - thank you so much! That's made my bird happy, and at the weekend the kids will be happy too. So therefore I'm in peace!

Hats off and many thanks.
i only discovered the iplayer plugin a few days ago, and have been waiting with baited breath for the forum to come back up so i could figure out how to work it!!

I run xbmc in fluxbox on an ubuntu server box and administer through putty, i have found the first and third pages of the thread mentioned above in google's cache. I have tried the instructions for the xbmc live cd at the bottom of page one... but have been having trouble making it work!

i seemed to fail at the first wget! it say the file is downloaded but when i look is not a .deb file? so dpkg -i doesn't work?

Code:
[email protected]:~$ wget http://linuxcentre.net/get_iplayer/packages/get-iplayer-current.deb
--2010-03-17 22:14:06--  http://linuxcentre.net/get_iplayer/packages/get-iplayer-current.deb
Resolving linuxcentre.net... 206.225.17.53
Connecting to linuxcentre.net|206.225.17.53|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://linuxcentre.net/getiplayer [following]
--2010-03-17 22:14:06--  http://linuxcentre.net/getiplayer
Reusing existing connection to linuxcentre.net:80.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: `getiplayer'

    [      <=>                                                                                                           ] 70,607      30.3K/s   in 2.3s

2010-03-17 22:14:09 (30.3 KB/s) - `getiplayer' saved [70607]

So i installed get_iplayer from the universe package, everything else went swimmingly, until i get to the last few commands!!

Quote:exit nano via ctl-x

su xbmc

get_iplayer.cgi --port=1935 --getiplayer=/usr/bin/get_iplayer

Go back to xbmc via ctl-f7

Run the Iplayer script and see if it works! You can check for messages from the get_iplayer web pvr via console (ctl-F2).

Good luck...

i'm in putty so i can't start xbmc from there.... i go downstairs, restart xbmc via exiting and starting in fluxbox... come back upstairs (man i need a laptop!!) drop the command

Code:
[email protected]:~$ get_iplayer.cgi --port=1935 --getiplayer=/usr/bin/get_iplayer
get_iplayer.cgi: command not found
[email protected]:~$ get_iplayer --port=1935 --getiplayer=/usr/bin/get_iplayer
Unknown option: port
Unknown option: getiplayer
Usage ( Also see http://linuxcentre.net/getiplayer/documentation ):

as you can see i dropped the .cgi the second time around but it still bugged out! have i gotton the get_iplayer package from here: http://linuxcentre.net/get_iplayer/packa...urrent.deb mixed up with the one in the ubuntu repo? if so, then as you can see above, above ^^ that linuxcentre link doesn't appear to work? or am i missing something here!!


EDIT:
i have examined the file which downloads using the wget http://linuxcentre.net/get_iplayer/packa...urrent.deb command and it is a html page which looks like this
Big Grin The King is dead long live the King!! Big Grin

Many, many thanks Exobuzz - top work Cool

Hope this lasts - but even if it doesn't I'm so glad guys like you are around to fix it for us folks.

Cheers
most welcome. it will work until iplayer change their swfplayer. its a hack. its not the best way of doing it. but, for me, i wanted to use iplayer, and my littleun likes her iplayer cbeebies, so I didnt want to wait around for a better solution.
sipart Wrote:Hope this lasts - but even if it doesn't I'm so glad guys like you are around to fix it for us folks.

If it stops working before there is a more permanent solution available, gimme a nudge, and I'll rebuild with a new hash. source diffs are on the link for anyone else who wants to tweak it too.