Kodi Community Forum

Full Version: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hey Dink as you have mentioned the beeb are using some of your programming in theirs, can't you sort of use it back?
kiboy6 Wrote:So, sorry if i missed it, but is there currently a viable workaround for Windows? or is it just Xbox, Live and Linux usersin luck for now?

it was mentioned before... but this thread is starting to get a little long!!

No windows workaround at the moment... would need a get_iplayer.exe (linux centre are not hosting anymore!!) to be able to play with the get_iplayer.cgi.... (which i think would need perl and apache on a windows machine?) gonna look at it this w/e.... but i have never played with porting stuff from deb to windows so i can't promise my fiddling with cygwin will come to anything, but its an interesting project? nah... more something to play with Wink

not that i have any clue what i'm doing!!
gobbledigook Wrote:it was mentioned before... but this thread is starting to get a little long!!

No windows workaround at the moment... would need a get_iplayer.exe (linux centre are not hosting anymore!!) to be able to play with the get_iplayer.cgi.... (which i think would need perl and apache on a windows machine?) gonna look at it this w/e.... but i have never played with porting stuff from deb to windows so i can't promise my fiddling with cygwin will come to anything, but its an interesting project? nah... more something to play with Wink

not that i have any clue what i'm doing!!

If you're going to be recompiling anyway, then just build xbmc with this patch

http://trac.xbmc.org/ticket/8971

and it'll all work fine, on every platform.
Did we used to be able to watch shows like Eastenders in higher res than 832x468 ?
Sle7enUK Wrote:This is the way I do every update:

After I've uploaded the new version (folder not named XBMC) to my Xbox, I rename the old 'XBMC' folder to 'XBMC (Old)' then rename the new version 'XBMC'.

Move a copy of my old 'guisettings.xml' and the 'sources.xml' from 'UserData' folder to the new one and delete all files from the 'TDATA' and 'UDATA' folders in the 'E' folder.

Move fresh downloads of plugins to their respective folders for 'video', 'programs' etc.... (Example: iPlayer would be a fresh download and put into 'video' in the 'plugins' folder), then move a copy of the old 'plugin_data' (In 'UserData') folder to the new upload.

It works for me every time, and if the new install is no good, then I just rename my old install back to 'XBMC and because everything is there it works as before. (I always delete the files from 'TDATA' and 'UDATA' folders every time I change the version)

I've done exactly that, using Buzz's build - and huge thanks to Buzz, iPlayer now works again on my Xbox. However, I seem to have lost all the icons for my various plugins. I FTP'd the newest iPlayer plugin into the Plugins folder and also copied over all my old plugins from the previous XBMC build folder. It works, but no icons... any ideas ?
Tis a bug in those revisions regarding icons. There is a fix now on svn. I need to do a new build for you. At least, it "could" be the bug that has just been fixed.
Sle7enUK Wrote:This is the way I do every update:

After I've uploaded the new version (folder not named XBMC) to my Xbox, I rename the old 'XBMC' folder to 'XBMC (Old)' then rename the new version 'XBMC'.

I thought these instructions were going to do it for me, but I'm still doing something wrong.

I've ftpd exobuzz's folder as well as the old user data and plugins files but I can't rename the old "xbmc" folder via filezilla.

Can someone explain what I'm doing wrong and point me to a solution ?

Many thanks
highlandsun Wrote:If you're going to be recompiling anyway, then just build xbmc with this patch

http://trac.xbmc.org/ticket/8971

and it'll all work fine, on every platform.

I don't suppose there's a way to patch the xbmc.exe is there?
MisterRusty Wrote:I thought these instructions were going to do it for me, but I'm still doing something wrong.

I've ftpd exobuzz's folder as well as the old user data and plugins files but I can't rename the old "xbmc" folder via filezilla.

Can someone explain what I'm doing wrong and point me to a solution ?

Many thanks

I don't use Filezilla but usually when you can't rename something it's to do with 'permissions' check those and/or what it says when you try and change it (if anything) and let us know.
MisterRusty Wrote:I thought these instructions were going to do it for me, but I'm still doing something wrong.

I've ftpd exobuzz's folder as well as the old user data and plugins files but I can't rename the old "xbmc" folder via filezilla.

Can someone explain what I'm doing wrong and point me to a solution ?
Are you trying to rename it whilst running XBMC from within it...?
exobuzz Wrote:IPlayer hackery info and files for xbox1 users are available on my homepage url (on my forum profile)! or msg me.

I also have a build with some patches from the librtmp guys for linux, but currently it crashes. I was about to discuss this with the patch creator when the site went down. His patches are on trac anyway. search for rtmp.

looking at implementing the automatic hash generation stuff similar to what librtmp uses with the xbox build too.

Thank you very much for this fix. Works a Charm!
Thanks for your replies,
My xbox boots into xbmc and I'm then using filezilla remotely from my pc.
I now understand that was stopping me changing the xbmc folder name and have used an xbox boot disc to give me write access to the necessary folders.

Problem solved, normal iplayer service resumed, happy family SmileSmile
@ Mr gobbledigook or any others that may have a clue.

Did you manage to get the get_iplayer command running automatically after xbmc has started ?

I've tried several different ways of starting the command at startup but none work. As you say it needs to be run after xbmc has started.

The only way I can think of is a python script from within xbmc, unfortunately Ive not a clue how to go about anything like that.

Anyone any ideas ?
exobuzz Wrote:Tis a bug in those revisions regarding icons. There is a fix now on svn. I need to do a new build for you. At least, it "could" be the bug that has just been fixed.

Will updating via SVN knacker your fix for iPlayer ?

Also... a note to anyone else about to delete the Udata and Tdata folders... that's where any game saves appear to be kept ! I was 2/3 the way through GTA Vice City and now I have to start from the beginning again :-(

Ah well, it's worth it to get iPlayer back !

Incidentally, the display looks slightly different to the original version, e.g. the colours seem just *slightly* out, and it looks a bit too 'zoomed in'. Is there any chance this could be down the fix Buzz ? - or am I just putting the wrong set of specs on ? Big Grin
aneng Wrote:Will updating via SVN knacker your fix for iPlayer ?

Also... a note to anyone else about to delete the Udata and Tdata folders... that's where any game saves appear to be kept ! I was 2/3 the way through GTA Vice City and now I have to start from the beginning again :-(

Ah well, it's worth it to get iPlayer back !

Incidentally, the display looks slightly different to the original version, e.g. the colours seem just *slightly* out, and it looks a bit too 'zoomed in'. Is there any chance this could be down the fix Buzz ? - or am I just putting the wrong set of specs on ? Big Grin

the latest build of the xbox version is available at my link. I keep it updated occasionally. no idea about the colours. I can only think thats your settings. My modifications are only for the libRTMP streaming part.