Kodi Community Forum

Full Version: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
@gjlp

Nope tried everything you said. Does not work for me. I only get the 1500 stream even when setting says 3200k stream. I am in NJ on fios. And going through fios dns. I wonder if I should try another DNS. If possible can you tell me if it works for you using some public DNS like opendns. Also when it is working, at that time can you tell me what was your specific exit node on the tor?

I can get the hd stream through the browser, but not through XBMC. Through the browser I never get limelight requests, but either of Akamai or Level3. What is strange is Akamai refuses to work through XBMC for recorded streams. Bizzare.
@ developers,

Great work to get this going. Any possibility of Level3 support going back into the code? Should I just try to merge code from the last level 3 supported code with the present one? Or it ain't that simple?

It is just that I don't seem to get any 3200k streams through Limelight. And Akamai does not work for me either.
ndeshmukh Wrote:@gjlp

Nope tried everything you said. Does not work for me. I only get the 1500 stream even when setting says 3200k stream. I am in NJ on fios. And going through fios dns. I wonder if I should try another DNS. If possible can you tell me if it works for you using some public DNS like opendns. Also when it is working, at that time can you tell me what was your specific exit node on the tor?

I can get the hd stream through the browser, but not through XBMC. Through the browser I never get limelight requests, but either of Akamai or Level3. What is strange is Akamai refuses to work through XBMC for recorded streams. Bizzare.

Hmmm - I was just assuming I was receiving the 3200k stream because that's what I had selected in the options. I'll check later to confirm that is indeed what I'm receiving and get back to you with this and the other information you asked for.

What are your experiences with pausing/resuming? Do have the same issue as me?
there were a lot of changes at one point and i took the level3 code out. i guess i could revisit it, but right now it seems as though bbc are doing stuff again. i want to wait and see how things are in a week, if they have indeed changed some authentication stuff or not... they are doing changes certainly and from previous experience it's best to wait and see, and then modify once things seem sorted.

Bear in mind that there is a new v2 of the swf verification, in use by some streaming companies already (seesaw for example), and I fear the beeb may be moving to this too. and if they do, there won't be anything I can do certainly.
and just to add if anyone was unaware, the Dharma branch is broken for seeking in rtmp stream currently also...
(I've had a fair few reports of this)

http://trac.xbmc.org/ticket/10204
on Xbox build 36050 seems to be working great thanks (builds after that rumoured to have some problems, haven't tried).
I've not had time for a thorough check in the last few days. what with more serious issues like a non working light in the bathroom, and the old "paid work" thing.I did notice some videos not playing recently, and I thought to wait and see. I really lack the free time to be honest... such is life :/ Good that it works for you though smiff.
I cant even find the iPlayer app under video addons in Dharma 2. It was installed in 9.11 but dosent even show now!
ndeshmukh Wrote:@gjlp

Nope tried everything you said. Does not work for me. I only get the 1500 stream even when setting says 3200k stream. I am in NJ on fios. And going through fios dns. I wonder if I should try another DNS. If possible can you tell me if it works for you using some public DNS like opendns. Also when it is working, at that time can you tell me what was your specific exit node on the tor?

I can get the hd stream through the browser, but not through XBMC. Through the browser I never get limelight requests, but either of Akamai or Level3. What is strange is Akamai refuses to work through XBMC for recorded streams. Bizzare.

I checked last night -- the bit rate is showing as between 1-2 mb/s so I guess that means I'm only getting the 1500 kbps stream, even though I have 3200 Limelight selected and the picture quality looks impressive on my 43" LCD. I do use OpenDNS rather than the RoadRunner DNS. I'm not sure I follow your question re. the exit node on Tor. I'll look tonight and see if I can figure out what you mean.
joelang6126 Wrote:I cant even find the iPlayer app under video addons in Dharma 2. It was installed in 9.11 but dosent even show now!

you need to install it as an addon. see install.txt or use a version from hitchers addon repo.
Seems my playback problems were due to a wrong clock setting so getting out of date cached information. oops! Good old user error! Big Grin
If you use FireFox you really should give this a try...

http://forum.xbmc.org/showthread.php?tid...easemonkey

I have a patch which switches to JSONRPC instead of the deprecated HTTP API....

http://pastebin.com/hCrSNKLA
exobuzz Wrote:you need to install it as an addon. see install.txt or use a version from hitchers addon repo.

For all of us basic users out there can anyone explain how to do this please or point us in the right direction.
Have i killed this thread Huh
Hi, does this plugin work for Dharma 2?

I have tried to put the .ZIP File onto a memory stick and to install this onto XBMC Live 9.11 beta 2 and to no avail.

Any help at all would be greatly appreciated