Kodi Community Forum

Full Version: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
your build is from Jan 17 2011 which would be the first public release i guess, so if they have done something to fix this, it wouldnt be in your build.
ive had confirmation it is fixed in the atv2 branch from spiff

https://github.com/xbmc/atv2/commit/c296...e7ee43f1e1 https://github.com/xbmc/atv2/commit/53b0...120b429e55

so it's just a matter to wait until a new build is made.
exobuzz Wrote:ive had confirmation it is fixed in the atv2 branch from spiff

https://github.com/xbmc/atv2/commit/c296...e7ee43f1e1 https://github.com/xbmc/atv2/commit/53b0...120b429e55

so it's just a matter to wait until a new build is made.

I'll have a go at building my own build tomorrow to see if it fixed the iplayer problem… will let you know how i get on!!
Does any body suffer weird crashes when playback is paused or resumed?

I'm on Windows 7 64bit, and basically I get either a crash (app not responding) or sometimes I can repeatedly whack the X key and get it to stop playback - but then it will not play another video afterwards.

I can only trigger it using iPlayer, but the devs think it's an XBMC bug.

Here's the trac
http://trac.xbmc.org/ticket/11122

Cheers
I too have experienced crashes which occur mainly when trying to resume playback, had just assumed it was a problem similar to seeking in an encrypted stream (which was fixed). The easy fix for me is to login via SSH and issue a killall xbmc (Ubuntu 10.10, XBMCLive install).

Sometimes if I just leave it alone after a period of time the plugin ends, not sure if I have pressed stop or not at that point. Thinking about it I have also possibly experienced it with Navi-X but I'm really not sure. I am using a PVR development version so have never bothered filing a proper bug report because of the status of the version I'm using.
the pause functionality doesnt work on the xbox either. in our codebase we disable rtmp pause functionality (you can still pause but for only as long as the stream doesnt time out). I reproduced this problem on linux, but it was very hard to get it to freeze (took many attemps). Doesn't surprise me that windows has it too. I dont know whether the problem is in xbmc or the rtmp library though, or just the way it is integrated. Then again, ive not debugged it in detail either.
Just to confirm, this addon is now working on ATV2 using a build built from the latest releases on repo (librtmp enabled). Smile

So BBC iPlayer on Apple TV 2! Finally! Big Grin
I've updated my ATV2 to the unofficial build, but still cant get the iplayer plugin to work - what's your secret?

- SORRY -

Got it sorted now- had'nt installed it properly all along Sad
Okay, after a bit of work I think this is (just about) ready for prime time!

the iPlayer add-on is great, but choosing videos to play isn't the best UI. So i've been working on a way to leverage the BBC iPlayer website.

What I've come up with is a Firefox / Firefox Mobile addon that will allow you to select an iPlayer show and play it on your XBMC.

Installation Instructions
Okay, first off, this requires some changes to the xbmc iplayer plugin, as the current version doesn't support the JSON api.

I've put a modified version up on github:
https://github.com/AWilco/iplayerv2

You'll have to git clone, or download the files manually to your .xbmc/addons/plugin.video.iplayer/ folder

Once you've done this, you need the firefox plugin. This is available at
http://goo.gl/Zsa22

This plugin will work for Firefox or Firefox mobile.

Once you have installed the add-on you will need to go to the options page to set up some options.
These are:
Hostname: the IP/name of your xbmc server
Port: the port XBMC's network settings uses
Username/Password: the login details needed to authenticate with your XBMC server.

Once you have done this you can go to the iPlayer website, and when you choose a video you will see a "Play on XBMC" option. Click this and the show should start playing on your XBMC!

Notes
This is an initial alpha release. I've tested it with TV shows on the iPlayer website. Radio shows will NOT work (even though the button appears), and Live TV will NOT work (there is no button). I'll definitely look to work on this.

For those running Android, this will work (I have an android phone). When you visit the iPlayer website, the add-on spoofs the user-agent to make you look like an iPhone, allowing you to browse the site. You can't watch videos on the phone though.

Exobuzz: (I take it you're the dev of the iPlayerV2 plugin). You may have missed my post earlier in this thread, and not got to my issue. This is a further development of what I was doing there.

I've converted the add_programme function to return playable items. This causes XBMC to ask the plugin to resolve the plugin URL into a URL it can handle. You'll see that I've created a resolve_url function that takes over ?pid=xyz... calls and returns the URL of the file to XBMC. This I think is the "proper" way to do it, as it allows other methods of choosing a iPlayer video to work. I think this will also fix the bug some people have where their video only plays for a few seconds (I used to have that problem until I developed this).

I'd like to get this into the main iPlayerv2 plugin. I've also converted the radio and live tv functions to work in the same way. The source is available in the github link given above.

Also, the source of the firefox plugin is available at: https://github.com/AWilco/xbmciplayersender

If anyone does try this, please post any issues on this google code page:
http://code.google.com/p/songbird-telescope/
Which has turned into my catch-all development tracker for the moment.


Finally: I hope to write up a better guide, with pictures and stuff, over the next few days.

Enjoy! (at your own risk).
I did see it, but have not had a lot of time due to other projects. I do need to do some updates though, so hopefully i can get on it soon. If they look reasonable (im sure they are), and you have more, then we could look at giving you svn access. Thanks for the contributions.
I've also got the iPlayer working on ATV2 now. However once the video is playing the only button that seems to work on the remote is the menu button which stops the video. The play/pause button does not seem to work. I'm not sure if this is a XBMC issue or a iplayer issu. Does anyone have any suggestions.
This will be an XBMC issue. Once the video starts playing the iPlayer plugin is done and isn't running any more.
Can someone please explain how you install this plugin on the atv2. All instructions are for the atv1. Cheers.
exobuzz Wrote:You have installed it incorrectly (wrong name). Check the install instructions and install.txt alternatively you can install from hitcher's repository http://wiki.xbmc.org/index.php?title=Uno...positories

Ah, ok: I just installed it directly from the .zip within xbmc. Cheers bud.

...

Created the folder and put it in there now works great. THANKS
I've written some better instructions for my XBMC iPlayer Firefox plugin. Hopefully a bit easier to follow.

http://www.awilco.net/doku/xbmciplayer