Kodi Community Forum

Full Version: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!)
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Prof Yaffle Wrote:Folks -

Can I ask someone to do some testing for me, please... I'm getting corruption on HD videos (specifically, iPlayer HD) since the April build of XBMC PVR, and I'm struggling to isolate the fault. So I'd like to see if anyone else is running a comparable system and whether they see the same - or whether it's personal!

... <snip> ...

Does anyone have a similar system that they could perhaps test for me, please? Thanks in advance to any kindly victims/volunteers!

Anyone...? Anyone...? Bueller...?
Hi,

The video stream of my iPlayer plugin seems to stop after about 5 mins, but the audio continues. My TV just goes to a blue screen displaying its own "No input detected" message (i.e. the message is produced by the TV, not XBMC). The only way I seem to be able to regain any control of the system is to hit Ctrl+Alt+F1 to get to a terminal (at which point the display comes back to life), and then F7 to get back to XBMC.

A google search suggests that someone might have had this problem back in February 2010 and filed an Issue #10 on the googlecode page, but that link returns a 500 server error so I can't find any more details.
Would greatly appreciate some help fixing this. Not at home at the mo, so can't paste a log, but am hoping that someone already knows what the fix is.

I'm running Dharma Live on an ION-based Zotac ND-22.

Cheers.
Hi
I anyone else getting the following error :
Network Error. Failed to fetch URL http://feeds.bbc.co.uk/iplayer/bbc_one/list

From my log

iplayer2.py: INFO IPlayer: version: 2.4.12
01:24:01 T:1844 M:911687680 NOTICE: .
01:24:01 T:1844 M:911691776 NOTICE: iplayer2.py: INFO IPlayer: Subtitles dir: C:\Users\me\AppData\Roaming\XBMC\userdata\addon_data\plugin.video.iplayer\Subtitles
01:24:01 T:1844 M:911691776 NOTICE: .
01:24:01 T:1844 M:911683584 NOTICE: iplayer2.py: INFO (<iplayer2.feed object at 0x0A5ACE50>, 'list', None, None, None, None, None, None, None, None)
01:24:01 T:1844 M:911683584 NOTICE: .
01:24:01 T:1844 M:911683584 NOTICE: iplayer2.py: INFO Read RSS: http://feeds.bbc.co.uk/iplayer/bbc_one/list
01:24:01 T:1844 M:911683584 NOTICE: .
01:24:01 T:1844 M:911683584 NOTICE: iplayer2.py: INFO Feed URL not in cache, requesting...
01:24:01 T:1844 M:911683584 NOTICE: .
01:24:01 T:1844 M:911683584 NOTICE: Traceback (most recent call last):
01:24:01 T:1844 M:911683584 NOTICE: File "C:\Users\me\AppData\Roaming\XBMC\addons\plugin.video.iplayer\lib\iplayer2.py", line 161, in httpget
01:24:01 T:1844 M:911683584 NOTICE: resp, data = http.request(url, 'GET')
01:24:01 T:1844 M:911683584 NOTICE: File "C:\Users\me\AppData\Roaming\XBMC\addons\plugin.video.iplayer\lib\httplib2\__init__.py", line 1092, in request
01:24:01 T:1844 M:911626240 NOTICE: info = email.Message.Message()
01:24:01 T:1844 M:911626240 NOTICE: File "C:\Program Files\XBMC\system\python\Lib\email\__init__.py", line 79, in __getattr__
01:24:01 T:1844 M:911622144 NOTICE: __import__(self.__name__)
01:24:01 T:1844 M:911622144 NOTICE: ImportError: No module named message
01:24:06 T:1844 M:912150528 NOTICE: iplayer2.py: ERROR Network Error. Failed to fetch URL http://feeds.bbc.co.uk/iplayer/bbc_one/list
01:24:06 T:1844 M:912150528 NOTICE: .


I can get to http://feeds.bbc.co.uk/iplayer/bbc_one/list in a browser, have tried the same on 2 different machines (on the same network) wondered if anyone was getting the same error or if its something to do with my setup, I should mention its been working fine up until now!
lewis Wrote:Hi
I anyone else getting the following error :
Network Error. Failed to fetch URL http://feeds.bbc.co.uk/iplayer/bbc_one/list

I am getting the same error and just like you it works fine in firefox or IE. Not sure if I shuld post my log, so let me know if someone wants it.
Are you using nightly XBMC builds?
mortstar Wrote:Are you using nightly XBMC builds?

Yes but happy to try any version to get this working!
This plugin doesn't work with nightly builds of XBMC
mortstar Wrote:This plugin doesn't work with nightly builds of XBMC
Well that would explain it! Looks like I will have to wait till its updated Sad
Problems on Openelec and XBMC4Xbox too - streams only play for 20mins max then stop - if I get time at the weekend I'll debug and pastebin.
lewis Wrote:Well that would explain it! Looks like I will have to wait till its updated Sad

I think it's more XBMC than the plugin that's causing it.
bearing in mind, the plugin just sends a url to xbmc to play. anything after that is out of the plugins control. So if it starts playing then stops, it could be networking, compatibility with librtmp, or something related to xbmc, but nothing the plugin has control over.
Don't run nightly builds unless you are interested in testing bleeding edge stuff at the sake of other stuff not working. Certainly if you are running nightly builds, you should be aware of issues, and how to fix them etc.
exobuzz Wrote:Don't run nightly builds unless you are interested in testing bleeding edge stuff at the sake of other stuff not working. Certainly if you are running nightly builds, you should be aware of issues, and how to fix them etc.

Would have though that the whole point of this forum is to share these issues and especially any fixes that others may have to get things working as the builds progress through development. We all learn how to fix issues with the help of others, right!
it isnt particularly helpful to me, when a bug is reported regarding the iplayer, that is actually caused due to a change in xbmc that may be a temporary thing or not. Im not sure I follow your logic. I wouldnt recommend any use unfamiliar with the workings of xbmc to run daily builds. stuff breaks sometimes. sure its useful to give bug feedback regarding xbmc development, but thats not what im seeing on this thread, and the problem seems to be that users expect everything to work on the dev release, which of course it might not.
As you can see from http://trac.xbmc.org/ticket/11417 some functionality of new xbmc was only "confirmed" 2 weeks ago. I have actually fixed up the iplayer script before this but it is an example of when some behaviour can change and stop scripts from working during the development cycle.