Kodi Community Forum

Full Version: [OLD] HOW-TO watch Live TV in XBMC for Linux with Tvheadend, the easy way!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
In a few-days-time I've read all these posting (from this thread),
"[LINUX] HOW-TO watch Live TV in XBMC for Linux with Tvheadend, the easy way"
but couldn't not find;.....the easy way!

I read all these postings one by one.
I tried all the tips mentioned here and none of them works for me;
no connection to the server at htsp:/ipaddress:9982 as final result!

I have 2 Asrocks ION330 and 1 Tevii S660

So, on the other Asrock I install from ISO, yaVDR 0.30.a
and I'm on the right track, I search the yaVDR forums
and step-by-step I could tweak the right settings.

Finally I could watch my sat. channels!
XBMC giv's me LIVE-TV and it works just fine,
I can leave XBMC and jump to yaVDR and from yaVDR to XBMC
Make recordings, watch live TV, and play back.

Think, I wait for stable tvHeadend LiveCD, in the mean time I
stay with yaVDR.
like I said in my previous post, I'll make a new howto post that explains it all properly. didn't have time for it today, so I'll do it tomorrow.

all it takes to install tvheadend + xbmc is installing 2 packages from a ppa and a few actions to do the initial setup.
Actually, tvheadend is already installed in Dharma LiveCD. Not sure if it's the same build as yours, though.
Hi,

@ costi: Maybe you mean the Tvheadend Streaming Client embedded in the Dharma Release. The Tvheadend consits of an Streaming Server (the hts-tvheadend in the online repository) and a Client (add-on) installed in XBMC for receiving and displaying the Video-Stream from the TVheadend Server.

@all: Which Skins do actually Support proper LiveTV playback? And do I need a special patched Version of them?

regards, crasher
Hey guys,

I just got my asrock ion330 running dharma xbmc-pvr and tvheadend. I had it partially set up earlier in the year, but i botched the installation for something (forgot what), so I re-formatted. I've gotten all the channels to scan nicely and appear in xbmc with the tvheadend addon, but I have a few problems.

Whenever xbmc starts up, it'll say that it cannot connect to tvheadend. I fix that by disabling the plugin and re-enabling it, but my parents or sibling would not be able to do that if they want to record something.

Also, even though the EPG works perfectly, when I try to view a channel, i get an error saying that it cannot descramble the channels (i think this may be due to low signal strength, because it used to do this intermittently on the previous setup), or that it cannot connect or something similar (can't remember the exact error). I may try out a tv signal amplifier for this problem.

Anyone have any suggestions?
crasher2k Wrote:Hi,@all: Which Skins do actually Support proper LiveTV playback? And do I need a special patched Version of them?

regards, crasher
Hi as far as I know there are only two skins supporting the (tvheadend) PVR client: Confluenca (default skin) and SLik-pvr a skin for XBMC PVR branch,
But maybe others can add to this list.
regards,
Ruud.
because of some pc problems (caused by myself ofc Smile) the howto will be a day later.

@tominated
what's in the debug log?
dushmaniac Wrote:@tominated
what's in the debug log?

How would i find the debug log (i'm not too experienced with this sort of stuff)?
tominated Wrote:How would i find the debug log (i'm not too experienced with this sort of stuff)?

wait, i think i figured it out. I ran
Code:
tail /home/xbmc/.xbmc/temp/xbmc.log
and got the following:

Code:
12:11:01 T:139716519245568 M:1351548928   ERROR: PVR: Tvheadend HTSP Client/127.0.0.1:9982 - Client returns bad error (-3) after SignalQuality
12:11:01 T:139716508755712 M:1351548928   DEBUG: CGUIInfoManager::SetCurrentMovie(pvr://channels/tv/all/2.pvr)
12:11:02 T:139716519245568 M:1351794688   ERROR: PVR: Tvheadend HTSP Client/127.0.0.1:9982 - Client returns bad error (-3) after SignalQuality
12:11:02 T:139716508755712 M:1351794688   DEBUG: CGUIInfoManager::SetCurrentMovie(pvr://channels/tv/all/2.pvr)
12:11:03 T:139716519245568 M:1351802880   ERROR: PVR: Tvheadend HTSP Client/127.0.0.1:9982 - Client returns bad error (-3) after SignalQuality
12:11:03 T:139716508755712 M:1351802880   DEBUG: CGUIInfoManager::SetCurrentMovie(pvr://channels/tv/all/2.pvr)
12:11:04 T:139716519245568 M:1351802880   ERROR: PVR: Tvheadend HTSP Client/127.0.0.1:9982 - Client returns bad error (-3) after SignalQuality
12:11:04 T:139716508755712 M:1351802880   DEBUG: CGUIInfoManager::SetCurrentMovie(pvr://channels/tv/all/2.pvr)
12:11:05 T:139716519245568 M:1351802880   ERROR: PVR: Tvheadend HTSP Client/127.0.0.1:9982 - Client returns bad error (-3) after SignalQuality
12:11:05 T:139716508755712 M:1351802880   DEBUG: CGUIInfoManager::SetCurrentMovie(pvr://channels/tv/all/2.pvr)

I'm getting this after I used a signal amplifier, too.
tominated Wrote:How would i find the debug log (i'm not too experienced with this sort of stuff)?

The xbmc log is saving in the directory /home/xbmc/.xbmc/temp/ in your computer. The file is xbmc.log.

It would be more useful to people that could help you to put the COMPLETE log on pastebin (see http://en.wikipedia.org/wiki/Pastebin and http://pastebin.com/) and post in this forum the link to it.
Hi,

I'm trying dharma pvr from https://launchpad.net/~lars-opdenkamp/+archive/xbmc-pvr with tvheadend and I have to say I'm impressed, I've been trying new versions with all linux backends and this is the fastest and most stable, it didn't crash once even switching channels like a maniac (aka zapping)

Now I need commercial skipping (bad habit from mythtv) I use wine + comskip, the thing is that if I open the video through video explorer the EDL is loaded and respected, but according to the log, when I open the recording through PVR recordings there is no sign of loading and pressing 'o' show edl:- so no skipping. Is this expected or I'm doing something wrong?

I have also noticed that vaapi is compiled in and libva is kindly upgraded from lars ppa, but I'm unable to use it, XBMC crashes if activated, mplayer simply don't shows any video, I have an intel HD 4500, any one got VAAPI working with this card?
Hirs Wrote:Now I need commercial skipping (bad habit from mythtv) I use wine + comskip, the thing is that if I open the video through video explorer the EDL is loaded and respected, but according to the log, when I open the recording through PVR recordings there is no sign of loading and pressing 'o' show edl:- so no skipping. Is this expected or I'm doing something wrong?
Hi, comskipping via a EDL file that has the same name as the recording should work out-of-the box. as far as I know, no configuration needed.
Just curious, I never got comskip to properly detect the commercials on a tvheadend recording: 1 run the MKV through ffmepg to create a mpg file, run comskip over it, but every detected commercial is either to early or to late or not detected at all. When recording with MP (records into .ts files) comskip worked flawlessly (99%). So I stopped using comskip completely (I suspect that it is due to the MKV issues, running into them where I try to cut a recording, but avidemux is not able to properly cut / transcode without the sound going miles out of sync (have tried several programs ;( )

How do you use comskip (e.g. what settings etc.)

regards,
Ruud.
Ruud Wrote:Hi, comskipping via a EDL file that has the same name as the recording should work out-of-the box. as far as I know, no configuration needed.

How do you use comskip (e.g. what settings etc.)

EDL file has the same name as the recording, i.e. rec.mkv -> rec.txt, if this is implemented in PVR recordings is not working for me Sad

What do you mean with 'When recording with MP' is a tvheadend option? or MP stands for mplayer...?

So far, I have only tested with one recording, and actually is not very accurate, but I've seen you can do a lot of tuning in comskip.ini, there is also a forum to ask for help on this matter. I guess you should find the right parameters for the channels you watch, if you are lucky someone could have this settings already Smile
anyone get this working for DVB-S in North America?
Hirs Wrote:What do you mean with 'When recording with MP' is a tvheadend option? or MP stands for mplayer...?

So far, I have only tested with one recording, and actually is not very accurate, but I've seen you can do a lot of tuning in comskip.ini, there is also a forum to ask for help on this matter. I guess you should find the right parameters for the channels you watch, if you are lucky someone could have this settings already Smile
Sorry, bad habit to write MP when I actually mean MediaPortal Wink
MediaPortal records into a .ts file, that can be run straight into comskip. Default setting on comskip never missed a commercial, with tvheadend recording into .mkv is okay (although not suitable for timeshifting) but trying to convert is a real pain.... converting to another file always leaves me with 'bad format' messages and out-of-sync audio, I think that is where it goes wrong with comskip... stopped using it before version 2.12 was out, will try some test runs to see if something has changed with version 2.12, I know there has been a lot of discussion over at the tvheadend mailing list regarding 'mkv format issues', will report back here Wink
Maybe one of the devs is willing to have a look at how MediaPortal (also opensource) implemented the file format and recording... just to see what the difference is?
regards,
Ruud.