Kodi Community Forum

Full Version: [OLD] HOW-TO watch Live TV in XBMC for Linux with Tvheadend, the easy way!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
@tominated
what version of tvheadend are you running? if you posted the complete log (like vane.xbmc said) I wouldn't have had to ask you Smile
looks like tvheadend isn't reporting the signal status, which could indicate that you're running an old version.

@Hirs
I only enabled the compile options and added the dependencies on the ppa build. since I only got nvidia cards, I never tested vaapi. could you post a crashlog?
dushmaniac Wrote:@Hirs
I only enabled the compile options and added the dependencies on the ppa build. since I only got nvidia cards, I never tested vaapi. could you post a crashlog?

This is the log: http://pastebin.com/f9vQR9bh
And this what I get on the stderr:

/usr/bin/xbmc
Running DIL (3.6.0) Version
DtsDeviceOpen: Opening HW in mode 0
DtsDeviceOpen: Create File Failed
libva: libva version 0.31.1-sds1
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/va/drivers/i965_drv_video.so
libva: va_openDriver() returns 0
xbmc.bin: i965_avc_ildb.c:621: i965_avc_ildb_decode_init: Assertion `avc_ildb_context->urb.cs_start + avc_ildb_context->urb.num_cs_entries * avc_ildb_context->urb.size_cs_entry <= ((((&i965->intel)->device_id == 0x0042) || ((&i965->intel)->device_id == 0x0046)) ? 1024 : (((&i965->intel)->device_id == 0x2E02 || (&i965->intel)->device_id == 0x2E12 || (&i965->intel)->device_id == 0x2E22 || (&i965->intel)->device_id == 0x2E32) || ((&i965->intel)->device_id == 0x2A42)) ? 384 : 256)' failed.
Aborted (core dumped)

vlc was working with the ubuntu libva, now crashes just when it's about to show the video, but I would rather prefer xbmc with hw acceleration than vlc Smile

Seems like it can load the driver, but something dark happens right after, I can't figure out what's going on :/
Forgive me for asking if this has already been asked before, but the thread is 151 pages long already Smile

I currently own a VU+ DUO (call it a DreamBox 8000 clone) for watching TV. Is this TVHeadend on my XBMC (Core i3, NVIDIA GT425M, 4GB memory) a good replacement for my "DreamBox"? It will be connected with an EyeTV Sat.

Is it worth trying, or won't it be as good as a "Dreambox"?
does tvheadend pvr plugin support teletext?
dushmaniac Wrote:@tominated
what version of tvheadend are you running? if you posted the complete log (like vane.xbmc said) I wouldn't have had to ask you Smile
looks like tvheadend isn't reporting the signal status, which could indicate that you're running an old version.

Here's the xbmc.log file after I tested today: http://pastebin.com/10EyrH6N

I'm pretty sure tvheadend starts up a bit too slowly, because if i disable, then re-enable the plugin it doesn't error.

I'm pretty sure I'm running hts-tveadend 2.12.svn5683~odk1

Thanks heaps in advance
@dushmaniac, Are your dharma ppa compiled with crystalhd support? If not could you add this perhaps?

Also is the recordings button under live tv in xbmc supposed to work? I see whats recorded but i can't play anything.
@tominated:
I'm not seeing any received frames in your log. can you play channels if you access tvheadend using the video source (so not the livetv)?
video -> add source -> htsp://hostname:9981
if not, you should check the tvheadend log (which is outputed in /var/log/daemon.log)

@Hirs:
looks like ffmpeg and libva aren't being nice to each other. does vlc still work with the provided libva?

@Jaken:
don't think crystalhd is added. could have a look later.
playing recordings don't always work correctly, but that's a problem in tvheadend. since andoma is changing a lot in there for his v3, we'll have to wait till he's done.

@ErAzOr2k:
doesn't work at the moment. think the stream is identified incorrectly, but haven't looked into it yet.

@all:
I thought I had some software error before and that's why I didn't finish the new howto yet. Turned out to be hardware problems and it's fixed now. The new howto will be a little later (again Smile)
Hirs Wrote:This is the log: http://pastebin.com/f9vQR9bh
And this what I get on the stderr:

/usr/bin/xbmc
Running DIL (3.6.0) Version
DtsDeviceOpen: Opening HW in mode 0
DtsDeviceOpen: Create File Failed
libva: libva version 0.31.1-sds1
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/va/drivers/i965_drv_video.so
libva: va_openDriver() returns 0
xbmc.bin: i965_avc_ildb.c:621: i965_avc_ildb_decode_init: Assertion `avc_ildb_context->urb.cs_start + avc_ildb_context->urb.num_cs_entries * avc_ildb_context->urb.size_cs_entry <= ((((&i965->intel)->device_id == 0x0042) || ((&i965->intel)->device_id == 0x0046)) ? 1024 : (((&i965->intel)->device_id == 0x2E02 || (&i965->intel)->device_id == 0x2E12 || (&i965->intel)->device_id == 0x2E22 || (&i965->intel)->device_id == 0x2E32) || ((&i965->intel)->device_id == 0x2A42)) ? 384 : 256)' failed.
Aborted (core dumped)

vlc was working with the ubuntu libva, now crashes just when it's about to show the video, but I would rather prefer xbmc with hw acceleration than vlc Smile

Seems like it can load the driver, but something dark happens right after, I can't figure out what's going on :/

Try this:

Quote:Somehow xbmc looks for the libva libraries with the wrong filename, so i create symbolic links to the proper files.
sudo ln -s /usr/lib/libva.so.1 /usr/lib/libva-0.31.1.1.so.1
sudo ln -s /usr/lib/libva-glx.so.1 /usr/lib/libva-glx-0.31.1.1.so.1
Taken from: http://forum.xbmc.org/showthread.php?tid=86581
Why doesn't TVheadend find any HD channels? I'm on the sattelites Thor ans Sirius. Can any one help me if i am missing something. I get all the outer channels to work but i cant even see the HD ones.
post your tvheadend debug log (tvheadend started from the console).
without I can only guess:
- the subscription with your provider doesn't allow you to watch hd channels (aka I didn't pay)
- your cam is having problems decoding the stream
- etc.
@drago
Do you have a DVB-S2 capable tv card?
pucko Wrote:@drago
Do you have a DVB-S2 capable tv card?

Yes I have this one: DVBWorld HD 2104 FTA USB Box

And I have a dreambox where everything works so i dont think there is a problem with the card. Is there any reason i cant watch for example the channel U ether? it works on my dreambox but not with tvheadend. I think its a free channel.
@drago:
post the log I asked for in my previous post and I might be able to help. without it I can only guess.
Make sure your are picking the the right transponder settings in tvheadend, in particular delivery system and constellation as those two are sometimes different for HD channels.


Also install the s2-liplianin driver if its needed for your card and not installed already.

Installation guide from first page of thread:
hg clone http://mercurial.intuxication.org/hg/s2-liplianin
cd s2-liplianin
make
sudo make install
sudo reboot
dushmaniac Wrote:@drago:
post the log I asked for in my previous post and I might be able to help. without it I can only guess.

Where is the debug log located?