Kodi Community Forum

Full Version: [OLD] HOW-TO watch Live TV in XBMC for Linux with Tvheadend, the easy way!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi dushmaniac,
I already assigned 512MB to the graphic card.
And my chipset is listed. That is the weird thing here. I have vdpau working on my box. As I told you, when pressing the "o" I can see vdpau_vdpau and the CPU is so low that there must be a Hardware accelaration. I fear that you are running out of ideas as well Sad

I have on more option. I have another Board (ASRock ION). Do you think or better know that there is a option for the VDPAU temporal?

And just for clarification if we are talking about the same thing.
What I've been looking for is a option when pressing "M" during playback, go to the video settings and change the selection in "interlaced handling". Here a option "(VDPAU) temporal" should be available. Correct?

I am really getting mad here. Why is it nor working. Grrr.
dushmaniac Wrote:I'm cleaning it all up after the new howto is ready, maybe create a separate forum section for pvr.

A forum section for PVR is a must, this thread is way too long!
mw0208 Wrote:Hi dushmaniac,
I already assigned 512MB to the graphic card.
And my chipset is listed. That is the weird thing here. I have vdpau working on my box. As I told you, when pressing the "o" I can see vdpau_vdpau and the CPU is so low that there must be a Hardware accelaration. I fear that you are running out of ideas as well Sad

I have on more option. I have another Board (ASRock ION). Do you think or better know that there is a option for the VDPAU temporal?

And just for clarification if we are talking about the same thing.
What I've been looking for is a option when pressing "M" during playback, go to the video settings and change the selection in "interlaced handling". Here a option "(VDPAU) temporal" should be available. Correct?

I am really getting mad here. Why is it nor working. Grrr.

Hi mw0208.
What content do you play. Is SD or HD. I have several ION systems at my house and I can say that no one is working on 1080i video and Temporal deinterlacer. Try to select the Auto - ION Optimized one and see if this helps.

You can also try to set Half deinterlacers and see if that helps.
I'm having an issue with the tvguide in timeline mode while using the master repo, latest build:
It does not show wether a program will be recorded or not.
Is this a bug?
probably. stay away from "master" if you're not developing
I mapped some channels, so I had like 7XX channels. It worked fine. Then the other day I started a full channel mapping, and let it go it's course, so I ended up with 8XX channels. Now I get an message instantly when I click on a channel: "channel can not be played".

DEBUG: AddOnLog: xbmc.pvrclient/Tvheadend HTSP Client: Connect - connected to server: [HTS Tvheadend], version: [git-114ac7c], proto: 5
ERROR: AddOnLog: xbmc.pvrclient/Tvheadend HTSP Client: ReadResult - maximum queue size (1000) reached

Can it be that when I reach a certain amount of channels, it will flood with more messages than the queue has capacity for?

I have tried both dharma and master ppas with the same result. Worked with less amount of channels before. I will try to delete like half and try again tomorrow!
hmm. could be because too many data (channel entries etc.) is received before it's being processed, because that data is sent right after connecting to the tvheadend backend if I'm correct.

Removing some channels should be a workaround.

Please post a ticket on trac for this issue with the full xbmc debug log.
I also suspected this, and we were right.
Increasing the queue size worked. I increased it to 6000 in HTSPSession::HTSPSession(). used this git rep: https://github.com/opdenkamp/xbmc

I was told it sends a message per channel, so the queue size should be as large as the potential or actual number of channels. Or it should take message by message and reduce the queue. Smile I also sends a bunch of other messages as well, since it stopped working well under 1000 (8XX).

UPDATE: I now run the dharma ppa, and I just copied my newly compiled addon to /usr/lib/xbmc/addons/pvr.hts. SUCCESS

Btw, is there a way to apply deinterlacing settings on ALL tv channels (not all videos in general) ?
Hello all,

Someone could tell if it's possible to use a Dreambox or an Azbox with XBMC + Tvheadend?

Thanks
hi all,
can somebody explain me in two words how can i watch live tv.
i have xbmc linux. now i can watch iptv using vlc udp://@212.24.0.1:3000
how can i do it using xbmc!
thanks
Does anyone have issue with Tvheadend [I've tried both v2.11 and v2.12] loosing access to encrypted channels following a reboot?

I am using Ubuntu 10.04 and I find that after a reboot, I change to an encrypted channel and Tvheadend states that it is trying to obtain the key.

If I delete the Multiplexes, let them rescan, then remap the channels.

Has anyone else noticed the same or a similar issue? I've had to rebuild my HTPC a few times recently and I've done a full clean install of Ubuntu but the issue still remains the same.
hi again,

created m3u file and typed there folowing
(
#EXTM3U
#EXTINF:0,1 EuroNews
udp://@224.12.0.1:3000)

can see now iptv channels but channel switching is too slow.
with vlc it takes about 1 sec with xbmc takes 3-4 second.
as i understood this way of watching tv is not quite right so it might be there is some plugin or soft which allow to watch iptv in xbmc.


dmankg Wrote:hi all,
can somebody explain me in two words how can i watch live tv.
i have xbmc linux. now i can watch iptv using vlc udp://@212.24.0.1:3000
how can i do it using xbmc!
thanks
AP0ll0UK Wrote:Does anyone have issue with Tvheadend [I've tried both v2.11 and v2.12] loosing access to encrypted channels following a reboot?

I am using Ubuntu 10.04 and I find that after a reboot, I change to an encrypted channel and Tvheadend states that it is trying to obtain the key.

If I delete the Multiplexes, let them rescan, then remap the channels.

Has anyone else noticed the same or a similar issue? I've had to rebuild my HTPC a few times recently and I've done a full clean install of Ubuntu but the issue still remains the same.

same issue here since today :/
AP0ll0UK Wrote:Does anyone have issue with Tvheadend [I've tried both v2.11 and v2.12] loosing access to encrypted channels following a reboot?

I am using Ubuntu 10.04 and I find that after a reboot, I change to an encrypted channel and Tvheadend states that it is trying to obtain the key.

If I delete the Multiplexes, let them rescan, then remap the channels.

Has anyone else noticed the same or a similar issue? I've had to rebuild my HTPC a few times recently and I've done a full clean install of Ubuntu but the issue still remains the same.

Can anyone suggest HW and SW to encrypt channels. I have no experience of soft cams.
Gujs Wrote:Hi mw0208.
What content do you play. Is SD or HD. I have several ION systems at my house and I can say that no one is working on 1080i video and Temporal deinterlacer. Try to select the Auto - ION Optimized one and see if this helps.

You can also try to set Half deinterlacers and see if that helps.

Hi gujs,

thanks for your reply. That's also my experience and it seems that the interlacer in XBMC with VDPAU seem to be the real problem. Is that right?
I found a post in a german vdr board. The guy there mentioned that the "Deinterlace Skip Chroma" option is not implemented in XBMC.
Is there a developer who can confirm that or not. The guy said, that after he implemented it the quality was much better and there was no more juddering. Unfortunately I don't know how. He attached a diff file as a patch.