Kodi Community Forum

Full Version: [OLD] HOW-TO watch Live TV in XBMC for Linux with Tvheadend, the easy way!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi.

No, it does not working too.

Here some output from CCcam:

Code:
[email protected]:/usr/local/bin# LD_PRELOAD=./capmt_ca.so ./cccam -d
20:37:42.236 CCcam: ======================================================================
20:37:42.236 CCcam: starting CCcam 2.1.0 compiled on Mar 19 [email protected]:46:46
20:37:42.236 CCcam: ======================================================================
20:37:42.236 CCcam: online using nodeId 3826e04db8bb6bc1
20:37:42.237 CCcam: DM8000 detected
20:37:42.237 CCcam: create 8 cam device(s)
20:37:42.237 CCcam: readKeyfile: cannot open /var/keys/SoftCam.Key or not found
20:37:42.237 CCcam: readKeyfile: cannot open /var/keys/AutoRoll.Key or not found
20:37:42.238 CCcam: static cw not found or bad
20:37:42.238 CCcam: parsed 0 entries from /var/etc/CCcam.prio
20:37:42.239 CCcam: added 510 provider names from /var/etc/CCcam.providers
20:37:42.239 CCcam: added 4 channel names from /var/etc/CCcam.channelinfo
20:37:42.239 CCcam: server started on port 12000

this execute creates 2 files in tmp directory.
-/tmp/.CCcam.nodeid*
-/tmp/cpuinfo

but there isn't a file camd.socket in tmp directory.

Do i need to perform some requirements before i start CCcam?

@mason
can you send me a download link of your cccam (via pm), maybe i use wrong version of CCcam?
Try using the guide moontan77 wrote on page 36 of this thread, that works very well.
The only version of cccam that works directly for me is 2.0.9
It is best to use the oscam guide he wrote on previous page as it works much better with tvheadend.
HI,

i solved my problem.

The config file CCcam.cfg must contain following line

DVB API: 3

by DVB API: 0 the socket file /tmp/camd.socket will not created.

i have tested with CCcam 2.1.2 and it works.
damn youre right, i recall now i struggled there too ...

problem with the linux stuff is once you got it you never need it.. so if you don't write it down your back to square one if you need it again. LOL
Hi guys !

I have great news ! Check this out: Smile

http://trac.xbmc.org/changeset/30037

Really great thanks to Developer Topfs2 !!!

I think we should donate...
alanwww1 Wrote:Hi guys !

I have great news ! Check this out: Smile

http://trac.xbmc.org/changeset/30037

Really great thanks to Developer Topfs2 !!!

I think we should donate...


Nod

Yes, great news!!!

I can not wait to try it. Hopefully soon to be included in the Gujs PPA.

Thanks to all the people who makes XBMC and its addons posible.
which version of tvheadend are people using?

I am trying 2.11 with todays xbmc 30050 and having trouble setting recordings via xbmc.

it works well watching tv and the channel change is super fast.
I have the same issue with start recording. This is from log:
Code:
20:21:41 T:140269502900256 M:2463449088   ERROR: PVR: Tvheadend HTSP Client/192.168.0.180:9982 - Client returns bad error (-2) after AddTimer

And channel change is not working very good for me. I use DVB-S/S2 and I have a lot of different channels with different video and audo codecs inside. I was investigating the problem last night, but I still didn't find how to fix this. It looks like xbmc sometimes doesn't know which part of stream is audio and which video. That is why sometimes after channel change just audio is played or just nothing at all.

I will try to add new xbmc to my ppa today, but please wait with upgrade before I tell you gujs that it is good. I ask you this because debian packaging for xbmc was changed. And I would like to investigate it first if upgrade works OK.

If somebody knows PVR Client infrastructure here, please PM me for help about channel change problems. I saw in vdr VNSI plugin that after every channel change, a packet with stream changed information is send to player, but it didn't make any difference, when I tried this with tvheadend plugin.

EDIT: I went through code and I thing that adding recording through xbmc is not included yet. From code:
Code:
PVR_ERROR AddTimer(const PVR_TIMERINFO &timerinfo) { return PVR_ERROR_NOT_IMPLEMENTED; }
Yep only browsing and watching of already recorded movies are implemented with today's commits. No scheduling by xbmc is supported yet. Sad

Let's hope it will be some time
With current pvr-testing2 and current tvheadend, i cant even use the pvr client at all.
Code:
23:44:25 T:139821369096256 M:738340864   ERROR: AddOnLog: pvrclient/Tvheadend HTSP Client: cHTSPSession::Open - failed to connect to server (The specified host is unknown)
23:44:25 T:139821369096256 M:738340864   ERROR: ADDON: Dll Tvheadend HTSP Client - Client returned bad status (1) from Create and is not usable
23:44:25 T:139821369096256 M:738340864    INFO: Called Add-on status handler for '1' of clientName:Tvheadend HTSP Client, clientID:pvr.hts (same Thread=no)
Thats all i get. I tried using hostname and ip-address, both of which are resolvable.
But i CAN watch tv by adding an htsp://hostname-Source so my Videos, so there should be absolutely no problem connecting whatsoever.
You should manyualy edit tvheadend addon settings.xml. Because IP is not saved corectly. You can find it in .xbmc/userdata/addon_data/hts*******/settings.xml
Hey, i thought i tried that already, but obviously i didn't. Works now. Thanks Smile
I guess since the hostname of my server has a "-" in it, the problem there was probably the same.
Gujs Wrote:I have the same issue with start recording. This is from log:
Code:
20:21:41 T:140269502900256 M:2463449088   ERROR: PVR: Tvheadend HTSP Client/192.168.0.180:9982 - Client returns bad error (-2) after AddTimer


EDIT: I went through code and I thing that adding recording through xbmc is not included yet. From code:
Code:
PVR_ERROR AddTimer(const PVR_TIMERINFO &timerinfo) { return PVR_ERROR_NOT_IMPLEMENTED; }


Sad We will have to wait a bit more for the full recording function but at least there is progress. Smile

Gujs Wrote:I will try to add new xbmc to my ppa today, but please wait with upgrade before I tell you gujs that it is good. I ask you this because debian packaging for xbmc was changed. And I would like to investigate it first if upgrade works OK.

Today I have tried to install the XBMC in a 64bits machine from the repo but it fails. I supose that it fail because the changes that you have comented above. Do you think that will be operative again soon?
What version of ubuntu did yo use? If you have 9.10 than it should work. And it would be great if you paste an error here, I would like to see what went wrong.
Hello, I have a problem with tvheadend and a Hauppayge HVR-4000 multi frontend card.
In fact tvheadend find the /dev/adapter0 but only the frontend0, not the frontend1
frontend0 is for DVB-S/S2 and frontend1 is for DVB-T.
so I added a link to simulate another adapter (ln /dev/adapter0/frontend0 /dev/adapter1/frontend0) and I have the following error message:

[ALERT]:dvb: Unable to open /dev/dvb/adapter1/frontend0 -- Device or resource busy

If I rename adapter0 to adapter1 and adapter1 to adapter0 my frontend DVB-T is recognized and the DVB-S one is busy !!!

Please could you help me.
Thanks.