Kodi Community Forum

Full Version: [OLD] HOW-TO watch Live TV in XBMC for Linux with Tvheadend, the easy way!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm running all the latest builds from Gujs PVR Testing repository and XBMC keeps crashing and restarting. In the last hour or so whilst watching TV using TVHeadend it's happened about 5 times. Any idea why? Maybe a new build of XBMC would be a way to fix it?!

System:

Asus eeeBox EB1501 (Atom 330 - ION - 2GB)
Ubuntu Karmic

XBMC : 30746
TVHeadened : r4829

Also, the plugin page on XBMC isn't working with this build.
same thing happens me with all the recent builds, probably due to the pvr integration still being in development.
Hey alanwww1.
I would really like to try your hack but cant seem to find my location of this.

In xbmc svn dir:

nano xbmc/cores/dvdplayer/DVDCodecs/Video/DVDVideoCodecFFmpeg.cpp

this seems to be my homedir (T: XBMCLive)[email protected]:/home/xbmc#
Any idea where to find it.
using a live version, not the latest. Think its 9 something.
Thanx in advance
Diddleydoo
Diddleydoo: I am fairly sure that patch is only for people who compile their own xbmc. You will need to checkout the source, apply the patch, compile, then install.

Thanks for the hack alanwww1. I am compiling a version now to try out.
Ok bluecop.
then i think i wait a bit more. sounds bit advanced. took me sometime to get my remote for my asus pundit to work so i dont wanna mess anything up if im not sure that it will work.

btw is it possible to get teletext subs to work with tvheadend?
i think teletext isnt working at all atm
I have an issué that i think is coming from XBMC itself : in France somebody had the good idea to change the sound codec for Digital HD Channel : channels use AC3+ ...
So i have no sound with xbmc trunk svn or with XBMC PVR.

I made other tests with VDR VNSI & Streamdev : same thing => no sound but VDPAU Smile
nunu Wrote:I have an issué that i think is coming from XBMC itself : in France somebody had the good idea to change the sound codec for Digital HD Channel : channels use AC3+ ...
So i have no sound with xbmc trunk svn or with XBMC PVR.

I made other tests with VDR VNSI & Streamdev : same thing => no sound but VDPAU Smile

Have you tried to play it back from a recorded file ?

Maybe you AV receiver does not support the decode of this format. In this case you can try to untick the "AC3 capable receiver" option in xbmc settings. This way xbmc will decode the stream and at least you can play it in stereo. If by any chance your AV receiver suppors analog multichannel or HDMI multichannel connection, you can even enjoy the stream in 5.1.
thanks alot a with make the test.
My AV receiver is an Hauppauge WinTV-NOVA-TD-500

thanks
New version is up. You can set Force VDPAU from plugin configuration.
perfect! just in time for the World Cup! Wink i'm gonna give it a shot! thanks for the good work!

[Edit]
Works perfectly!
superb.
Right im gonna reload my machine and load this version on. whats the best version of ubuntu to run it on. Lucid?? 32 or 64 ??
running a Zotac ION board.
Cheers
nunu Wrote:thanks alot a with make the test.
My AV receiver is an Hauppauge WinTV-NOVA-TD-500
thanks

Sorry, but the NOVA card is not your AV reciver. That's your TV card. I am talking about your amplifier (or in case the media center is directly connected to your TV it is actually your TV)
Gujs Wrote:New version is up. You can set Force VDPAU from plugin configuration.

Thanks a lot for the great work. You did a really great job.

Thx
oula !!!
Thanks alot !!!